nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Installing nForce drivers on Debian 3.0 (http://www.nvnews.net/vbulletin/showthread.php?t=1830)

Doink 09-14-02 01:14 AM

Installing nForce drivers on Debian 3.0
 
I'm having problems installing the nvnet and nvaudio drivers on Debian 3.0. I downloaded the source and it compiles fine. The problem occurs when I try to run 'make install', after which I receive the following errors:

*** Unresolved symbols in /lib/modules/2.4.19/kernel/drivers/net/nvnet.o
*** Unresolved symbols in /lib/modules/2.4.19/kernel/drivers/net/nvnet.o~
*** Unresolved symbols in /lib/modules/2.4.19/kernel/drivers/sound/nvaudio.o
*** Unresolved symbols in /lib/modules/2.4.19/kernel/drivers/sound/nvaudio.o~

I've compiled my own 2.4.19 linux kernel and I've verified that I'm running the new kernel. I saw the other threads where people were having the same problems and I tried symlinking /usr/include/linux with the directory the 2.4.19 kernel sources are located at, but it doesn't resolve the errors. Does anyone have any suggestions? Do I need to set something special in the linux kernel config in order to get it to interface nicely with the nForce drivers?

Andy Mecham 09-14-02 02:07 AM

Unresolved symbols are usually caused by a mismatch between your running kernel and your kernel sources. Can you verify that your kernel source configuration exactly matches your running kernel?

--andy

Doink 09-14-02 11:05 AM

How exactly would I go about making sure that my kernel headers match the running kernel? I downloaded the latest 2.4.19 kernel from kernel.org, decompressed it into /usr/local/src/linux-2.4.19 and symlinked /usr/src/linux to that directory. I reconfigured and compiled the kernel (and it's modules) and rebooted with the new kernel.

Attempting to run 'make install' on the nforce motherboard drivers results in the same unresolved symbols error.

Any suggestions?

Thanks!

Doink 09-14-02 11:19 AM

Ironically, if I type "insmod nvnet" at the command line it seems to install without problems. I haven't tried configuring the ethernet at all after installing the nvnet module though. If I try to run 'insmod nvaudio' it says the unresolved symbol is:

ac97_probe_codec_R84601c2b

Do I need to set something special in the kernel config? Also, I'm puzzled as to why the nvnet driver has unresolved symbols when I try to run 'make install' in the nforce directory but when I insmod the nvnet driver it installs without complaints. Any ideas?

Doink 09-14-02 09:34 PM

Okay, I got the audio working. For everyone out there having problems installing the nvaudio driver here's what I did:

when I recompiled the kernel, I enabled sound support and included the EMU10k1 drivers (this handles the ac97_probe_codec_R84601c2b unresolved symbol). I guess nvaudio somehow relies on the EMU10k1 drivers somehow?

Anyways, then I had to chmod 666 /dev/dsp, /dev/mixer, and /dev/audio

After following those steps I was able to listen to a couple MP3's with XMMS :-)

However, I'm still unable to get the nvnet driver to work properly. If I insmod nvnet, the nvnet driver gets loaded without complaining but it still doesn't seem to be working correctly. For some reason I'm unable to lease an IP address through dhcp-client. Also, running depmod after nvnet is loaded results in 4 unresolved symbol messages:

*** Unresolved symbols in /lib/modules/2.4.19/kernel/drivers/net/nvnet.o
*** Unresolved symbols in /lib/modules/2.4.19/kernel/drivers/net/nvnet.o~
*** Unresolved symbols in /lib/modules/kernel/drivers/net/nvnet.o
*** Unresolved symbols in /lib/modules/kernel/drivers/net/nvnet.o~

Is there any way to determine what the unresolved symbols are? Perhaps if I can figure out what the unresolved symbols are, I might be able to modify my kernel config settings to get it working (like I did with the nvaudio driver).


All times are GMT -5. The time now is 02:25 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.