nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   pixel wraparound, DVI, FX 5600 and 1.0-4496 (http://www.nvnews.net/vbulletin/showthread.php?t=18306)

devurandom 09-19-03 01:31 PM

pixel wraparound, DVI, FX 5600 and 1.0-4496
 
Hey gang. I just built a new system using a ASUS V9560 / NVidia FX 5600 GPU. The card offers dual DVI outputs on the back. So far everything is pretty awesome. The drivers went in easy and everything works great except for one little thing:

In my prefered video mode, 1600x1200, I have two columns of pixels on the right hand side of the screen that belong on the left hand side and one row down. It's almost as if the hsync is coming late and not in sync with the draw. The problem exists only when using DVI and the NVidia provided driver. The probelm does not exist when using analog or when using the XFree86 "nv" driver (analog or DVI).

I've tried all kinds of things, like moving the hsync pulse in the mode line, changing clock rates, pulse widths, etc with no luck. The problem does go away though in some video modes, namely:

"1600x1200" yes
"1400x1050" yes
"1280x1024" no
"1280x960" no
"1152x864" yes
"1024x768" no
"800x600" no
"640x480" no

When testing these modes, my virtual desktop was still 1600x1200, and the pixel wrap-around still occured relative to the panel, not the virutal desktop (ie: was still visible). The wrap-around is likewise _always_ two physical pixels on the panel (interesting eh? Is the video card doing the scaling to 1600x1200 or the panel?). Wrap around does not occur in text modes.

If it weren't for the fact that it works fine with the same video modes using the XFree86 nv driver, I would think it to be a problem on the panel side.

Anyway, other info:

Video Card: Asus V9560 (GeForce FX 5600) w/ 128MB, dual dvi out, and S-video in/out, AGP.
Driver version: 1.0-4496
OS/Distro: RHL9 running self-compiled 2.4.22 SMP kernel
Video BIOS: 04.31.20.28.00
Processor: P4-3.0GHz w/ hyper threading
Motherboard: SOYO P4I875P Dragon 2 Platinum edition
Panel: Planar PL201M 20.1" 1600x1200 w/ DVI and analog

... and no, I'm not overclocking anything. :)

concatenated XF86Config and XFree86 log attached.

- Dave

P. S. The fact that NVidia has drivers for Linux rocks. Thanks for the great work!

devurandom 09-28-03 07:53 PM

Oops!
 
1 Attachment(s)
You know... I think my attachments got dropped. Here's my configs again... Anyone have any ideas? -- Also, as an FYI, I've tried upgrading to rawhide's 4.3.0-33 as well as downgrading to RHL 8's 4.2.0 versions of X with no change...


All times are GMT -5. The time now is 02:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.