nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia 173.14.35: Fedora 17 x86 terribly slow (http://www.nvnews.net/vbulletin/showthread.php?t=183079)

Mr Wolf 06-08-12 02:37 AM

Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
3 Attachment(s)
My graphic card is a Nvidia GeForce FX 5600XT (GPU: NV31) and Fedora 17 32 bit (kernel 3.4.0-1.fc17.i686.PAE) is running on my system (here is my hardware profile).

I installed the 173.14.35 release of the Nvidia drivers (i.e. xorg-x11-drv-nvidia-173xx-173.14.35-1.fc17.i686 from the RPM Fusion updates-testing repository, along with akmod-nvidia-173xx-173.14.35-1.fc17.i686, kernel-PAE-devel-3.4.0-1.fc17.i686 and dependencies).

After a reboot, the Nvidia drivers were enabled (since Gnome Shell started, whereas, with the open source Nouveau drivers, Gnome 3 fallback mode was starting instead).
But now the system is terribly slow: it takes something about 15 - 20 seconds to respond to commands (e.g. to open a new window, to react after clicking a button or pressing a key etc.); on the contrary, by the way, the mouse arrow behaves correctly and moves smoothly.
I tried to configure the drivers through nvidia-xconfig and nvidia-settings, but no improvements.

Attached are some (hopefully useful) logs and my xorg.conf (renamed to xorg.conf.txt, as it looks like uploading files with the ".conf" extension is not allowed).

Thank you in advance.

P.S.: I'll upload nvidia-bug-report.log as soon as I get back home.

kwizart 06-08-12 04:03 AM

Re: Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
Please attach the full output of nvidia-bug-report.sh

Please delete the spurious Files section in your xorg.conf
-----
Section "Files"
EndSection
----

Mr Wolf 06-08-12 04:51 PM

Re: Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
1 Attachment(s)
Quote:

Originally Posted by kwizart (Post 2562088)
Please attach the full output of nvidia-bug-report.sh

nvidia-bug-report.log is inside the archive which is attached to this message.

By the way, top reports that the gnome-shell process always takes up almost 100% CPU.

Mr Wolf 06-11-12 04:48 AM

Re: Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
Note that in Gnome 3 Fallback Mode everything runs smoothly with no lags at all. Only in Gnome Shell the system responds with such a lag that it is almost unusable (this being related to the fact that the gnome-shell process takes up almost 100 % CPU).
I also tried to replace the xorg.conf generated by nvidia-xconfig with that created through Xorg -configure, but nothing changed.

Any news/suggestions by you?

sandipt 06-13-12 04:31 AM

Re: Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
Tested with 295.59 ?

leigh123linux 06-13-12 04:54 AM

Re: Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
Quote:

Originally Posted by sandipt (Post 2563512)
Tested with 295.59 ?


His card (FX series) is only supported by the legacy 173xx driver!!
I have tested the 295.59 driver with my GT450 (fermi) and gnome-shell works as expected (Fedora 16 & 17).

Dragoran 06-13-12 06:02 AM

Re: Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
http://www.nvnews.net/vbulletin/show...10#post2498210

Mr Wolf 06-15-12 01:25 AM

Re: Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
Quote:

Originally Posted by kwizart (Post 2562088)
Please attach the full output of nvidia-bug-report.sh

Quote:

Originally Posted by Mr Wolf (Post 2562211)
nvidia-bug-report.log is inside the archive which is attached to this message.

I did what I was asked to.
Any news by you? What's next?

AaronP 06-15-12 02:20 PM

Re: Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
Is this a regression from older 173.14.* releases?

Mr Wolf 06-15-12 04:42 PM

Re: Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
Quote:

Originally Posted by AaronP (Post 2564268)
Is this a regression from older 173.14.* releases?

I don't know, since I had never installed the Nvidia drivers before release 173.14.35 on my system.

Dragoran 06-16-12 02:55 AM

Re: Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
Quote:

Originally Posted by AaronP (Post 2564268)
Is this a regression from older 173.14.* releases?

No. This a bug that has only been fixed in the newer branches (i.e non legacy drivers) see my discussion with Plagman here: http://www.nvnews.net/vbulletin/show...10#post2498210

Mr Wolf 06-17-12 12:52 AM

Re: Nvidia 173.14.35: Fedora 17 x86 terribly slow
 
Quote:

Originally Posted by Dragoran (Post 2564456)
This a bug that has only been fixed in the newer branches (i.e non legacy drivers)

And is this issue expected to be fixed in the 173.* drivers, too?


All times are GMT -5. The time now is 08:29 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.