nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   RedHat9 2.4.20-20.9 (http://www.nvnews.net/vbulletin/showthread.php?t=18416)

Wade777 09-21-03 04:13 PM

RedHat9 2.4.20-20.9
 
Ok, I think i've done everything that has been mentioned in previous threads (I have been searching through many of them). Let me walk you through what ive done... I still get an error.
1. Installed the kernel-source for 2.4.20-20.9 (i386)
2. Ctrl + Alt + F1'd
3. Ran telinit 1
4. Logged on as root
5. Used the command "sh /home/wade/NVIDIA-Linux-x86-1.0-4496-pkg2.run --kernel-include-path=/usr/include/"
6. Accept agreement etc.. then get error
Here is my log file: (800 lines so im only going to post the beginning and end)
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sun Sep 21 15:49:34 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : /usr/include/
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
ERROR: Unable to connect to download.nvidia.com (temporary DNS error (try again
later))
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Using the kernel include path '/usr/include/' as specified by the
'--kernel-include-dir' commandline option.
-> Kernel include path: '/usr/include/'
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f nv.o os-agp.o os-interface.o os-registry.o nv-linux.o nv_compiler.h *
.d NVdriver nvidia.o
-> Building kernel module:
executing: 'cd ./usr/src/nv; make nvidia.o SYSINCLUDE=/usr/include/'...
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > nv_compiler.h
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -
DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D_
_KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVE
L=4496 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -I. -I/us

/include/ -Wno-cast-qual nv.c
In file included from /usr/include/linux/tqueue.h:18,
from nv-linux.h:69,
from nv.c:14:
/usr/include/asm/bitops.h:327:2: warning: #warning This includefile is not a
vailable on all architectures.
/usr/include/asm/bitops.h:328:2: warning: #warning Using kernel headers in u
serspace: atomicity not guaranteed
In file included from nv-linux.h:69,
from nv.c:14:
/usr/include/linux/tqueue.h:94: parse error before "tqueue_lock"
In file included from nv.c:14:
nv-linux.h:72:75: linux/vmalloc.h: No such file or directory
In file included from /usr/include/linux/fs.h:23,
from /usr/include/linux/capability.h:17,
from /usr/include/linux/binfmts.h:5,
from /usr/include/linux/sched.h:9,
from /usr/include/linux/delay.h:12,




------------END---------------
nv.c:2816: `jiffies' undeclared (first use in this function)
nv.c: In function `nv_stop_rc_timer':
nv.c:2827: `nvl' undeclared (first use in this function)
nv.c:2827: parse error before ')' token
nv-linux.h: At top level:
nv-linux.h:554: storage size of `rc_timer' isn't known
nv.c:157: storage size of `nv_fops' isn't known
nv.c:1079: storage size of `nv_vm_ops' isn't known
make: *** [nv.o] Error 1
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
-----------------------------------------------------
Any help?
Thanks a lot! I'm still very new to the whole linux thing :)

djmuk 09-21-03 09:14 PM

I installed them on RH9 today with no problems at all.

Here's my procedure:
- Upgraded kernel (rpm -ivh filename.rpm).
- Rebooted, because there's a new kernel to log into at bootup.
- Installed XFree86 4.3.0 'X' drivers.
- Installed Nvidia drivers:

1.) Editted my /etc/inittab file and changed the init value from "5" to "3".
2.) CTRL+ALT+BACKSPACE to get to command line.
3.) Logged in with root.
4.) "sh /home/myname/NVIDIA-Linux-x86-1.0-4496-pkg2.run"
5.) Followed the on-screen instructions and all was done.
6.) Re-editted /etc/inittab from "3" to "5".
7.) Editted /etc/X11 and changed "nv" to "nvidia".

All sorted. The full instructions are on Nvidia's site, but the above is what I did and all was well.

bitterjack 09-21-03 11:30 PM

RH kernel 2.4.20-20.9 DOES NOT update (nvidia driver)
 
I have been struggling with this for a long time. I finally gave up and reloaded RH9. The very first thing I did is update my nvidia driver (successfully). My kernel after reinstall is 2.4.20-6. The kernel I was having so many problems with was 2.4.20-20.9. I could not get nvidia to update no matter what I tried.
Also note that when I did everything, it took a while for the x server to start the first time. I had a blank screen for several minutes.
I would recommend reinstalling your distro, being sure to include binutls and gcc under the development tools section. I have not updated my kernel again. Do not plan on it either.
NVIDIA people, I am seeing more and more people having problems with RH9 and your new driver update. I strongly recommend finding a work around for this

zander 09-21-03 11:31 PM

The command you used (5. Used the command "sh /home/wade/NVIDIA-Linux-x86-1.0-4496-pkg2.run --kernel-include-path=/usr/include/") instructs the installation routine to use header files intended for user-space applications, hence the failure. You will need to install the kernel-source package matching the running kernel and repeat the installation.

Wade777 09-22-03 06:18 AM

The problem is I did install it ...

bitterjack 09-23-03 06:36 PM

Wade777,
I can almost gaurantee you do not have your binutils tool from your Development Tools package.
I was having the exact same problems as you. I had to reload RH9 to get the binutls tool successfully installed. After reloading, I immediately updated my nvidia driver (kernel 2.4.20.6 at the time). I got brave then, I updated my kernel to 2.4.20-20.9 and had to reinstall the nvidia driver update. Much to my honest surprise, it worked (the updater updated the driver perfectly). My geuss is that we installed RH9 as a personal PC and everyone that had it work fine (the nvidia update) did their (RH) install as a workstation.
I believe the key is the binutls tool being enabled.
The only unresolved issue I have is that it takes 10 minutes for my X server to start:wtf:
good luck

Wade777 09-23-03 07:25 PM

Thank you so much!
I will try that when I get enough time!


All times are GMT -5. The time now is 07:31 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.