nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GT650M not recognized by 295.59 Driver on Ubuntu 12.04 (http://www.nvnews.net/vbulletin/showthread.php?t=184421)

hvontres 06-16-12 11:56 PM

GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
I am trying to get the gt650M in My Hp dv6t-7000 working with optimus. One thing I noticed that I was not able to load the "nvidia-current" module. Any ideas?




Here is the syslog output:

[ 3817.157736] nvidia 0000:01:00.0: power state changed by ACPI to D0
[ 3817.157747] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[ 3817.157759] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 3817.157774] nvidia 0000:01:00.0: setting latency timer to 64
[ 3817.157783] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns =none
[ 3817.157877] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0fd1) installed
[ 3817.157879] NVRM: in this system is not supported by the 295.59 NVIDIA Linux
[ 3817.157881] NVRM: graphics driver release. Please see 'Appendix A -
[ 3817.157883] NVRM: Supported NVIDIA GPU Products' in this release's README,
[ 3817.157884] NVRM: available on the Linux graphics driver download page at
[ 3817.157886] NVRM: www.nvidia.com.
[ 3817.157906] nvidia: probe of 0000:01:00.0 failed with error -1
[ 3817.157952] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 3817.157955] NVRM: None of the NVIDIA graphics adapters were initialized!




Here is the nvidia log:

____________________________________________

Start of NVIDIA bug report log file. Please include this file
when reporting a graphics driver bug via the nV News NVIDIA
Linux forum (see www.nvnews.net) or by sending email to
'linux-bugs@nvidia.com'.

nvidia-bug-report.sh Version: 11669588

Date: Sat Jun 16 21:42:51 PDT 2012
uname: Linux Dr-Bunsen 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux


here is the output of lspci -vvnn:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:0fd1] (rev a1) (prog-if 00 [VGA controller])
Subsystem: Hewlett-Packard Company Device [103c:181b]
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0
Interrupt: pin A routed to IRQ 16
Region 0: [virtual] Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
Region 1: Memory at a0000000 (64-bit, prefetchable) [size=256M]
Region 3: Memory at b0000000 (64-bit, prefetchable) [size=32M]
Region 5: I/O ports at 4000 [size=128]
[virtual] Expansion ROM at b2000000 [disabled] [size=512K]
Capabilities: [60] Power Management version 3
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Address: 0000000000000000 Data: 0000
Capabilities: [78] Express (v2) Endpoint, MSI 00
DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s unlimited, L1 <64us
ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+
MaxPayload 256 bytes, MaxReadReq 512 bytes
DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
LnkCap: Port #0, Speed unknown, Width x16, ASPM L0s L1, Latency L0 <512ns, L1 <4us
ClockPM+ Surprise- LLActRep- BwNot-
LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x8, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
DevCap2: Completion Timeout: Range AB, TimeoutDis+
DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
LnkCtl2: Target Link Speed: Unknown, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
Compliance De-emphasis: -6dB
LnkSta2: Current De-emphasis Level: -3.5dB
Capabilities: [b4] Vendor Specific Information: Len=14 <?>
Capabilities: [100 v1] Virtual Channel
Caps: LPEVC=0 RefClk=100ns PATEntryBits=1
Arb: Fixed- WRR32- WRR64- WRR128-
Ctrl: ArbSelect=Fixed
Status: InProgress-
VC0: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
Status: NegoPending- InProgress-
Capabilities: [128 v1] Power Budgeting <?>
Capabilities: [600 v1] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Capabilities: [900 v1] #19
Kernel modules: nvidia_current, nouveau, nvidiafb

amonakov 06-17-12 12:56 AM

Re: GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
If you're trying to load the module manually while bbswitch module is loaded, you have to power on the card first:
sudo tee /proc/acpi/bbswitch <<<ON

butters 06-17-12 02:55 AM

Re: GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
When I run "optirun glxgears" by example, I have this problem :
Code:

[  30.398673] NVRM: RmInitAdapter failed! (0x26:0xffffffff:1170)
[  30.398682] NVRM: rm_init_adapter(0) failed

Hm... the module loads successfully.

butters 06-18-12 08:40 AM

Re: GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
Nobody have this problem? An idea ?

balgo 06-18-12 09:01 AM

Re: GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
I have the same problem with a GT 640M. See http://www.nvnews.net/vbulletin/showthread.php?t=184524

butters 06-18-12 10:05 AM

Re: GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
I hope that NVIDIA will resolve this problem.

butters 06-20-12 03:41 PM

Re: GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
An idea ?

amonakov 06-21-12 04:44 AM

Re: GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
If, like balgo, you have "GPU has fallen off the bus" message earlier in dmesg, try running some CUDA application before optirun. You will need to power on the card and create device files prior to running a CUDA program:
sudo tee /proc/acpi/bbswitch <<<ON
sudo mknod -m 666 /dev/nvidiactl c 195 255
sudo mknod -m 666 /dev/nvidia0 c 195 0
sudo modprobe nvidia

balgo 06-21-12 06:14 AM

Re: GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
Quote:

Originally Posted by amonakov (Post 2565862)
If, like balgo, you have "GPU has fallen off the bus" message earlier in dmesg, try running some CUDA application before optirun. You will need to power on the card and create device files prior to running a CUDA program:
sudo tee /proc/acpi/bbswitch <<<ON
sudo mknod -m 666 /dev/nvidiactl c 195 255
sudo mknod -m 666 /dev/nvidia0 c 195 0
sudo modprobe nvidia

This won't work for me. The "fallen off the bus" error will be gone, when I start a cuda program before. But the other error messages (RmInitAdapter failed!) are still there.

-->
bbswitch: enabling discrete graphics
pci 0000:01:00.0: power state changed by ACPI to D0
pci 0000:01:00.0: power state changed by ACPI to D0
pci 0000:01:00.0: power state changed by ACPI to D0
pci 0000:01:00.0: power state changed by ACPI to D0
pci 0000:01:00.0: enabling device (0006 -> 0007)
nvidia: module license 'NVIDIA' taints kernel.
Disabling lock debugging due to kernel taint
nvidia 0000:01:00.0: power state changed by ACPI to D0
nvidia 0000:01:00.0: power state changed by ACPI to D0
vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:ow ns=none
NVRM: loading NVIDIA UNIX x86_64 Kernel Module 302.17 Tue Jun 12 16:03:22 PDT 2012
NVRM: GPU at 0000:01:00.0 has fallen off the bus.
NVRM: RmInitAdapter failed! (0x26:0xffffffff:1170)
NVRM: rm_init_adapter(0) failed
NVRM: RmInitAdapter failed! (0x23:0x2f:674)
NVRM: rm_init_adapter(0) failed
NVRM: RmInitAdapter failed! (0x23:0x2f:674)
NVRM: rm_init_adapter(0) failed
<--

After that I'm not able to reactivate the card via bbswitch anymore.
-->
bbswitch: enabling discrete graphics
nvidia 0000:01:00.0: power state changed by ACPI to D0
nvidia 0000:01:00.0: Refused to change power state, currently in D3
nvidia 0000:01:00.0: power state changed by ACPI to D0
bbswitch: enabling discrete graphics
nvidia 0000:01:00.0: power state changed by ACPI to D0
nvidia 0000:01:00.0: Refused to change power state, currently in D3
nvidia 0000:01:00.0: power state changed by ACPI to D0
<--

amonakov 06-21-12 07:03 AM

Re: GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
Hm. Note that there still is one "fallen off the bus" message in the logs you show. What exact commands are you running after 'modprobe nvidia'? Are you sure that nothing causes a power state transition after modprobe?

butters 06-21-12 11:33 AM

Re: GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
I haven't got the "fallen off the bus" problem ;)

Quote:

[yimm@yimm ~]$ optirun glxgears
[ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to assign any connected display devices to X screen 0
Hm.... Xorg.8.log says :
Quote:

[ 1484.418] (**) NVIDIA(0): Option "ConnectedMonitor" "DFP"
[ 1484.418] (**) NVIDIA(0): Enabling 2D acceleration
[ 1484.418] (**) NVIDIA(0): ConnectedMonitor string: "DFP"
[ 1484.419] (**) NVIDIA(0): Ignoring EDIDs
[ 1488.238] (WW) NVIDIA(0): Failed to enable display hotplug notification
[ 1488.241] (II) NVIDIA(0): NVIDIA GPU GeForce GT 650M (GK107) at PCI:1:0:0 (GPU-0)
[ 1488.241] (--) NVIDIA(0): Memory: 1048576 kBytes
[ 1488.241] (--) NVIDIA(0): VideoBIOS: 80.07.1d.00.21
[ 1488.241] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 1488.241] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[ 1488.245] (--) NVIDIA(0): Valid display device(s) on GeForce GT 650M at PCI:1:0:0
[ 1488.245] (--) NVIDIA(0): none
Quote:

[root@yimm yimm]# nvidia-xconfig --query-gpu-info
Number of GPUs: 1

GPU #0:
Name : GeForce GT 650M
PCI BusID : PCI:1:0:0

Number of Display Devices: 0
Hm... why nvidia card doesn't detect my screen ?

Quote:

dmesg:
[ 1485.336606] ACPI Error: Field [TMPB] at 282624 exceeds Buffer [ROM1] size 262144 (bits) (20120320/dsopcode-236)
[ 1485.336617] ACPI Error: Method parse/execution failed [\_SB_.PCI0.PEG0.PEGP._ROM] (Node ffff880129272d48), AE_AML_BUFFER_LIMIT (20120320/psparse-536)

amonakov 06-21-12 01:09 PM

Re: GT650M not recognized by 295.59 Driver on Ubuntu 12.04
 
Quote:

Originally Posted by butters (Post 2565944)
Hm... why nvidia card doesn't detect my screen ?

My guess it's related to this:
Quote:

Originally Posted by butters (Post 2565944)
(WW) NVIDIA(0): Failed to enable display hotplug notification

Which in turn may or may not be related to this:
Quote:

Originally Posted by butters (Post 2565944)
ACPI Error: Method parse/execution failed [\_SB_.PCI0.PEG0.PEGP._ROM] (Node ffff880129272d48), AE_AML_BUFFER_LIMIT (20120320/psparse-536)

No further ideas though. Let's hope someone has a clue what we can do with this.


All times are GMT -5. The time now is 12:27 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.