nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine (http://www.nvnews.net/vbulletin/showthread.php?t=184526)

Lamieur 06-18-12 09:57 AM

[WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine
 
Hello,

Title might sound more dramatic than it really is. After upgrading to 302.17, I was greeted with login screen on low resolution and refresh rate.

In Xorg.0.log there's information like:
[ 1350.735] (WW) NVIDIA(0): Error while parsing panning domain in mode description
[ 1350.735] (WW) NVIDIA(0): "1152x864@120"

Not only I'm using modes like this for ages, ALL the modeline calculators on the Internet produce modes with "@" followed by refresh rate.

Now every ModeLine containing "@" is rejected.

Work around was to replace every "@" with "_" in xorg.conf and all looks working.

I hope this helps someone :)

mlord 06-19-12 10:49 PM

Re: [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine
 
Quote:

Originally Posted by Lamieur (Post 2564982)
Hello,

Title might sound more dramatic than it really is. After upgrading to 302.17, I was greeted with login screen on low resolution and refresh rate.

In Xorg.0.log there's information like:
[ 1350.735] (WW) NVIDIA(0): Error while parsing panning domain in mode description
[ 1350.735] (WW) NVIDIA(0): "1152x864@120"

Not only I'm using modes like this for ages, ALL the modeline calculators on the Internet produce modes with "@" followed by refresh rate.

Now every ModeLine containing "@" is rejected.

Work around was to replace every "@" with "_" in xorg.conf and all looks working.

I hope this helps someone :)

Ouch. That's a nasty bug.

AaronP 06-20-12 11:43 AM

Re: [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine
 
Thanks for reporting this. I filed bug 1003603.

Lost Dog 06-20-12 07:14 PM

Re: [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine
 
I've had this same issue so I've been using 29X.XX series on my HTPC. I thought it may have been some change in how modelines were handled and didn't bother investigating it!

Let me know if you need any additional logs from another user's system.

mlord 06-22-12 08:16 AM

Re: [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine
 
Mmm.. related to this, perhaps: MythtTv-0.24-fixes (mythfrontend) seems to be unable to use xrandr to change screen refresh rates with the new 302.xx drivers. The exact same xorg.conf file works fine with 295.53 (even with all of the '@' symbols changed to '_' so they don't get ignored by the newer driver).

Looks like a beta release, not ready for production just yet.

mlord 06-22-12 08:24 AM

Re: [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine
 
Quote:

Originally Posted by mlord (Post 2566185)
Here's the code from MythTV

Wrong os -- that was for OS/X. Still digging here.


All times are GMT -5. The time now is 09:34 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.