nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Manual modelines with current drivers (http://www.nvnews.net/vbulletin/showthread.php?t=184659)

mxxmmxxm 06-20-12 05:43 AM

Manual modelines with current drivers
 
Hi! I'm having a hard time getting the Nvidia driver to recognize custom modelines.

Basically, my setup is a nice, shiny LCD panel, and an old, big CRT monitor--I want to add custom modelines to the latter, for things like MAME and Dosbox--both of which use relatively exotic video modes. Additionally, I know the monitor is capable of using these modes, since I used it years before the new Xorg configuration infrastructure existed.

I'm using the version 302.17 driver, from the Ubuntu xorg-edgers repository, and I notice that while it does support much of the randr spec, it doesn't support the "--addmode" parameter

So, the next resort is to xorg.conf--Currendly, I have the following setup.

Code:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 302.11  (buildd@louvi)  Tue May 22 00:14:23 UTC 2012

Section "Files"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "DELL P1130"
    HorizSync      30.0 - 130.0
    VertRefresh    48.0 - 170.0
    ModeLine      "1600x1200" 229.500 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
        Modeline "320x200_120.00"  10.32  320 328 360 400  200 201 204 215  -HSync +Vsync 
        Modeline "320x240_120.00"  12.38  320 328 360 400  240 241 244 258  -HSync +Vsync
        Modeline "640x480_120.00"  52.41  640 680 744 848  480 481 484 515  -HSync +Vsync
        Modeline "256x224_120.00"  9.25  256 264 288 320  224 225 228 241  -HSync +Vsync
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 9800 GT"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "Stereo" "0"
    Option        "TwinViewXineramaInfoOrder" "DFP-0"
    Option "metamodes" "CRT: 1600x1200 +1680+0, DFP: nvidia-auto-select +0+0; CRT: 320x200_120.00, DFP: NULL; CRT: 320x240_120.00, DFP: NULL, CRT:640x480, DFP:NULL; CRT:256x224_120.00, DFP: NULL"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection

The 320x240, 640x480 and 1600x1200 modes all work, but 320x200 and 256x224 don't, giving the following error:

[ 9031.940] (WW) NVIDIA(0): No valid modes for "CRT:320x200_120.00,DFP:NULL";
removing.
[ 9031.940] (WW) NVIDIA(0): No valid modes for "CRT:256x224_120.00,DFP:NULL"; removing.

I've tried both with and without the _120.00 in Xorg.conf, and that doesn't make a difference.

Does anyone know what I'm doing wrong?


All times are GMT -5. The time now is 11:36 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.