nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Tired Of Trying (http://www.nvnews.net/vbulletin/showthread.php?t=18609)

ctv99 09-24-03 10:02 PM

Tired Of Trying
i Have A ti4200 128mb Card, Mandrake 9.1 Clean Install,

i downloade the drivers did an extract only then did make install

then i ran X and all i get is errors

that it cant start the module

russofris 09-25-03 12:27 AM

Did you read the readme where it says

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")


Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist. There are also numerous options that can be added to
the XF86Config file to fine-tune the NVIDIA XFree86 driver. Please see
Appendix D for a complete list of these options.

Once you have configured your XF86Config file, you are ready to restart
X and begin using the accelerated OpenGL libraries. After you restart X,
you should be able to run any OpenGL application and it will automatically
use the new NVIDIA libraries. If you encounter any problems, please
see the FREQUENTLY ASKED QUESTIONS section below.

Please give us more information about what you did so that we may help you.

Thank you for your time,
Frank Russo

ctv99 09-25-03 08:08 AM

yes i changed the xf86config-4 file and thats when i get the error

ive tried alot of the recomendations in oter posts but nothing seems too work

i thought all yu hd to do was run make install change the file and it worked

but all i get is an error telling me that xf86 seems too need more memory

the ulimit -v in a script file

but it runs fine if i switch it back to the nv file

my mother board is an amptron m925
i have 512 mb of ram 1 stick pc133
a gainward ti4200 128mb ddr

ctv99 09-25-03 08:26 AM

(--) NV(0): Display dimensions: (270, 200) mm
(--) NV(0): DPI set to (75, 76)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xddc80000 - 0xddcfffff (0x80000) MX[b]
[1] 0 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[b]
[2] 0 0 0xde000000 - 0xdeffffff (0x1000000) MX[b]
[3] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[4] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[8] -1 0 0xdfffff00 - 0xdfffffff (0x100) MX[b]
[9] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[b]O
[10] -1 0 0xdfee0000 - 0xdfefffff (0x20000) MX[b](B)
[11] -1 0 0xddc80000 - 0xddcfffff (0x80000) MX[b](B)
[12] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[b](B)
[13] -1 0 0xde000000 - 0xdeffffff (0x1000000) MX[b](B)
[14] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b](OprD)
[15] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b](OprD)
[16] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b](OprD)
[17] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[18] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[19] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[b]
[20] -1 0 0x0000e800 - 0x0000e81f (0x20) IX[b]
[21] -1 0 0x0000e400 - 0x0000e41f (0x20) IX[b]
[22] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[b]
[23] -1 0 0x0000fc00 - 0x0000fc0f (0x10) IX[b]
[24] -1 0 0x0000ec00 - 0x0000ec3f (0x40) IX[b]
[25] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
[26] 0 0 0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(==) NV(0): Write-combining range (0xd0000000,0x8000000)
(II) NV(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
8x8 mono pattern filled rectangles
Solid Lines
Offscreen Pixmaps
Setting up tile and stipple cache:
32 128x128 slots
32 256x256 slots
16 512x512 slots
(==) NV(0): Backing store disabled
(==) NV(0): Silken mouse enabled
(**) Option "dpms"
(**) NV(0): DPMS enabled
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not found)
(II) Keyboard "Keyboard1" handled by legacy driver
(**) Option "Protocol" "PS/2"
(**) Mouse1: Protocol: "PS/2"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/psaux"
(**) Option "Emulate3Buttons"
(**) Option "Emulate3Timeout" "50"
(**) Mouse1: Emulate3Buttons, Emulate3Timeout: 50
(==) Mouse1: Buttons: 3
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) Mouse1: ps2EnableDataReporting: succeeded
AUDIT: Wed Sep 24 19:18:51 2003: 1751 X: client 5 rejected from local host
GetModeLine - scrn: 0 clock: 49500
GetModeLine - hdsp: 800 hbeg: 816 hend: 896 httl: 1056
vdsp: 600 vbeg: 601 vend: 604 vttl: 625 flags: 5
GetModeLine - scrn: 0 clock: 49500
GetModeLine - hdsp: 800 hbeg: 816 hend: 896 httl: 1056
vdsp: 600 vbeg: 601 vend: 604 vttl: 625 flags: 5

ctv99 09-25-03 08:26 AM

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Sep 24 17:28:34 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> A precompiled kernel interface for kernel 'Mandrake Linux 9.1 kernel
2.4.21-0.13mdk i586' has been found.
executing: 'cd ./usr/src/nv; /usr/bin/ld -r -o nvidia.o precompiled-nv-linux
.o nv-kernel.o'...
-> Kernel module linked successfully.
-> Installing classic TLS OpenGL libraries.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (1.0-4496):
executing: './usr/src/nv/makedevices.sh'...
executing: '/sbin/ldconfig'...
executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Sanity check passed.
-> Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86
(version: 1.0-4496) is now complete. Please update your XF86Config file as
appropriate; see the file /usr/share/doc/NVIDIA_GLX-1.0/README for details.

mtrr 09-25-03 08:50 AM

read the readme and make the changes in the config file.

there should even be a sample XF86Config(-4) .


geowiz 09-25-03 09:51 AM

The output from your log indicates it is using the standard XFree NV module. Check to see that you don't have 2 configuration files (/etc/X11/XF86Config*).

XF86Config-4 is not preferred and XF86Config is the default that is used in Xfree 4.3.0.

I suspect that you have both XF86Config and XF86Config-4 files and that you are making changes to XF86Config-4 which aren't being used.

See if that doesn't solve your problem.

ctv99 09-25-03 10:58 AM

i have made the changes when i try to use them i get errors

i have switched back you the nv driver

when i get home ill fry it again for a new error log

ctv99 09-25-03 10:59 AM

on my install log did i do it right to do the extract-only then make install

i get no errors
but it wont install the module it says its tainted

geowiz 09-25-03 11:22 AM

The proprietary drivers from Nvidia (and anyone for that matter) taint the GPL'ed kernel. That is normal and is not an error. It's just telling you that you are running non-GPL'ed software.

Extract/make install should have worked ok.

Do a /sbin/lsmod | grep nvidia to make sure the module is loaded - should return a line something like nvidia 1698924 10 . Check your /etc/modules.conf file to verify you have the following alias char-major-195 nvidia line in the file. Then check that devices are made by ls /dev/nvidia* . If all of that is in order, and you have made the XF86Config changes, it should rock-n-roll.

Good luck

ctv99 09-25-03 08:47 PM

the lsmod did nothing

geowiz 09-25-03 09:06 PM

If lsmod doesn't list the nvidia module then it's not loaded. You can try to manually load it by using /sbin/modprobe nvidia.o .

lsmod should return a list of modules. (lsmod is list modules). By returning nothing did you mean no nvidia or nothing?

I think mandrake uses /etc/modules.conf . The line I mentioned for that file autoloads nvidia on system startup. You might check to see if it is in modules.conf .

All times are GMT -5. The time now is 09:56 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.