nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Driver Lockup, black screen when exiting X. (http://www.nvnews.net/vbulletin/showthread.php?t=18623)

Kimc 09-25-03 08:19 AM

Driver Lockup, black screen when exiting X.
 
1 Attachment(s)
I experience the same thing as many other users, with my GeForce4 Ti4200 agpx8, first I thought it was a known issue with the AGPx8 cards, and I just waited for an updated driver. But know im not that sure you guys (Nvdia) has acknowledge the problem.

My symptons are somehow different, but I believe its the same problem as other people describe in here. I started wayback with an nvidia tnt2 card, everything was fine stable and fast. Then I upgraded to a GeForce 4 ti4200 AGPx4, and think just got even better with twinview etc. Still no problem. Then the graphics adapter broke down, and I recieved a new GeForce4 4200 AGPx8 (was using a GeForce2 i the meanwhile with no problems), and everything went bad, I havent change any of my software settings and in windows it works as it should.

If I switch to the terminal the system hangs and lockup, if I stay in X for too long it will lock up, there are some small graphics glitches on the screen, not sure how to describe it, its like all pixels make a shadow, so the border of a window will make a dark line 16 pixels to the right of it. its not very noticeably but its visible (old card didnt do that). The lines are somehow stuck to a grid, it wont move with the windows, unless the window cover the line and the line will show up 20 pixels further to the right. (sometimes the lines a brighter than the background, but they follow sharp edges very precisely)

I found a workaround for the lockup when switching to the terminal. If I configure the driver for twinview(2 indenpendent screens), I can switch to the terminal but the text is VERY dark(almost black) and the text wont scroll, but it is able to shutdown. The cursor is not visible.

I have tried both with the kernel agp driver and nvidia's with same errors. Tried the 2.6.0-test3 kernel and 2.4.[19-22].

I have include all the details that could be of interest, please ask for what I have forgotten

Everything seems to work, tvout is working and I can boot with the cable plugged in, 3d works well too.

best regards
Kim Carlsen

Kimc 09-26-03 09:11 AM

Can I get any response on the subject

LordMorgul 09-27-03 01:56 AM

AFAIK the nVidia guys are a touch sparse on the forum in the last couple months. I'm sure they're keeping an eye on it but don't seem to be active at present. (Andy Mecham is missed)

I have experienced this issue with screen blanking while the system appears to be operating otherwise. This has happened on exit of an Xserver (4.3.0, servers set to restart when exiting) and on failed load of Quake3.

I'm using the 2.6.0-test5 kernel and it is much more stable regarding this particular problem than the earlier -testx 2.6 kernels were. I haven't had this happen on my 2.4.20 or 2.4.21 kernels however, so I'm not convinced it is directly related to the drivers in any way.

When the system hangs like this (black screen) the kernel is still responding well enough to shutdown on ctrl-alt-del or external login. I think it is probably agp driver related but nothing solid on that. As soon as the system gets all 3 Xservers shut down the vga text mode operates correctly during the rest of my shutdown but telinit doesn't correct this problem so something additional is being shut down by the time it reverts to the virtual terminal.

GeF ti4400 at 4x nvAGP, driver 4496


All times are GMT -5. The time now is 12:43 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.