nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   repeated X lockups w/ 44.96 + FX5600 + 2.4.22 (http://www.nvnews.net/vbulletin/showthread.php?t=18645)

darkhelmet03 09-25-03 05:47 PM

repeated X lockups w/ 44.96 + FX5600 + 2.4.22
 
Hi,

Since upgrading to an FX5600 I experience random lockups during boot _only_.
When I reach the login screen there's a 10-20% chance that X will stop responding and even ctrl-alt-F6 will not bring up another console.
I have to press the reset button.

With my old GF2MX400 there was no problem. Same driver. I even reinstalled it just to be sure. 3D works perfectly (RTCW:ET). It never crashes in-game. Only after boot and in the login screen.

Config:

Athlon 1.4GHz
ABIT KG7 (w/ lates DM bios)
512MB DDR 266MHz (no overclocking)
Albatron FX5600P

RH 8.0
2.4.22 (kernel.org)
XFree86 4.2.1
nvidia 44.96

To NVidia people: HELP!
The problem is definitely card-specific. With the same configuration the GF2MX gave no lockups at all.

russofris 09-25-03 07:18 PM

How is your AGP configured? NV or AGPGART? SBA and FW?

How is X configured (copy of your XF86config would be helpful)

What else are you doing with the hardware? Do you have a TV plugged in?

Thank you for your time,
Frank Russo

darkhelmet03 09-25-03 07:34 PM

replying ;)
 
1 Attachment(s)
AGP is AGPGART. Nevre tried NV since AGPGART was working OK w/ the GF2.
I have set SBA and FW both to 1 in modules.conf but only SBA gets enabled. FW is still disabled. Though even with both of them disabled I was _still_ getting the same problem. So that's not the cause.

Nor the kernel. 2.4.21 gave the same problem, but worked fine with the GF2MX.

It seems to be a driver problem but specific to NV31 only.

I know that the drivers do underclock and overclock the card. When they first get loaded maybe the frequency is then adjusted. Maybe that's the unstable part? That question goes to NV guys...

No TV is attached.

Thanks again.

p.s. even 43.63 was giving the same problem.

darkhelmet03 09-25-03 07:35 PM

and some more info
 
1 Attachment(s)
some useful stuff...

darkhelmet03 09-27-03 07:01 PM

any idea?
 
some more info that might help:

I check every time messages.log and Xfree86.log at /var/log/ but nothing is logged there. Is there any other log I should check after this happens?


All times are GMT -5. The time now is 07:49 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.