nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE (http://www.nvnews.net/vbulletin/showthread.php?t=186787)

Stingray 07-13-12 08:00 AM

Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE
 
I have two similar systems that I have upgraded from Fedora 15 to Fedora 17 recently. I'm using the RPM Fusion packages for the 295.59 NVIDIA driver, and all current Fedora 17 updates (which means Xorg server 1.12.2).

One of the systems has a GTX 460 SE. That one runs fine.

The other system has a 9300 GE, and after being logged in for a while (let's say 24 hours), things start to slow to a crawl. Xorg uses near-100% CPU when rapidly moving your mouse between windows (using focus-follows-mouse). Trying to use Firefox is awful, everything goes in slow motion. Logging out and back in to restart Xorg solves the problem, temporarily of course.

This is easily reproduceable and has happened every day for the last week or two. I tried the Nouveau driver instead of the NVIDIA driver and the problem went away as expected, but I'd rather use the NVIDIA driver for various reasons.

Is there a known issue with older cards (ie 9 Series) and the latest NVIDIA drivers?

Is there any easy way to use the older drivers (I believe I was using 280.13 on Fedora 15, and had no problems) with Fedora 17, to at least test that? RPM Fusion doesn't seem to have them available for F17. And getting NVIDIA drivers running without RPM Fusion packages seems to be a real nightmare in recent Fedora versions.

I did try using the 173xx drivers from RPM Fusion (for the 9300 GE system), and with those drivers, the slowness occurs right off the bat. You don't even have to wait the 24 hours to see it.

kwizart 07-13-12 12:58 PM

Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE
 
You need to attach the output of nvidia-bug-report.sh

I don't remeber if 280.13 is compatible with xorg-server 1.12, it's not according to:
http://us.download.nvidia.com/XFree8...uirements.html

You can try to reproduce on F-15 but with the 295.53 packages from rpmfusion-nonfree-updates-testing. (You will need the kernel from fedora updates-testing for pre-built kmod).

Now the other way would be to grab the lastest nvidia packages ( xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs akmod-nvidia) from:
http://download1.rpmfusion.org/nonfr...ide/x86_64/os/
You will need to install kernel-devel and run akmods --force

Stingray 07-13-12 01:08 PM

Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE
 
1 Attachment(s)
Here's the bug report file.

I'll give the newer (beta?) versions a try later on.

kwizart 07-13-12 02:12 PM

Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE
 
The beta driver is now available.

To witch problem the video=vesa:off vga=normal is the solution ? I expect it to have no effect toward grub2 graphical boot that make early vesa initialization.

Stingray 07-13-12 02:17 PM

Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE
 
Without the "video=vesa:off vga=normal", I get the complaint at bootup about "NVRM: Your system is not currently configured to drive a VGA console" etc etc. With it, I don't. Not sure that it matters, though. Anyway, I've tested it both ways, and the slowdown happens either way.

leigh123linux 07-14-12 11:07 AM

Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE
 
Quote:

Originally Posted by Stingray (Post 2569802)
Without the "video=vesa:off vga=normal", I get the complaint at bootup about "NVRM: Your system is not currently configured to drive a VGA console" etc etc. With it, I don't. Not sure that it matters, though. Anyway, I've tested it both ways, and the slowdown happens either way.


Try the beta


Code:

su
yum --enablerepo rpmfusion-nonfree-rawhide update *\nvidia\*


Stingray 07-14-12 11:18 AM

Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE
 
Yep, already got the 304.22 beta from RPM Fusion running on both computers, should know results on the 9300 GE system within a day or two.

Stingray 08-07-12 03:47 AM

Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE
 
Figured out the problem. It isn't the card model. It's VMware Workstation.

I run VMware Workstation with a Windows XP VM on the system with the 9300 GE card (but not the system with the GTX 460 SE card). Running NVIDIA's Linux driver (including the latest beta) + VMware Workstation on Fedora 17, causes video to drag to a crawl within 24-48 hours.

I switched from VMware to VirtualBox and the problem went away.

Note that the problem doesn't happen with Nouveau, though. So I don't know if it's a VMware problem or an NVIDIA problem. Likely VMware though, as its kernel modules haven't been updated in a while and it doesn't officially support Fedora 17.

xorbe 08-07-12 04:04 PM

Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE
 
Oooh I see something like this too -- vncviewer repaints start getting really slow, before everything goes into a death spiral ("NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context" and black boxes on the screen, and 2 second hangs, etc.) with 295.59 64-bit that is.

Not using vmware, just vncviewer.

Stingray 08-07-12 08:51 PM

Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE
 
Are you using VMware or no?


All times are GMT -5. The time now is 10:45 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.