nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   304.22 drivers feedback thread (http://www.nvnews.net/vbulletin/showthread.php?t=186821)

artem 07-13-12 01:10 PM

304.22 drivers feedback thread
 
This thread is only for reporting issues which are new to these drivers.

At least for me (8800GT here) dead VesaFB text consoles and no resume from suspend issues are fixed, thanks NVIDIA!

artem 07-13-12 05:47 PM

Re: 304.22 drivers feedback thread
 
OK, I've found a serious regression, it's impossible to watch flash videos in Google Chrome 20.0.1132.57.

Chrome's CPU usage spikes to 100%, it looks like Flash drops 3/4 of frames:

Code:

PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  P COMMAND
3779 artem    20  0  198m  88m  40m R 94.6  1.1  1:09.18 2 chrome
1955 root      20  0 98.6m  81m  18m S 12.6  1.0  10:40.69 2 X

GPU: NVIDIA 8800GT, Fedora Linux, kernel 3.3.8

leigh123linux 07-13-12 06:56 PM

Re: 304.22 drivers feedback thread
 
Chrome and flash work as expected here


Code:

[leigh@main-pc ~]$ rpm -qa *\nvidia\* google-chrome-stable |sort;uname -r;lspci |grep -i vga
akmod-nvidia-304.22-1.fc17.x86_64
google-chrome-stable-20.0.1132.57-145807.x86_64
kmod-nvidia-3.4.4-3.fc17.x86_64-295.59-1.fc17.3.x86_64
kmod-nvidia-3.4.4-5.fc17.x86_64-304.22-1.fc17.x86_64
nvidia-settings-1.0-20.fc18.x86_64
nvidia-xconfig-1.0-18.fc18.x86_64
xorg-x11-drv-nvidia-304.22-1.fc17.x86_64
xorg-x11-drv-nvidia-libs-304.22-1.fc17.i686
xorg-x11-drv-nvidia-libs-304.22-1.fc17.x86_64
3.4.4-5.fc17.x86_64
01:00.0 VGA compatible controller: nVidia Corporation GF106 [GeForce 450 GTS] (rev a1)


RUSTY 07-14-12 01:33 AM

Re: 304.22 drivers feedback thread
 
how to disable Sync to Vblank in this new driver ?

kokoko3k 07-14-12 04:01 AM

Re: 304.22 drivers feedback thread
 
@rusty:
remove the option from the gui
or
remove the option from the gui and do nvidia-settings -l
or
nvidia-settings -a SyncToVBlank=0

kokoko3k 07-14-12 04:02 AM

Re: 304.22 drivers feedback thread
 
Anyway 9800GT and vesa consoles are still broken.
Text consoles 'seems' to work by now, but i observed they to vanish after some days of use with older drivers.

...will report if anything weird happens.

-EDIT-

S**t, even text consoles are still blank to me.

cheechr1 07-14-12 09:03 AM

Re: 304.22 drivers feedback thread
 
On my wifes computer, if I enable hardware acceleration in flash, people will have a blue tinge instead of the proper color. This is on a Geforce 210. Other than that, so far so good. Keep up the great work Nvidia dev team!

gradinaruvasile 07-14-12 10:13 AM

Re: 304.22 drivers feedback thread
 
Quote:

Originally Posted by cheechr1 (Post 2569898)
On my wifes computer, if I enable hardware acceleration in flash, people will have a blue tinge instead of the proper color. This is on a Geforce 210. Other than that, so far so good. Keep up the great work Nvidia dev team!

This is not new issue. I have this for quite some time with my 8200 + newer flash (including Chrome's built-in). This happens with vdpau-capable cards.

Milos_SD 07-14-12 01:53 PM

Re: 304.22 drivers feedback thread
 
Again, the same hard freez as with all 30x.xx series. :(
I have Ubuntu 12.04 with Unity (3D version), and Gainward 7600GT PCIx card.
Here is the thread I started about this problem: http://www.nvnews.net/vbulletin/showthread.php?t=184536

QBANIN 07-14-12 02:11 PM

Re: 304.22 drivers feedback thread
 
Quote:

Originally Posted by Milos_SD (Post 2569945)
Again, the same hard freez as with all 30x.xx series. :(
I have Ubuntu 12.04 with Unity (3D version), and Gainward 7600GT PCIx card.
Here is the thread I started about this problem: http://www.nvnews.net/vbulletin/showthread.php?t=184536

+1

hlandgar 07-14-12 06:10 PM

Re: 304.22 drivers feedback thread
 
2 Attachment(s)
304.22 display nothing after gdm login.

With 304.22 all three monitors come up for gdm login and all looks right. After signing in to gnome, all the screens blank and Xorg.0.log begins to fill with setting mode messages which continue until I stop X. I am attaching the Xorg.0.log and xorg.conf

302.17 brings gnome up properly.

RUSTY 07-14-12 09:27 PM

Re: 304.22 drivers feedback thread
 
Quote:

Originally Posted by kokoko3k (Post 2569862)
@rusty:
remove the option from the gui
or
remove the option from the gui and do nvidia-settings -l
or
nvidia-settings -a SyncToVBlank=0

There are 2 options in GUI with Sync To Vblank. First is in "Opengl Settings" and the second one is "X Server Xvideo Settings".
In the new driver the second option in the "X Server Xvide Settings" is gone, but it seems to be enabled cause performance level goes to 2 for any small things I do like opening a web browser etc.
I've tried you solution and it didn't worked.


All times are GMT -5. The time now is 03:24 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.