nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Running redhat 9, trouble fixing an rpm error (http://www.nvnews.net/vbulletin/showthread.php?t=18841)

darren 09-30-03 12:09 AM

Running redhat 9, trouble fixing an rpm error
 
I installed the rpm with the updated drivers for Redhat, for kernel 2.4.20 but it had errors. I went to remove the rpm and it said, 'rpm not installed'. So I tried to reinstall the rpm, and it reported the rpm is already installed. I checked the redhat website and they keep telling me to use the package manager. That won't help, seeing as Redhat can't even make up its mind whether the RPM is there or not. I need help, or I'm going back to the dark side...nah. But I would like some help. thanks.

oh ya, if it matters, I'm running the Asus A7N8X Deluxe, the rpm was to try to get my ethernet card working so I could get DSL to work. and it was copied from an NTFS hd...cus I can't get onto the net to put it on my ext3 hd...

geowiz 09-30-03 07:11 PM

Use the force
 
Feel like you're chasing your tail? Hmmm....

You can try using rpm -Uvh --force RPMname.rpm . In all likelyhood it will install even though it is already installed. (Of course it doesn't fix the original issue/error you had in the first install). Note the double dash before force.

You can also use the --test switch to see whether it thinks it will work before you actually commit to the installation.

If the rpm was corrupted in the download, rpm should have refused to run indicating a checksum error in the package file.

Hope it solves your rpm problem.

darren 09-30-03 11:55 PM

It allowed me to install, again, but I still have the errors.

It reports unresolved symbols in /lib/modules/2.4.20-8/kernel on just about everything. I still can't uninstall it, and the files it reports are there. The rpm I'm trying to install is the closest to the kernel version i could find.

I ran rpm --test and it just returned to the command line w/ no output, and rpm --test RPMpackagename is an invalid option

Thanks for the help, guess I gotta dig deeper for what the problem is.

geowiz 10-01-03 07:47 AM

test
 
With the test option, you have to have given it something to test. So, the command should be something like rpm -Uvh --test RPMname.rpm .

Close to the RPM probably won't be of much help. Unresolved symbols indicate a kernel mismatch and won't work (generally).

If you're trying to install the Nvidia Nforce drivers and have the mismatch- download rhe source rpm and use rpmbuild --rebuild RPMname.src.rpm and then do an rpm install. Otherwise, you only need the network driver so just download the tar.gz code, extract it to a directory and build the one or two things you need (nvnet, maybe sound). Instructions are in various threads on this site.

Good luck


All times are GMT -5. The time now is 01:36 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.