nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Can't load nvidia drivers, don't have bios settings (http://www.nvnews.net/vbulletin/showthread.php?t=18900)

psiegel 10-01-03 12:43 PM

Can't load nvidia drivers, don't have bios settings
 
I've installed the latest dirvers (1.0-4496), but when I type 'modprobe nvidia', I get the following output:

0: nvidia: Can't find an IRQ for your NVIDIA card!
0: nvidia: Please check your BIOS settings.
0: nvidia: [Plug & Play OS ] should be set to NO
0: nvidia: [Assign IRQ to VGA] should be set to YES
0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4496 Wed Jul 16 19:03:09 PDT 2003

However, when I go into my bios, these settings don't exist! No plug & play related settings, no vga settings, no agp settings of any kind. I have discovered that when I boot in Windows, my card reports as being on IRQ 16, so it does appear that the card is getting an IRQ assigned. I've also contacted the manufacturor asking about these bios settings, but they were of little help.

Here's the specs of the machine:

Alienware Area 51m
Pentium 4 3.0 GHz
GeForce FX5600 Go

Log file attached.

Paul

Reeve 10-01-03 04:11 PM

ACPI
 
The IRQ probably needs to be assigned with ACPI. Easiest way to go about that would be to upgrade your kernel to 2.4.22 and make sure acpi is enabled (put the line in lilo.conf: append="acpi=on")

psiegel 10-01-03 05:26 PM

1 Attachment(s)
Thanks for the reply, Reeve. I gave what you said a try, but I've still got nothing. I'm noticing in the output when I try to start X the following:

NV: could not open device /dev/nvidia0 (Input/output error)
NV: couldn't map fb (0xc0000000, 268435456M) on /dev/nvidia0 (No such de
hint: there may be a ulimit restricting the amount of
virtual memory available to XFree86. It may be a good
idea to check your startup scripts for something like

ulimit -v <number>

and either boost this value or remove the line.

I'm also attaching my XF86Config file this time, just in case that helps. Note that I've tried it with and without the section labeled "nvidia specific options" and get the same results.

I can't even get the default 'nv' drivers to work - those make the desktop always appear at 640x480, though the screen is set a higher resolution, thus resulting in a giant black border around the desktop. All I can get working is the 'vesa' drivers, which of course don't let me set a higher resolution than 800x600. Ugh.

Paul

psiegel 10-01-03 05:27 PM

1 Attachment(s)
Hmm, I'm not seeing my log file in the original post. I'm attaching it again, just to be sure.

Paul

Reeve 10-02-03 02:38 AM

Very strange. Did you check the ulimit as it suggested? Also, are you using devfs? If not then you may need to create the /dev entries (/dev/nvidia0, etc.) If you are using devfs, try making sure the nvidia kernel module is being loaded, and that you have devfsd installed.

psiegel 10-02-03 08:56 AM

I'm sorry, I was quite wrong. I forgot to reinstall the NVidia drivers on top of my new kernel. Now I am getting different behavior, though I can't say it's any better.

Now, instead of X crashing and giving me the output I mentioned in my earlier post, it just hangs with a blank screen. What's more, I can't switch to a different terminal using ctrl-alt-F1. So it's totally hosed at that point, and all I can do is reboot in an older kernel.

Paul

Reeve 10-02-03 02:38 PM

I've seen that problem on one of my systems before, but I have no idea how to fix it. :(

psiegel 10-03-03 11:25 PM

1 Attachment(s)
Just thought I'd follow through, as I've tried a million ways to Sunday to fix this and am still sitting at the same problem. I can modprobe the nvidia drivers now no problem. Setting up ACPI seems to have fixed my IRQ issue. However, when I start X I simply get a black screen and complete lock-up.

I've tried using the 'nv' drivers instead, but they always draw my desktop at 640x480, even though the screen resolution is set higher, resulting in huge black bands around the tiny desktop.

One intesting piece of info that may be totally irrelevant. I tried connecting an external monitor to my machine, which displays the error "resolution not supported" when I start X. What's more, it displays the H/VSynch setting, which appear to be abnormally high. (Something along the lines of 160 Hz for Vertical, which I know is beyond what my monitor can do, and an equally high for the Horizontal.) Just thought I'd include that info in case it's helpful in diagnosing this.

Anyway, I'm attaching my latest log file, and inlining my XF86Config as well. Thanks for any help!

Paul

XF86Config:

# XFree86 4 configuration created by pyxf86config
Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unprobed Monitor"
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "NV AGP"
Driver "nvidia"
VendorName "nvidia"
BoardName "GeForce FX5600 Go"
VideoRam 131072
BusID "PCI:1:0:0"
#nvidia specific options
Option "NvAgp" "1"
Option "UseEdidFreqs" "yes"
Option "FlatPanelProperties" "Scaling=aspect-scaled"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NV AGP"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Moled 10-04-03 01:10 AM

Section "DRI"
Group 0
Mode 0666
EndSection

comment all that out^


have you tried disabling agp, since it seems to hang just after setting x8

I would give the kernel agpgart a go, it will probably be faster too

fyi this is what I get after that section:

(II) NVIDIA(0): AGP 8X successfully initialized
(II) NVIDIA(0): Setting mode "1600x1200"
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-GLX
(II) Loading extension NV-CONTROL

etc etc

psiegel 10-04-03 10:44 AM

Thank you so much!!! This has finally made it work.

It took some experimentation, but I've discovered I cannot make it work with agpgart at all. It only works if I have the NvAgp setting set to 1. This is fine by me though.

One more oddity I've noticed is that I can't seem to use any resolutions that match the aspect ratio of my laptop's native screen. (It's a 15.4" WSXGA+ screen). Resolutions like 1280x800 or 1680x1050 which work fine in Windows are rejected by the nvidia drivers. It's not a huge deal, as I can use resolutions like 1280x960 that result in only slight black bands on either side of the screen. Anyway, if anyone knows a way to make that work, excellent.

But in the meantime I'm just happy I can finally use my Linux boot again. Thanks so much Reeve and Moled!

Paul

Moled 10-04-03 03:48 PM

do you have agpgart built as a module?
what does:
Quote:

dmesg |grep agp
give?

when you get the module to use kernel agpgart?

psiegel 10-06-03 08:54 AM

dmesg | grep agp returns nothing. I can load the agpgart module, but only with the command:

modprobe agpgart agp_try_unsupported=1

However, as I said, getting agpgart working isn't huge on my list of priorities, as it seems to be working fine with the nvidia agp drivers.

What's really bizarre is that sometimes I still get that blank screen and freezing. It took me a while to determine exactly what causes it, and frankly, it doesn't make much sense to me. After a lot of testing, here's what I've determined:

1. If I turn on the machine from a cold state and directly load linux, I get the blank screen and freezing as mentioned earlier.

2. If instead I boot to Windows or an older kernel that doesn't load X, and then do a warm reboot into linux kernel 2.4.22, everything works fine.

Can anyone think of a reason why this would happen? It is slightly annoying having to boot the machine twice every time to get it running.

Paul


All times are GMT -5. The time now is 07:19 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.