nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   VESA framebuffer modes are not available if TV is plugged (http://www.nvnews.net/vbulletin/showthread.php?t=19035)

Norman 10-03-03 04:49 PM

VESA framebuffer modes are not available if TV is plugged
 
Normally I use mode 791 ( 1024x768 16 bit ) of the linux VESA framebuffer driver ( linux 2.4.22 ). But when I plug in the TV at boot time, grub comes up with the message "You passed an undefined mode number". However, I know that this mode is supported by the TV-out of my card ( Geforce4 MX 440 ) because I use nView with that mode under Windows. So I would like to ask if someone knows a solution on how to use the VESA framebuffer modes even if a TV is plugged. Could it be that the VESA BIOS extension of the graphics card is disabled when TV-out is enabled ? Does the linux riva driver support a GeForce4 and may it work while TV-out is enabled ?

vnpenguin 10-04-03 11:51 AM

Hi,
I never use TV-out in my card. With "GeForce4 MX 440" and nVidia driver 4496 I can use framebuffer (vga=791) without any problem. Since I changed to "GeForce4 MX 440 AGP8x" the framebuffer no longer work any more. I think there is problem with AGP support ...
I have posted my question longtimes, but no response at all :(

ribx 12-08-03 11:01 AM

i know what you mean...
 
my kyroII also worked fine with the vesa frame buffer, but the GF4mx440 agp8x (aka nv18) doesnt support any higher resolutions.. i worked very hard on this problem, because i realy love workin in the text console.. i think the problem on my card is that the tv-out is always enabled. this causes problems with the bios, because every bootloader reads out the resolutions which are supported by the card from the bios at boottime.

btw pls try the command:
lilo -T video

i get this back:

VGA/VESA adapter

640x350x16 mode 0x0010
640x480x16 mode 0x0012

320x200x256 mode 0x0013
640x480x256 mode 0x0101
800x600x256 mode 0x0103

Enable Screen Refresh bug is present.

strange is that i cannot find anything about this bug in google! i never had such a problem which wasnt found in google!

the problem is that there are no fb support from nvidia. they do not give any source codes to the developpers of linux .. so they cannot create an fb for nvidia (in my opinion: this sux a bit :P )


All times are GMT -5. The time now is 09:16 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.