nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia drivers won't compile with Slackware 8.0 (http://www.nvnews.net/vbulletin/showthread.php?t=1905)

z28Power 09-16-02 02:00 PM

Nvidia drivers won't compile with Slackware 8.0
 
I'm using Slackware 8.0 and trying to compile the 3123 drivers (the source of course, since slackware doesn't have a prebuilt rpm file like the others), however when I extract the files from the tar.gz files and run make install, I get a few unresolved errors and the kernel file won't compile -- errors out. The GLX file appears to run the makefile correctly however. Anybody have any ideas? Thanks! (First install of the Nvidia drivers isn't going so well!)

Andy Mecham 09-17-02 02:29 AM

Slackware 8.0 shipped unconfigured kernel sources, so they don't match your running kernel. This is why you're getting unresolved symbols; your kernel sources need to be configured to match your running kernel.

To fix this, you can either configure and recompile a new kernel, or find a .config that matches the Slackware 8.0 default kernel config, and update your kernel sources that way. You can probably find the .config through google - I seem to remember someone posting one here recently, although I can't seem to find it on a cursory search.

I hope this helps...

--andy

z28Power 09-17-02 03:14 AM

recompile kernel
 
So I'm still pretty new to the linux scene, and don't really know how to configure my kernel and compile it. Do i need to run a setup program or go and manually enter in settings into a file and then run an sh file or something? Thanks again -- andy that seems to make sense, if I just knew what to do about it! TIA

Andy Mecham 09-17-02 03:22 AM

Configuring and compiling your kernel is a little outside the scope of this forum, but there are several good guides that can help you through your First Kernel Compile (tm) on the net. Check out http://www.ibiblio.org/pub/Linux/doc...nel-HOWTO.html for a *detailed* walkthrough (and it's much better than my standard explanation :) ).

Thanks!

--andy

z28Power 09-17-02 03:29 AM

Thanks Andy I'll read that over tomorrow morning and see what I can do! :D:D

z28Power 09-18-02 01:07 PM

Well the recompile went well up to the make modules_install and then it said I had unresolved symbols in my /lib/modules/pcmcia folder on about four or five .o.tz files I think, and if I try to run the make install file, I get the same unresolved symbols, with one extra one -- NVdriver having unresolved symbols! at this point i'm mildly confused as to how to fix them and haven't had my NVidia driver working for linux since friday! Anybody that can help, I would love it and welcome all suggestions openly

z28Power 09-18-02 07:20 PM

Well I reconfigured and recompiled the kernel again and for some reason it worked this time. make modules_install didn't error out although depmod showed unresolved symbols still.
When I ran make install for the NVIDIA_kernel I still got unresolved symbols, but the last line says: module installed successfully (or something like that) and I'm FINALLY into Xwindows! now to learn about window managers... :D :cool:


All times are GMT -5. The time now is 09:38 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.