nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   My source RPM won't build right! (http://www.nvnews.net/vbulletin/showthread.php?t=1927)

z28Power 09-16-02 10:56 PM

My source RPM won't build right! Details Inside.
 
I downloaded the .src.rpm file for build 3123 of the nvidia drivers for my Ti4200. The rpm --build command worked fine, however when I tried to run the rpm -ivh /usr/src/rpm/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm file, I get the following message:
Code:

error: failed dependencies:
  kernel >= 2.2.0 is needed by NVIDIA_kernel-1.0-3123
  rpm >= 3.0.4 is needed by NVIDIA_kernel-1.0-3123
  /bin/sh        is needed by NVIDIA_kernel-1.0-3123
  /bin/sh        is needed by NVIDIA_kernel-1.0-3123
  /bin/sh        is needed by NVIDIA_kernel-1.0-3123

I have kernel 2.2.19 of linux, and 3.4.x of rpm
I know the sh command works because I used it to upgrade my xwindows just earlier, and have used the NVchooser.sh program as well!

This all occured after the make install command from the .tar.gz failed as well. I feel like I'm almost there but something is just a little bit off!! any help would be greatly appreciated!
(When I try to do it with the .tar.gz files, I get unresolved symbol errors and it does not complete.)

utiel 09-17-02 10:05 AM

dependencies...
 
I have no tried with a 2.2 kernel...

I supose you have an old Redhat, 6.2

Try rpm -ihv /usr/src/redhat/RPMS/i386/NV* --nodeps
and if this fails
rpm -ihv /usr/src/redhat/RPMS/i386/NV* --nodeps --force

This omit all depenciencies and checks.

When I compiled Nvidia's Tar.gz, I needed having my kernel configured( I ever compile and install my custom kernel )

but now, I am using Redhat Limbo, beta 3 ( null) and is up2date in all packages

Also, I have made a simply guide to install in Limbo beta3.

Only post the packages I needed with a default desktop install
Redhat Null

But I think your problems are from an old "rpm" package
Redhat updated rpm to 4.0.1(rpm-build-4.1-0.81.i386.rpm)
also, rpm's database is different too

z28Power 09-17-02 11:45 AM

Possibly the kernel
 
I may need to reconfigure the kernel and recompile, I can see that now. I am using Slackware 8.0, so it's not really that out of date, and the RPM i am using is current as well. I will try to configure kernel at home after work today as one option. Does anybody else have any ideas?

KaLeVR1 09-18-02 04:05 AM

force it
 
If you verify that you meet all the requirements you can force the install:
rpm -ivh --force --nodeps packagename

John

KaLeVR1 09-18-02 04:10 AM

also it seems to not find /bin/sh. this should be a symlink to your running shell. Do ls -l /bin/sh to see if it's there. If not, find your shell:
env | grep SHELL
This should return SHELL=/bin/bash or something like that then:
ln -s /bin/bash /bin/sh
Would be strange if /bin/sh is not already there though.

John

z28Power 09-18-02 11:55 AM

Well I ended up recompiling the kernel, and went to 2.4.5 however the make modules_install didn't work and gave me a whole bunch of depmod errors regarding unresolved symbols in /lib/modules/pcmcia/filename.o.gz, about 4 or 5 of them! I have not tried using the --force --nodep for the rpm package, however when I try to run the .tar.gz files and do a make install, it gives me the same unresolved symbol errors and will not complete the make install! Any ideas on how to resolve those? I appreciate everybody's help with this, I am just very frustrated with my first install of linux right now. So far NOTHING has worked yet! i havn't been able to compile ANYTHING and can't even get xwindows to start right without this driver!


All times are GMT -5. The time now is 07:19 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.