nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVchooser (http://www.nvnews.net/vbulletin/showthread.php?t=1956)

mike 09-17-02 05:48 PM

NVchooser
 
hey!


I tried the forum, but could not paste any message there, so then i email you
:)


When i try to use ./NVchooser


-rwx--x--x Sep 18 00:25 NVchooser.sh


i get the message ": bad interpreter: No such file or directory", so im not
sure witch rpm files im going to get. I have also tried the tar files, but i
dont have the right GCC, and im not sure where in the code i can skipp the
GCC-check.
**********************************
uname -a
Linux qnde 2.4.18-3 #1 Thu Apr 18 07:37:53 EDT 2002 i686 unknown


cat /etc/issue
Red Hat Linux release 7.3 (Valhalla)
Kernel \r on an \m

mike

z28Power 09-17-02 06:08 PM

NVChooser
 
that should tell you which rpm or tar.gz to download.
another option for you woudl be to download the .src.rpm file
after you have it downloaded, you run

rpm --rebuild "NVIDIA_kernel-1.0-3123.src.rpm"
it will kick out a bunch of code. You're supposed to look and see where in the code it says "wrote path/to/RPMs/NVIDIA_kernel-1.0-3123.i386.rpm"
then from that point you run
rpm -ivh (that path above) and it should go! the GLX file should work right off the bat. without that messy procedure. the Nvidia readme has much better step by step if you need it.

Andy Mecham 09-18-02 07:15 PM

The copy of NVchooser.sh that was posted on the driver download page had extra DOS newlines, which is why you saw that error. The file has been updated. Please redownload it and try again.

Thanks!

--andy

larryboy7 09-19-02 04:32 PM

Andy,

I am having the same problem and I JUST downloaded NVchooser.sh. Looks like thay have not fixed it yet after all...

Also, z28power, the code you submitted ends in me getting an error 404: Object not Found.

The second suggestion, though it may work sounds like the extremely long route to doing this...

Any simpler ideas on how to use NVchooser.sh?


Thanks in advance! :p

Andy Mecham 09-19-02 04:41 PM

hmm. Are you downloading and saving this on a Win32 machine? I just checked from some external sites, and the file appears to be correct for me.

In any case, this is a pretty easy problem to fix. You can try using a script like 'dos2unix', or you can use an editor like vi. ('vi NVchooser.sh', ':set fileformat=unix', ':wq')

I hope this helps!

--andy

larryboy7 09-19-02 05:21 PM

Andy,

I don't know what to say...

I swear I tried it like 7 diffrent ways and got the results I listed above...

I just tried it again and presto! It works!

Thanks for the help from a mega-newbie!

Rich


All times are GMT -5. The time now is 12:54 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.