nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Anyone out there got Nvidia AMD 64bit driver workin? (http://www.nvnews.net/vbulletin/showthread.php?t=19569)

Silent Bob 10-15-03 11:07 AM

Anyone out there got Nvidia AMD 64bit driver workin?
 
I'm about to throw this system off a bridge and jump after it, has anyone out there got Nvidia's AMD6bit driver working on anything? I've tried SUSE's and all it does is complain about kernel mismatches. Redhat's gin gin just displays garbage. Anyway rant over can anybody out there HELP ME!

:afro:

normspe 10-17-03 06:40 PM

I am having the same (bad)luck as you. I am using SLES 8, and it gives the kernel mismatch message about it being compiled for 2.4.19 and I have kernel 2.4.19-SMP. Did you notice the readme tells you to use the .run file, but you can only download the tar files?

I tried using the 2.4.19 kernel and the driver installs, but then it won't load the GLX.

I spoke with our SuSE rep and he said SuSE can do nothing since NVIDIA hasn't released the source. He also said that the NVIDIA cards will work much better with their workstation AMD64 O/S coming out in a few weeks, but we will see that when it happens.

By the way...tell me which bridge you will throw it off, I'll wait at the bottom for it to land on my throbbing head.

Here is config:

Tyan 2885ANRF
Dual Opteron 246
16 GB DDR ECC
Quadro FX500

Hopefully we won't have to deal with the bridge.

Tim:mad:

mborgnia 10-20-03 12:18 AM

Well, I recompiled the kernel and the mismatch message went away. However, KDE will not start, back to square 0 (C notation).
Nothing seems to be out there as an alternative to NVIDIA, I called ATI and they told me their drivers do not work with 64 bit, is that true?. Has anybody tried running the opteron system with, say RedHat9 (32 bit). Will the card work there?

Silent Bob 10-21-03 04:48 AM

Hi there,

thanks for the reply, I've just about given up for now. I've tried a couple of Redhat Beta releases the 64bit AS and WS offerings with the same results. I will try the later version of SUSE when they release it.

Thanks again for replys. I'm glad it not just me losing my mind.:D

normspe 10-21-03 01:55 PM

I jumped the gun on this post...originally posted a solution, but it never loaded the GLX and I am still at the point of loading drivers.

Sorry for the confusion.

imapilot 11-03-03 02:24 PM

No luck on Mandrake 64amd-beta2 either
 
I've tried to compile the NVIDIA 4499 on a dual opteron running the Mandrake 9.2 amd64 release, kernel 2.4.22-15mdksmp. The GLX compiles / installs fine. The Kernel module compiles, but does not link with the error:

depmod: *** Unresolved symbols in /lib/modules/2.4.22-15mdksmp/kernel/drivers/video/nvidia.o
/lib/modules/2.4.22-15mdksmp/kernel/drivers/video/nvidia.o: unresolved symbol mem_map
/lib/modules/2.4.22-15mdksmp/kernel/drivers/video/nvidia.o:


sorry, no help, just more bad news. If anyone HAS gotten the NVIDIA drivers to compiler on Mandrake 9.2amd64, I'd like to hear about it!
Matt K

TheOneKEA 11-03-03 03:25 PM

Have any of you tried a recent 2.6.0-test kernel? The agpgart code in the 2.6.0-test kernel is much newer and more up-to-date than the 2.4 code, and includes full support for AMD64 AGP bridges, IMO.

Try the 2.6.0-test9 kernel, available from www.kernel.org, and see what happens.

kdgassiot 11-03-03 04:36 PM

Tried the 2.6-test9 kernel. It won't compile.
CC [M] arch/x86_64/kernel/msr.o
make[1]: *** No rule to make target `arch/x86_64/kernel/cpuid.c', needed by `arch/x86_64/kernel/cpuid.o'. Stop.
make: *** [arch/x86_64/kernel] Error 2
l

Oooops :)

I have been trying to get AGP working for months on the Tyan motherboard. They moved the 8151 chip off of the first Hypertransport bus, and the agpgart code only looks on the first bus. AGP works on other motherboards with the 8151, just not the one I want to use :( There is supposed to be a fix, (I got the fix for AGP), but now the Nvidia driver is broken on the new version of the kernel.

The 4180 version worked great on the 2.4.19 kernel from SUSE that I was running on an Athlon 64 system.

TheOneKEA 11-03-03 05:58 PM

Whoops. Then try 2.6.0-test9-mm1.

http://www.kernel.org/pub/linux/kern...0-test9-mm1.gz

To apply the patch, cd into the linux-2.6.0-test9 directory, and run this command:

zcat /path/to/the/mm/patch/file/2.6.0-test9-mm1.gz | patch -p1

Then run make xconfig again, and then rebuild the kernel.

kdgassiot 11-04-03 10:09 AM

Nope, same error...

CC arch/x86_64/kernel/init_task.o
CC [M] arch/x86_64/kernel/msr.o
make[1]: *** No rule to make target `arch/x86_64/kernel/cpuid.c', needed by `arch/x86_64/kernel/cpuid.o'. Stop.
make: *** [arch/x86_64/kernel] Error 2

The Makefile specifies a cpuid.o, but there is no cpuid.c to make it with. There is a cpuid.c in the i386 tree, but not in the x86-64 tree.

Is this an oversight, or an architecture change ?

TheOneKEA 11-05-03 03:53 AM

Whoops.

Set CONFIG_X86_CPUID to N and try again.

beaner 11-05-03 09:53 AM

wow
 
Finally, I received an email from someone.

Andy Mchann I believe.

here is what it said.

- "This is a problem with the SuSE -kernel-source RPM; it is incorrectly
-configured. You'll need to do the -following:

-cd /usr/src/linux
-make menuconfig
-enable SMP support
-save your kernel config
-make dep

-I hope this helps! Thanks!"

This part actually worked. I was finally able to run the NVIDIA-kernel makefile.

I modified the XF86Config file to have the nvidia driver loaded and I did get the nvidia splash screen.

It froze after that but at LEAST I'm moving now...

I hope this helps annyone who has the same problem!


All times are GMT -5. The time now is 02:40 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.