nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia/X do not start (http://www.nvnews.net/vbulletin/showthread.php?t=19616)

anzy 10-16-03 08:49 AM

nvidia/X do not start
 
When I boot into root and type startx at the command prompt, I get the following error message:

Using config file: "etc/X11/XF86Config-4"
Using vt 7
NV: could not get NV card info (Invalid Argument)
(EE) NVIDIA (0): Failed to initialize the NVIDIA kernel module
(EE) NVIDIA (0): ***Aborting***
(EE) Screens found but none have a usable configuration
Fatal server error
No screens found
XIO: fatal IO error 104 (Connection reset by peer)

What do I have to do to get the nvidia driver to work? I have updated to the most recent NVIDIA driver and updated Mandrake 9.1 from the update site but it does not work. Are there any other logs I should consult?

More information on problem:

Hardware
GeForce 4200
ASUS A7V8X with VIAKT400 Chipset
Distribution - Mandrake 9.1
Athlon XP 1800
Nvidia driver version 1.0-4496

When I type in lsmod I see nvidia in the list.
I have made sure that both binutils and libbinutils.rpm were installed before installing the driver.
I have made sure that in modules.conf, I can see the lines alias /dev/nvidia* nvidia and alias char-major-195 nvidia.
I have altered module section of XF86-Config4 and added the line glx and removed the other lines.
I tried using version NVIDIA-Linux-x86-1.0-4349.run because it sometimes work better to no effect.
When I replace "nvidia" in XF86Config-4 with "nv" X starts with no problems.
The nvidia driver version I have tried to install is 1.0-4496.
Another piece of information that may help. When I install the driver, everything works as it should, meaning I see the nvidia splash screen and then I am able to boot into KDE with no problems. However, when I reboot, I get the error message.


Some logs:
This is the content of my XF86Config-4 file

# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection


Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "DPMS"
EndSection
(data below removed to shorten the question)

lspci command yields:
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400 AGP] Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge
00:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
00:08.0 RAID bus controller: Promise Technology, Inc. PDC20376 (rev 02)
00:09.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5702 Gigabit Ethernet (rev 02)
00:0b.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
00:0b.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev 03)
00:0b.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port
00:10.0 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master IDE (rev 06)
01:00.0 VGA compatible controller: nVidia Corporation NV28 [GeForce4 Ti 4200 AGP 8x] (rev a1)

lspcidrake yields:
unknown : VIA Technologies Inc|VT8377 CPU to PCI Bridge
unknown : VIA Technologies Inc|PCI-to-PCI Bridge (AGP)
ohci1394 : VIA Technologies|OHCI Compliant IEEE 1394 Host Controller
unknown : Promise Technology, Inc.|PDC20376
tg3 : Broadcom Corporation|NetXtreme BCM5702X Gigabit Ethernet
audigy : Creative Labs|EMU10K2 Audigy Audio Processor
emu10k1-gp : Creative Labs|EMU10K2 Audigy Gameport
ohci1394 : Creative Labs|EMU10K2 Audigy IEEE1394 Firewire Controller
usb-uhci : VIA Technologies|VT82C586B USB
usb-uhci : VIA Technologies|VT82C586B USB
usb-uhci : VIA Technologies|VT82C586B USB
ehci-hcd : VIA Technologies Inc|VT8235 USB Enhanced Controller
unknown : VIA Technologies Inc|VT8233A PCI to ISA Bridge
unknown : VIA Technologies|VT82C586 IDE [Apollo]
Card:NVIDIA GeForce4 (generic): NVidia|GeForce4 Ti 4200 with AGP8X
unknown : Linux 2.4.21-0.13mdk ehci-hcd|VIA Technologies, Inc. USB 2.0 [Hub|Root Hub]
unknown : Unknown|USB UHCI Root Hub [Hub|Root Hub]
unknown : Unknown|USB UHCI Root Hub [Hub|Root Hub]
unknown : Unknown|USB UHCI Root Hub [Hub|Root Hub]
unknown : Logitech|Logitech Freedom 2.4 [Human Interface Devices|No Subclass|None]

chkconfig --list xfs yields:
xfs 0:off 1:off 2:on 3:on 4:on 5:on 6:off

rpm -q XFree86 yields:
XFree86-4.3-5mdk

I have made sure that the option PNP OS option in my BIOS is set to No. I do not see an option to assign an IRQ to AGP.

chris26 10-16-03 08:16 PM

Hi,

I had the same problem, no one posted a solution for it. I asked on several forums. I recommend you just switch back to "nv" until NVIDIA decides to update their drivers. It just doesnt work on some systems, I think.

Pitabred 10-17-03 03:06 AM

Or you could realize that the nvidia driver isn't loading for some reason. type "modprobe nvidia" at the command prompt and see what comes up. If it says it can't find module nvidia, then there's your problem. Try installing the drivers again.

TheOneKEA 10-17-03 05:18 AM

Not necessarily. It could be that the nvidia module is loading, but that his agpgart drivers are not configured correctly.

anzy: After trying to start X, post the entire contents of the output of the command 'dmesg.'

anzy 10-22-03 10:52 AM

When I run lsmod, I see nvidia in the list, which would indicate that the module is loaded.
When I go through dmesg (sorry, I don't have a log capture) I see a message that says "unable to determine aperture size." I think this is due to a conflict between the KT400 chipset and my 4200 8x nvidia graphics card, which seems to be somewhat incompatible.
I do not know how to configure agpgart. Can someone tell me how to do this?
There was also someone who recompiled their kernel with anew version of the agpgart. I have no idea how to do this. It is the next step in my Linux learning.

recbo 10-23-03 08:49 PM

easy, you're so close
 
Your X log is telling you that the kernel nvidia module has not been loaded before X.

insmod /lib/modules/2.6.0/kernel/drivers/video/nvidia.ko

then startx and you should be fine.

if you have nvidia.ko compiled from the http://www.minion.de/nvidia.html

recbo 10-23-03 08:52 PM

sorry, kt400 stinks
 
You did insmod nvidia.ko and it failed, I see.

If you had agpgart in the kernel, you have about one option. Take it out, let nvidia.ko do it's own agp!

I didn't try that. I just yanked out the kt400 mobo and stuck in an nforce2 mboard because my kt400 was only agp4 and I was stuck where you are, too.

Miky 12-02-03 03:34 AM

I have the same problem you guys have.
And i'm still waiting for NVIDIA to release new drivers for my mdk 9.2
:(:(:(:(:(:(

please, if one of you guys have solved the problem mentioned, post the solution.

Thanks in advance.
Miky

WmCook 12-02-03 01:55 PM

The solution for me after untold hours of frustration was to download the new bios for my Epox motherboard - it then worked perfectly.

Sir_Brizz 12-02-03 11:45 PM

new as in 3a17, ie released in october this year?

TheOneKEA 12-03-03 04:20 AM

Quote:

Originally posted by WmCook
The solution for me after untold hours of frustration was to download the new bios for my Epox motherboard - it then worked perfectly.
Figures, huh?

:rolleyes:


All times are GMT -5. The time now is 04:45 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.