nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia kernel 4496 in 2.4.21 kernel problems (http://www.nvnews.net/vbulletin/showthread.php?t=19631)

rs-pcv 10-16-03 01:45 PM

nvidia kernel 4496 in 2.4.21 kernel problems
 
1 Attachment(s)
I have the following:-
Sony Vaio RS series PVC-RS226
Pentium 4 2.8G wi Intel chipset 865pe (ASUS?)
GeForce 5200 128 mb (onboard)
Onboard sound
Sony display SDM-HS53 (though not an issue)

Redhat 9.1 with alternative kernels in Grub including 2.4.20-20.9smp and 2.4.21-20.1.2024.2.1.nptlsmp.
Having compiled in the headers etc. for nvidia kernel 4496 all works, though there are a few slips for the unwary.
However sound does not work for this board with this kernel. Research tells me that it only works with a 2.4.21+ kernel. I have patched the kernel and sound does work.
The problem then is to bring back up the nvidia support.
Following the logic of the drivers page directs one to the NVIDIA_kernel-1.0-4050 driver (although supported cards do *not* include GF 5200).
If I try to compile this into the new kernel it aborts with a complaint about the -m flag values being out of range. So I cannot comile that driver into that linux kernel.
If I compile in the 4496 kernel to that linux kernel this seems to go OK but when I start X that process aborts with a signal 11 and I don't believe much of anything else helpful. (This is not in the attached log file. I have looked for it but I think I would have to regenerate it doing all of the above.)
What to do?

mat_123 10-17-03 01:36 PM

hi

iam a newbie in linux, although i dont know the answer to ur question could u guide me as to how to compile the nvidia interface module.....

and where to get the interface

will be grateful for ur help

rs-pcv 10-17-03 08:56 PM

nvidia kernel and lib install
 
the kernel drivers are available off the nvidia site. Be careful to match with your version of linux and your own card.
Their wizzard walks you through the selection, though, as you can see, it seems inconsistant to me.
once downloaded you should log in as root and without X. There are various ways to achieve this, but the end result is that you must navigate to where you downloaded the kernel from the command prompt. Obviously there can be complications to this if you have no graphics to begin with (as I didn't). In my case I used the dual boot of this machine to burn the drivers onto a cd which I then accessed from the command line.
Instruction on the web site and in the install instructions give the correct form for calling the run script. You will find that the file name in the install file is different to that you have downloaded, be sure to note that actual name. There are other issues such as if X fails to start it will enter a routine where it tries to automatically fix itself. If you know it will fail this due to incorrect or absent drivers it is better to cancel out of this. In worse cases you may be confronted with a blank screen (I was.) I found I had to reboot (with the reset button) and cancel out of that routine as above.
Having got to this point with luck the install script throws up a basic graphics screen.
Read the doco for exact sequence of questions. You need to get to the point where you can decide if you want to compile in the headers (presumably) or download precompiled versions suitable for your kernel.
The script asks various questions as it proceeeds. You will probably want it to compile in the headers to your distro, but that choice is not straight forward as there must be compatability between the version of gcc (I think) the kernel was compiled with and the one your system has (that was used top compile your kernel. If I remember 2.3.x is is OK, read the doco.)
With that done the rest should be plain sailing.
You should be able to start X by typing X at the command line. However, really you should reboot so that your graphics front end can load properly.
There are no doubt other commands that can be issued at the command line that would hhelp with all of this, but this is as far as I know. I do know that instead of getting into trouble with blank screens as mentioned it is possible to edit one of the startup conf files. I decided not to do it that way though.
HTH
Adam

rs-pcv 10-17-03 09:00 PM

follow up to this problem
 
I notice that when using xine playing a CD the tracks are recognized and there is a regular blip coming from the speakers. So something is coming through that is connected to the play of a CD (something cyclic), obviously the sound is there in some way, but some connection is missing. So what am I missing, I need to reconfigure something, but what?

mat_123 10-19-03 03:09 AM

hi thank for extensive help

i did find the interface module, but i got some error while compiling them
dont know wht could me the problem..
could u suggest something..

as for ur sound problem, iam having a similar problem and posted a question in linux and software in this forum- u could check it out there...

thanks


All times are GMT -5. The time now is 10:43 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.