nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Red Hat 9 Network Problem (http://www.nvnews.net/vbulletin/showthread.php?t=19689)

smrtjustin 10-17-03 08:13 PM

Red Hat 9 Network Problem
 
I cannot get my Network Card to work. My LAN system is part of my Motherboard (nforce 2). I have downloaded and installed the proper driver. I get this error message: nvnet device eth0 does not seem to be present, delaying initialization. I'm running Red Hat 9

Velcro 10-18-03 03:18 PM

im having the same problem. RH9, Chaintech 7njs Ultra, Barton 2500+, Abit TI4200 Siluro

playaz 10-19-03 04:02 PM

I have seen this problem if the module is not installed. Try using "insmod" on the nvnet module.

Within your /etc/modules.conf file, you should also have a mapping to a ethernet interface. ie.

alias nvnet eth0


Then use "ifup eth0"

Also, make sure you the correct rpm package for your kernel. You can always use the .tar.gz file and follow the instruction found on the NVIDIA website.

brealer 10-19-03 08:16 PM

im having the same prob. im running RedHat 9 on an Asus A7N266-VM (nForce)
my /etc/modules.conf is configured with the correct alias
when i type ifup eth0 I just get the error message, "nvnet device eth0 does not seem to be present, delaying initialization", again.
i installed using the rpm for RedHat 9, i have also tryed installing the source files still no joy. im all fresh out of idears can anyone help?? :confused:

eagle17 10-19-03 09:11 PM

Ok maybe the earlier post wasn't clear enough... you will need to try this.

edit the /etc/modules.conf and make sure the line "alias nvnet eth0" is in there without the quotes.

then type this in a terminal window,

insmod nvnet

now to be safe I would reboot and you should get a found new hardware screen asking you if you want to configure it.

Linux_Lancer 10-20-03 01:35 AM

Eagle17, I am having the exact same problems and I've tried what you suggested with no luck. I have an MSI KN2G-ILSR with a Barton 2500+. I don't have any special modifications to the kernal (I just did a fresh install with RH 9.0) I am using BIOS version 1.4. Any more suggestions?

playaz 10-20-03 01:24 PM

bios setting
 
I'm sure you have already enabled the Ethernet device from the BIOS, but I thought I would double check anyways. :)

harmonicace 10-20-03 02:55 PM

I am having the same problem on my computer.

I have a windows installation on a western digital HD and redhat 9.0 installed on a second hardrive. My connection works fine and dandy on the WinXP installation but I am getting the same error messages from Redhat as everyone else has stated.

As soon as I get home I'm going to try that last suggestion and I hope that'll solve the problem.

brealer 10-20-03 02:59 PM

i got it working thanks for all your help people.
Linux_Lancer, Velcro & smrtjustin if u lot r still having the same prob try this it worked for me.
install the kernel-source rpm from cd two then install the nforce drivers using the source files
then type "vi /etc/modules.conf" and add the following lines
alias eth0 nvnet
alias sound-slot-0 nvaudio
alias usb-interface usb-ohci
then type "insmod nvnet"
reboot the kudzu should run and ask to configure your hardware then prompt you to configure networking select yes and the rest is as they say history.

thanks again to playaz & eagle17 i think i was just being a dougnut :D

harmonicace 10-20-03 09:53 PM

Well, I tried what you said. I got the source files and ran makefile (I assume that was all I had to do) and it printed out a lot of text showing that it did somthing.

I then checked the module.conf file and the appropriate lines were there except that "alias nvnet eth0" was "alias eth0 nvnet".

I then rebooted and nothing changed as far as I could tell from the start up. I went to network setting and tried to activate it and got the same message as before. I then went into each folder of the "nvidia" that decompressed from the tar.gz and none of them had anything to do. I figured that the first one did it all but I might as well check.

Anyways, the only difference I find is that now the "hardware" tab of the network settings utility shows that I actually have a device called "nvnet" but there is no progress in getting it to activate.



tomorrow I go out of town for a trip to mexico and I probably wont have access before I leave and definitely none while I'm there. I will check in again when I get back on thursday night.

Thanks for all the help posted so far.

brealer 10-20-03 11:33 PM

type rpm -qa |grep kernel
to make sure you the have RedHat kernel-source rpm installed first if not install this its located on the second instalation cd and for some reason is not installed by default

Obsidian 11-27-03 01:04 PM

I'm still having trouble with the LAN on my Asus A7N8X-VM with Red Hat 9.0.

I installed the nVidia nForce rpm without any problems. Now my LAN is detected as eth0, but it is not active (much like everyone else). My /etc/modules.conf is correctly annotated with alias eth0 nvnet.

ifup eth0 yields: nvnet device eth0 does not seem to be present, delaying installation.

insmod nvnet yields: no module by that name found.

I did a search of all directories for a file named nvnet and it found nothing. I rechecked and the rpm was installed properly. It's closer than I was before adding the rpm, but I'm stuck.

Any thoughts? Happy Thanksgiving!

-OBSIDIAN-


All times are GMT -5. The time now is 03:20 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.