nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Remote Accelerated GLX and Raster Display Oddity (http://www.nvnews.net/vbulletin/showthread.php?t=1979)

dzzero 09-18-02 08:53 AM

Remote Accelerated GLX and Raster Display Oddity
 
We are running remote X application from a Tru64 server and displaying it on RedHat 7.2 and 7.3 linux station using GeForce 3 and GeForce 4 cards.

The application makes use of GLX calls and therefore accelerated remote GLX (our primary reason for choosing nvidia cards).

The window of the application has 2 frames in which raster data is displayed. One window is static and the zoom level is preset and not changeable. The second window can be zoomed and panned.

The first instance of this application works perfectly. Yet, if we close that application, reopen it and then open the same dataset as before the raster data in the secondary zooming window is loaded but will not display. Almost as if a buffer someplace is not being cleared prior to opening the app or upon closure of it.

This does not happen on Matrox G200 or 3dfx Voodoo3 cards but these cards for obvious reason are painfully slow and render the application unuseable.

If we shut X down and hence the nvidia driver everything will work perfectly again one time.

Also if we pull up a new data set there is probably a 20-30 percent chance that that data will be displayed properly.

Does anyone have an idea what might be happening and/or what might fix this?

Thank You.
Jason

D-Cubed 09-18-02 12:18 PM

FINALLY! someone who's experiencing a problem similar to mine. well, it sounds similar, anyway. if you ever figure out what is causing it let me know.

i have an app that uses a GL screen in an xforms window. the first time it runs, the GL screen works fine, the second time and each time thereafter, until i restart X. i've run it on GeForce 2, 3, and 4s with RH 7.3 and 7.2. and several versions of X.

i spent days trying to find out what the problem was, and the only conclusion i got to was that when i downgraded to 1541, it worked. everything newer than that (2802, 2880, 2960, 3123) did the same thing.

it seemed no one else was having this trouble. i wonder if it might have something to do with the forms we use with the GL screens.

please let me know if you figure it out. and email me at dmd2@andrew.cmu.edu. and i will let you know if i figure anything out.

dzzero 09-18-02 01:59 PM

Welp, I tried as you mentioned. I went back and got the 1541 GLX and kernel src RPM. Uninstalled, rebuilt and rpm -ivh'd it all.

The app appears to be running perfectly now.

Ok nvidia what did you do to the drivers? heh

I hope this does not exist in the drivers when used with Quadro cards because we would love to start testing them and perhaps start working with stereo.

D-Cubed, thanks! This helps us a lot.


All times are GMT -5. The time now is 03:56 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.