nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   FSAA not working with 2.4.18-10 and 1.0-3123 (http://www.nvnews.net/vbulletin/showthread.php?t=1997)

perryd 09-18-02 10:59 PM

FSAA not working with 2.4.18-10 and 1.0-3123
 
I have not been able to get any FSAA to work with RH7.3. __GL_FSAA_MODE has the value I export when I run env. I even have set the environment variable globally in .bashrc, but when I run FlightGear, there is very noticable aliasing. My screen resolution is 1600x1200 and depth 16. I even installed FlightGear under Cygwin on and WinXP partition and confirmed that all antialiasing settings work with FlightGear under WinXP and the latest Nvidia driver.

I thought I might have created the problem by editing and recompiling joydev.c, but since I had saved the original joydev.o, even with the original joydev.o back (and with 2.4.18-5 which matches the original joydev.o), there is no affect of exporting __GL_FSAA_MODE= 1 or 2 or 4 or 5.

This evening, I removed Nvidia_GLX and NVIDIA_kernel and replaced XF86Config with the "nv" version, rebooted and ran RedHat up2date to update to 2.4.18-10. No errors. Edited lilo.conf and ran lilo, and rebooted into 2.4.18-10 and reinstalled the kernel rpm from the source rpm and installed the GLX rpm. Everything worked, but still no FSAA! Yes this is with either 1.0-2960 or 1.0-3123.

My system is an AMD Athlon XP 1800+ in an ASUS A7M266 motherboard with 512MB of PC2100 and a Seagate Baracuda IV 80G HDD. The card is a GF3 (ASUS V8200 Deluxe). FSAA used to work with RH7.2 with __GL_FSAA_MODE set to 1 or 2 and older drivers (1.0-1541 I think) on this system. It would lock up with value 4 or 5.

How can I find what the problem is? I am no newbie, but I have no way to check if the drivers even are accessing the environment variables. I hate closed source drivers!!

Will somone from NVIDIA please respond! This is my 3rd post of this problem.

Klaus-P 09-19-02 05:37 AM

Did you also tried

__GL_FSAA_MODE="1"

with " " and no space left between = and "1"

perryd 09-19-02 06:08 PM

Yes, I have tried putting quotes arround the number. Still no FSAA.

But thanks for the try!
Dave

Klaus-P 09-20-02 05:28 AM

Did you also checked the NvAGP option? Default is AGPGART that comes with
the Linux kernel and not NVAGP. AGPGART must not be statically
compiled into your running kernel if you want to test NVAGP.
The default was CHANGED with the newer driver versions! Cf. the GLX README

If all fails, "linux-bugs@nvidia.com"

perryd 09-20-02 07:32 PM

Yes, I tried NvAGP set equal to 0, 1, 2, and 3. I ran
startx -- -logverbose 5

each time to confirm that X was interpreting this correctly. It was. Still no FSAA in FlightGear.

This system is completely stable with the new 1.0-3123 drivers. But no FSAA no matter what I try!

I wish there were a log file that shows how the NVIDIA driver is interpreting the environment variables.
Thanks again!

perryd 09-20-02 10:22 PM

Well, FSAA works on my system under Linux!

I recalled that my son had written an opengl test program in C (I am attaching it.) this simple program draws a diagonal line in a window labeled "Hello". By resizing this window, you can see clearly the affect of the various values of the environment variable
__GL_FSAA_MODE
you change with
export __GL_FSAA_MODE=n
where for my GF3, n=0 and 3, there is no FSAA, and for n=1, 2, 4, and 5 there are various degrees of FSAA (see pp 51-52 in the NVIDIA pdf docs)

For some reason, FSAA is still better in FlightGear running under Cygwin and WinXP than under RH7.3 Linux. Anyone know why?

The attach won't take the .c or the make file, so I will paste them here for your use. Hope this can help someone else!

test.c

#include <stdlib.h>
#include <GL/gl.h>
#include <GL/glut.h>

static void display(void) {
glClear(GL_COLOR_BUFFER_BIT);

glColor3f(1.0, 1.0, 1.0);
glBegin(GL_LINES);
glVertex2f(0.0, 0.0);
glVertex2f(0.5, 0.3);
glEnd();
glFlush();
}

static void key(unsigned char k, int x, int y) {
switch (k) {
case 27: /* esc key */
exit(0);
break;
default:
return;
}
glutPostRedisplay();
}

void init(void) {
glClearColor(0.0, 0.0, 0.0, 0.0);

}

int main(int argc, char **argv) {
glutInit(&argc, argv);
glutInitDisplayMode(GLUT_SINGLE | GLUT_RGB | GLUT_DEPTH);
glutCreateWindow("Hello");
init();
glutDisplayFunc(display);
glutKeyboardFunc(key);
glutMainLoop();
return 0;
}

makefile

test: test.o
gcc -Wall -Wstrict-prototyes -Wnested-externs -Wno-format -Wp,-lang-c89 test.o -lGL -lGLU -lglut -lm -o test

# -lXmu -lSM -lICE -lXt -lX11 -lXext -lm -o test

test.o: test.c
gcc -c -Wall -Wstrict-prototypes -Wnested-externs -Wno-format -Wp,-lang-c89 test.c -o test.o

clean:
rm -f test.o test















gl


All times are GMT -5. The time now is 03:53 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.