nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   blank screen after stopping X (http://www.nvnews.net/vbulletin/showthread.php?t=200246)

stabu 01-24-13 09:04 AM

blank screen after stopping X
 
Hi,

For some time I have been trying to approach this problem where, after installing the nvidia 5.0 drivers, everything works fine, until I decide to close down the X server, whereupon I get a blank screen with no prompt. What is meant to happen is that I get my virtual console prompt again.

Primarily I get this on my Macbook Pro using Archlinux, but I have in fact had this with other machines too, using ubuntu linux, so I venture to say that it is not unique to the macbook. This did not happen with the v4 drivers.

I can login to the laptop from another computer and see that, after closing X, my login session is still active and X has closed down correctly, with no errors, so some sort of screen anomaly is taking place.

Of the other machines I have tested this with, one did not behave in this way, apparently due to the "nomodeset" option which I gave to the kernel boot. Of course, this means that the virtual console that I returned to has the 60 column resolution which is too primitive for me now.

Now I'm continuing to test this out, but I thought I'd post the problem here in case someone has also had it. I'm not convinced it's an nvidia problem either -although I am suspicious of it - it could also be a linux / screen or virtual console problem of course with nothing to do with nvidia.

Many thanks!

brebs 02-03-13 05:24 AM

Re: blank screen after stopping X
 
What do you mean by versions 4 & 5? Should be e.g. 310.32, 313.18


All times are GMT -5. The time now is 06:57 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.