nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   3123 drivers and inspiron 8100 not working (http://www.nvnews.net/vbulletin/showthread.php?t=2020)

w3a5e1 09-19-02 06:36 PM

3123 drivers and inspiron 8100 not working
Im trying to get the 3123 drivers to work on my dell inspiron 8100. It has a gf4 440 go. The 2960 drivers worked fine. With the new drivers I can not get any output to my lcd screen(a 1400x1050). When i startx it just goes black I can't get back to my console even if kill the x server. But i can attach a external monitor and switch the output to it. But i can not get the x server to come up on the LCD. The log complains about not being able to validate any of the modes, expect for 640x480, wich it uses and then starts up with out error, but no output. If i switch back to the 2960 drivers everything is fine.
Any suggestions? thanx

w3a5e1 09-19-02 08:45 PM

Well, i swaped out my GF4 go for the GF2 go and these drivers work. So something was changed between 2960 and 3123 that is preventing my gf4 go upgraded inspiron8100 from working. Does anyboady with a simillar setup have the new drivers working? What about an upgraded 8100 with a 1600x1200 screen? My 1400x1050 is made by IBM. I would really like to know what has changed that brought about this problem. I sure hope it wasn't intentional.

utiel 09-19-02 08:49 PM

try option IgnoreEDID
Try this option, in XF86Config, in Section Device,
Option "IgnoreEDID" "true". It override monitor resolution.


Section "Device"
Identifier "RIVA TNT2"
Driver "nvidia"
VendorName "RIVA TNT2"
BoardName "RIVA TNT2"
Option "IgnoreEDID" "true" #Ignore monitor resolution
Option "NoLogo" "true" #Dont show Nvidia logo at startup
Option "NvAGP" "1"

Furball 09-21-02 02:36 PM

HI, I have the exact same setup, and the exact same problem, and Nvidia messed something up major. Works great with 2960. Also the fix above doesn't work, The screen just blanks out completely and when you exit X you can't even see console text. Nvidia Please fix...


w3a5e1 09-23-02 01:40 PM

From reading the dell fourms it looks like people are having the same problem on the windows side.

neneonline 09-24-02 02:11 PM

The same happends to me :S
I have an 8200 Dell Inspiron Laptop with the nVidia GeForce 4 440 Go and a 1600x1200 display.

The kernel module seems to work and so does the X server... but no output. If I use the option:

Option "ConnectedMonitor" "DFP"

My display begins showing something... but the problem is something weird. Just in case it was a matter of refresh frequency I explicitely set everything with the data I got from fbset. But the same happends...

I have tried both with kernel 2.4.18 and 2.4.19, using and not using frame buffer, and changing a lot of options in the nvidia driver... but nothing works.

w3a5e1 09-24-02 06:07 PM

Does nvidia monitor these fourms, is there some one specific we could report this problem to?

Furball 10-14-02 05:33 PM

Hey Andy (of Nvidia) can you comment on this, I can't use my laptop under Linux until Nvidia fixes this problem and brings out a new driver! And all I really want is 2D, also I have a question, why are the 2D driver and the 3D driver now intergrated, so that one cannont be without the other. In early Nvidia driver realeases, I whould (on my desktop) us e the loadable module for 3d stuff, but I would use the opensource "nv" driver for 2D. Well my real thing here is why doesn't NVIDIA Bring out a pure 2D driver for Geforce 4 & 2 go users. I would finally like to suspend my laptop. I'm a gamer, but as of late I'm a serious programer too. And Linux is what I need to work under. I don't want to be forced to put an ATI in my next laptop, because Nvidia can't recognize the needs of their Linux laptop users.

Furball 10-14-02 05:36 PM

Oh I also forgot to mention that I can't go back to 2960 because the module that NVIDIA compiled in it was compiled with gcc 2. I've upgraded to RedHat 8 and guess what , modprobe spits at me and tells me to go to hell. So I'll have to get gcc 2.95 ,compile it, recompile my kernel and every other module with it to make it work. Now the latest drivers compile fine, but something was majorly screwed up for Geforce 4 go users.

Andy Mecham 10-14-02 06:12 PM


I'll look into reproducing the problems you're describing. As a follow-up, please send a mail to linux-bugs@nvidia.com reporting this. As a workaround, you can try using 'insmod -f' to insert the 1.0-2960 NVdriver on RedHat 8.0.

With regards to your other question: You can use the "nv" driver for 2D. The "nv" and "nvidia" drivers are not dependent on each other in any way. However, 'nv' support for the GeForce4 GO cards is only available in XFree86 CVS, as there hasn't been a (non security-fix) release of XFree86 since January.

I hope this answers some of your concerns...



Furball 10-14-02 08:22 PM

Thanks Andy, you deserve a raise. Thanks for the info, I haven't checked the XFree CVS in ages. It's really nice to know that someone at Nvidia is listening too us.

All times are GMT -5. The time now is 11:48 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.