nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Getting the error about the kernel source tree. (http://www.nvnews.net/vbulletin/showthread.php?t=202311)

devnull 02-24-13 03:58 PM

Getting the error about the kernel source tree.
 
Hi guys, I'm trying to install the newest drivers for my GT440 graphics card. I got as far as accepting the EULA, after which it gives me this error:

Quote:

ERROR: Unable to find the kernel source tree for the currently running kernel. Please make sure you have installed the kernel source files for your kernel and that they are properly configured; on Red Hat Linux systems, for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM installed. If you know the correct kernel source files are installed, you may specify the kernel source path with the '--kernel-source-path' command line option.
After a bit of Googling, I found this thread that basically told me it means you need the kernel sources for your distribution. Following the instructions, I searched for "kernel" in the install/remove software widget, but it revealed nothing. There's nothing about kernel sources in there. So now at this point, installing video drivers has become much like a guessing game for me. Are there any links that would help me determine the proper files it needs? (I can do the legwork myself, it's just finding exactly what kernel sources I need.) I am running Mandriva 2010.1 x64.

UPDATE: I believe I found the kernel sources it needs using uname -r (it says I'm using 2.6.33.7-desktop-2mnb if I'm understanding this correctly.) So I have downloaded the sources for this kernel. Is there anything extra I need to do? Like put in a path somewhere, or anything of that sort?

UPDATE2: Okay, I believe I've come as far as I can on this. I tried installing the NVidia drivers again, and got the same error. All I can do at this point is await your suggestions. Thank you in advance. :)

devnull 02-24-13 11:27 PM

Re: Getting the error about the kernel source tree.
 
I'm getting it, slowly but surely.

I got the kernel headers installed, now I'm getting a new error:;;;;;

Quote:

Neither the '/lib/modules/2.6.33.7-desktop-2mnb/build/include/linux/version.h' nor the '/lib/modules/2.6.33.7-desktop-2mnb/build/include/generated/uapi/linux/version.h' kernel header file exists. The most likely reason for this is that the kernel source files in '/lib/modules/2.6.33.7-desktop-2mnb/build' have not been configured.
What do they mean by "configuring kernel source files?"

devnull 02-25-13 01:40 PM

Re: Getting the error about the kernel source tree.
 
Okay, I'm compiling the kernel headers now (using instructions from here. I'm crossing my fingers that this will work now. I'll post back and let you know.

devnull 02-26-13 05:44 PM

Re: Getting the error about the kernel source tree.
 
Success! After physically installing the kernel per those instructions, the installation went off without a hitch.


All times are GMT -5. The time now is 10:41 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.