nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nforce driver problems Asus A7N266-VM (http://www.nvnews.net/vbulletin/showthread.php?t=20460)

rrk 11-02-03 06:31 AM

nforce driver problems Asus A7N266-VM
Have tried slackware 9.1 and Suse 9 -- no joy
in mudville -- i have been working mainly with
slack- download tarball make make install ok
go to insmod and it says nvnet complied with
ver 2 kernel compiled with ver 3 known not to work
open to any idea's

-Q- 11-11-03 10:49 PM

This is a problem that isn't easily worked around, and the warning is there for good reason. If you must use the nvnet driver the only 100% reliable way around it probably to use Slackware 8.1 instead as it is based on GCC 2.9.

There is a way to trick modprobe into loading the driver by using objcopy to strip the gcc tokens out of nvnetlib.o before linking, which is what NVIDIA do in the latest version of the driver (261) but this caused repeatable hangs on my Slackware 9.1 system, while Slackware 8.1 was rock solid.

Using one of the older versions of the nvnet driver from the archive section on NVIDIA's website and stripping the GCC tokens by hand seemed to work pretty well for a while, but I am not sure which version I was using as I have since reformatted the box and it now runs FreeBSD instead.


wildone81 11-13-03 05:07 PM

Hmm... how to put this... I have the same mb, and I have Slackware 9.1. With both the most recent and the older nvidia drivers, I've not had any issues with compilation or loading of the module. Of course, I also compiled my own kernel, which might be your problem.

I can't say how the default kernel was compiled, but you'll have much more sucess generally if you use the same compiler for the kernel and the module. Are you sure you have gcc 3.2 installed and not 2.95? I'm fairly sure that 2.95 has been put long to pasture, but that's about the only reason I can think of you having that error. Either way, best of luck with it, slackware isn't exactly the easiest to play with on your own ;)

-Q- 11-13-03 06:50 PM

The reason for the error is that nvnetlib.o in the nvnet package is compiled with GCC 2.96 and mixing GCC 2.9 objects with a GCC 3.2x compiled kernel is known to cause major stability problems. The latest version (261) of the drivers works around this warning from modprobe as I explained in my previous post, but it doesn't fix the stability problems.

Last time I tried I was unsuccessful in getting the version 261 drivers to work on Slackware 9.1 (even with a custom built kernel) without having them lock up the system under the slightest load. Using an older version of the drivers seemed to help, but the same kernel configuration on a Slackware 8.1 base system was rock solid, so it may have been a matter of time before I found another situation that would cause 9.1 to lock up.

In the end I got sick of all the stuffing around and trashed the system in favour of FreeBSD using a port of the nvnet driver and it has been much faster and more stable ever since.


wildone81 11-13-03 07:27 PM

Heh, can't say I'm having any of those sort of issues with the 261 or the 248 drivers. With both the system was stable, though the 261 drivers ate the cpu cycles and killed bw.

Of course, this might be because I've just been upgrading Slackware from 8.1 through 9 to 9.1, with periods of CVS versions of Slackware stuffed in for the hell of it. Regardless, just looking at the output of make, it stripped gcc2 symbols from both versions of the driver. I've also patched the kernel with a few things, so that might have helped in my situation, but I've rarely had the magnatute of problems that you got, since I went with only what was actually in the system for the kernel, with a few networking options as modules.

It's nice to know that FreeBSD worked out for you, though it certainly makes no sense why Slackware 9.1 didn't like your setup. Either way, hopefully the other guy can get anything out of this mess of compiler issues :)

All times are GMT -5. The time now is 02:09 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.