nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Segmentation fault in nvnet (http://www.nvnews.net/vbulletin/showthread.php?t=20479)

edsko 11-02-03 03:08 PM

Segmentation fault in nvnet

I'm getting segmentation faults as soon as I try to use the nvnet module (latest version, 1.0.0261). I tried the driver with both kernel version 2.4.20 and 2.4.22, with the same result. When I modprobe nvnet, everything seems fine (kernel tained message, that's it), but when I then try to ifconfig eth0 (...params...), I get:

Unable to handle kernel paging request at virtual address b0c4c661
printing eip:
*pde = 00000000
Oops = 0002
CPU: 0
EIP: 0010:[<c804a003>] Tainted: P
EFLAGS: 00010206
eax: c804a000 ebx: c7568400 ecx: 00000000 edx: c73eb690
esi: c029ecd4 edi: c73eb6dc ebp: c029ec60 esp: c715de90
ds: 0018 es: 0018 ss: 0018
Process ifconfig (pid: 244, stackpage=c715d000)
Stack: c73eb6dc c029ecd4 c029ec60 c715deb0 c7568400 c73eb690 00000000 c804a000
c01e5247 c7568400 c73eb690 c73eb62c c029f09c c73eb668 c7568400 c73eb690
c0209d7a c7568400 c029ec60 00000000 c776cbe0 c7568400 bffffcb0 c73eb610
Call trace: [<c01e5247>] [<c0209d7a>] [<c020a230>] [<c020aab1>] [<c020c867>]
[<c01dbc46>] [<c013c446>] [<c01086e7>]

Code: 00 80 61 26 c0 e8 f8 04 c8 e0 66 00 00 00 00 00 00 01 00 00

Then all subsequent uses of the modutils (modprobe, rmmod) fail with a similar message. I'm not using a specific distribution, but compiled my own following www.linuxfromscratch.org, book version 5.0pre2 (hence I used the tarball form of the driver).

The kernel is compiled with the options as specified in the ReleaseNotes.html, and is patched with the patch from the distribution (I tried both with the patch and without the path, with the same result - even though that shouldn't influence it anyway).

Note that I'm not using either the audio driver (or any other audio driver), or the graphics driver (I don't even have XFree installed).

My /etc/modules.conf only contains (as in, it contains a single line):

alias eth0 nvnet

The running system is an AMD Duron 1.3 GHz on an Asus A7N266-VM/SE motherboard (which has the nForce chipset on it). I tried to compile the kernel both for the AMD Duron, and for the (simplest) 386, to no avail. Module support and module versioning support is compiled in.

I hope you can help. If you need any more information, please let me know.


blueworm 11-04-03 12:20 PM

try: acpi=off
in your bootloader kernel line.

TheOneKEA 11-04-03 12:44 PM

That Oops isn't any good without it being processed first by a program called ksymoops. Use ksymoops to process the Oops and post the output here. You can get ksymoops from www.kernel.org.

edsko 11-06-03 03:12 PM

Dump from ksymoops
As requested, here is the dump from ksymoops. To get this dump, I did

modprove nvnet (no probs here)
ifconfig eth0 (ip) (netmask) (broadcast)

The ifconfig resulted in the crash. Immediately after that I ran ksymoops on the relevant part of the kernel log.

ksymoops 2.4.9 on i686 2.4.20. Options used
-v /usr/src/linux/vmlinux (specified)
-k /proc/ksyms (default)
-l /proc/modules (default)
-o /lib/modules/2.4.20/ (default)
-m /boot/System.map (default)

Unable to handle kernel paging request at virtual address c86ba0c8
*pde = 00000000
Oops: 0002
CPU: 0
EIP: 0010:[<c804c00f>] Tainted: P
Using defaults from ksymoops -t elf32-i386 -a i386
EFLAGS: 00010282
eax: c86ba0c8 ebx: c7570800 ecx: 00000000 edx: c73eb390
esi: c02ac214 edi: c73eb3dc ebp: c02ac1a0 esp: c7171e90
ds: 0018 es: 0018 ss: 0018
Process ifconfig (pid: 86, stackpage=c7171000)
Stack: c73eb3dc c02ac214 c02ac1a0 c7171eb0 c7570800 c73eb390 00000000 c804c000
c01ee337 c7570800 c73eb390 c73eb32c c02ac5dc c73eb368 c7570800 c73eb390
c0212e6a c7570800 c02ac1a0 00000000 c776cbe0 c7570800 bffffce0 c73eb310
Call Trace: [<c01ee337>] [<c0212e6a>] [<c0213320>] [<c0213ba1>] [<c0215957>]
[<c01e4d36>] [<c013c4e6>] [<c01086e7>]
Code: 00 00 00 00 00 05 00 00 00 57 00 00 00 00 00 00 00 94 20 05

>>EIP; c804c00f <_end+7d5cceb/7d5cd3c> <=====

>>ebx; c7570800 <_end+72814dc/7d5cd3c>
>>edx; c73eb390 <_end+70fc06c/7d5cd3c>
>>esi; c02ac214 <arp_tbl+74/1b4>
>>edi; c73eb3dc <_end+70fc0b8/7d5cd3c>
>>ebp; c02ac1a0 <arp_tbl+0/1b4>
>>esp; c7171e90 <_end+6e82b6c/7d5cd3c>

Trace; c01ee337 <neigh_parms_alloc+5f/b4>
Trace; c0212e6a <inetdev_init+96/128>
Trace; c0213320 <inet_set_ifa+50/bc>
Trace; c0213ba1 <devinet_ioctl+4f5/6e8>
Trace; c0215957 <inet_ioctl+1a3/1ec>
Trace; c01e4d36 <sock_ioctl+1e/24>
Trace; c013c4e6 <sys_ioctl+16a/184>
Trace; c01086e7 <system_call+33/38>

Code; c804c00f <_end+7d5cceb/7d5cd3c>
00000000 <_EIP>:
Code; c804c00f <_end+7d5cceb/7d5cd3c> <=====
0: 00 00 add %al,(%eax) <=====
Code; c804c011 <_end+7d5cced/7d5cd3c>
2: 00 00 add %al,(%eax)
Code; c804c013 <_end+7d5ccef/7d5cd3c>
4: 00 05 00 00 00 57 add %al,0x57000000
Code; c804c019 <_end+7d5ccf5/7d5cd3c>
a: 00 00 add %al,(%eax)
Code; c804c01b <_end+7d5ccf7/7d5cd3c>
c: 00 00 add %al,(%eax)
Code; c804c01d <_end+7d5ccf9/7d5cd3c>
e: 00 00 add %al,(%eax)
Code; c804c01f <_end+7d5ccfb/7d5cd3c>
10: 00 94 20 05 00 00 00 add %dl,0x5(%eax,1)

Hope this helps.


PS. I don't have ACPI enabled in the kernel, so that cannot be the problem. Thanks for the tip though.

TheOneKEA 11-06-03 03:27 PM

Ugh. Looks like ifconfig is trying to set something that the nvnet driver doesn't like.

Have you seen this yet?


If enough people can get this driver stable, then we can all pretty much forget about the NVIDIA drivers (except for SoundStorm).

All times are GMT -5. The time now is 06:16 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.