nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Stumped: X immediatly hard locks at Splash screen (http://www.nvnews.net/vbulletin/showthread.php?t=20597)

waxor 11-05-03 08:58 AM

Stumped: X immediatly hard locks at Splash screen
 
Ok, I have tried everything I can think of.

The problem is that X will start just fine, not a single WW or EE in the logs, but the system hard locks as soon as the Nvidia logo shows up. That is if I am using the nvidia driver. I get the same lockup with the nv driver, only without the splash screen, (of course). Oh, and the system is running Debain.

By lock I mean this. No led changes when I press caps lock, unable to ctrl-alt-F1 to get back to virtual terminal, ctrl-alt-del does nothing, power button does not call acpi shutdown, and the box no longer pings.

This same config was working on my old motherboard (via chipset) and a GF2 mx AGP card. I upgraded to Abit's NF7-m, with onboard GF4, and began having this issue.


I am 100% sure my XF86Config-4 is ok. Since it has not changed from the one that worked with the old board. Just in case I re-wrote it from scratch.

It is not a broken onboard card. For one the card works fine under Win2k and I get the same lock using my old card in the AGP slot. Using either driver.

I am using a hand compiled linux-2.4.22 kernel that does have MTTR, Nvidia AGP and Nvidia ATA enabled. I have recompiled it from scratch twice now. I also have nvnet and nvaudio installed from the nforce package although I dont think that matters.

I have uninstalled, using the installer, the nvidia graphics module and re installed it many times now. So the module is not to blame.

Finally, this weekend I did a complete re-install of debian from an install disk and have done a full dist-upgrade to the sid distro. I dont think this is an issue with some other config for X11, since the only non-default file is XF86Config-4.

Can anyone think of somethign to try or something I have missed? I will post my startx log when I get back to the machine tonight.

Thanks.
-Mikel

jcn 11-05-03 04:28 PM

hard lock
 
Mikel,
i'm not a super user but i think that you have to change the driver to nvidia from nv in the config file. it's in the readme that comes with the driver. hope this helps.
ps - read the readme file, it left me stumped also.

waxor 11-05-03 04:34 PM

Those are two different drivers.
nvidia is the proprietary driver supplied by nvidia, nv is the open source driver that comes with Xfree86.

I have the same lockup issue with both drivers.

If nvidia would just open up thier linux drivers this would not be an issue. People would fix stuff when it broke. nVidia pisses me off.

Anyway, thanks.


All times are GMT -5. The time now is 03:34 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.