nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVIDIA install in Mandrake 9.2 (newbie with Linux) (http://www.nvnews.net/vbulletin/showthread.php?t=21019)

runeron 11-15-03 06:30 AM

NVIDIA install in Mandrake 9.2 (newbie with Linux)
 
1 Attachment(s)
Having trouble installing the NVIDIA driver with MANDRAKE 9.2.

This is my first time with LINUX, so please be VERY specific.. Read a BUNCH of posts on the topic, but none seemed to work (either that or I did not understand it..).

* GeForce2 GTS
* 8KHA+ Mainboard w/AMD 1800Mhz
* uname -r gives: 2.4.22-10mdl

This is what I've tried (the LAST time..):
--------------------------------------------------------------------------------------------
1) exit X with init 3 in the console, and login as root
2) enter the directory where I downloaded the driver (/home/'user'/...)
3) type 'sh NVIDIA-Linux....... -a' (or whatever)
4) after some installing, it starts to build the Kernel from my source
(I think..). Stops at about 20% and gives me an error (see below).
5) Scratch my head and consider using Windows for Neverwinter
Nights (again..).
--------------------------------------------------------------------------------------------
Short version: 'unable to load the kernel module "nvidia.o". most likely because your kernel module was built using the wrong kernel-header-files... etc. ' (by the way - I don't know how to compile the kernel..)

* Error Message (logfile) - see attachment

I HAVE installed the Kernel-Source (think it was dl'ed - added it after the install). My /usr/src/ - directory contains:

1) /linux
2) /linux-2.4.22-1mdk
3) /RPM

When i try to specify the path in the installer to the /linux-2.4.22-1mdk directory, it adds an /linux at the end..

Any help would be appreciated!

Gun 11-15-03 11:09 AM

I think you need the right version.

Try downloading kernel-source-2.4.22-10mdk

http://rpm.pbone.net/index.php3/stat....i586.rpm.html

Good luck.

runeron 11-15-03 02:16 PM

Wow! It worked!
 
I must say.. I'd like to give you a hug right now (but I'll controll myself)!

I downloaded and installed the kernel source, edited XF86Config-4, and everything worked like a charm! Thought I had the right version, but apparently I was wrong (isn't x-1 the same as x-10). Well. That does it - I'm sticking to Linux ;)

Hope it works for you as well!

powerpenguin 12-19-03 03:47 PM

YEAH!!!
 
thanks so much i had the same problem and it's now fixed :) !!!
here are my computers specs:
P4 2.4 ghz
Nvidia GeForce 4 Ti 4200 (siluro by abit)
gigabyte motherboard

yeah

anyway thanks so much (nvidia should add this to the readme or somthing cause mandrake don't include the source)

thanks again
the powerfull penguin.


All times are GMT -5. The time now is 03:21 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.