nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nforce2 mb and gentoo (http://www.nvnews.net/vbulletin/showthread.php?t=21189)

adrien1977 11-18-03 11:28 PM

nforce2 mb and gentoo
Hi, I am a newbie in the world of linux.
I have a leadtek MB nforce2 with the GPU integrated.

I have installed GENTOO with the kernel 2.4.20 in my machine.
I emerged :
I added the nvidia to the module.autoloadfile
Restarted the machine rebooted and then when I started XFREE with startx the screen went totally crazy with a bunch of weird characters and no way to do anything
So I decided to download the lastest drivers from the nvidia site, try to install it but no way to do so.
Problem finding I do not remember what. Basically it could not compile new kernels for my machine
So I read the doc and after I ran
sh NVIDIA-Linux-x86-1.0-4496-pkg2.run --add-this-kernel
So it recompiled everything and created a new file and the installation went successfully
But after a restart, same problem

So could anyone help me pretty please and tell me exactly what to do, so I can go to the next step and install KDE.

UnarmedPlayer 11-19-03 03:14 AM

Re: nforce2 mb and gentoo

Originally posted by adrien1977

Restarted the machine rebooted and then when I started XFREE with startx the screen went totally crazy with a bunch of weird characters and no way to do anything
It was my problem with the Epox 8RDA mobo.
Your BIOS could have some bugs, look for patches on the mobo website then you should use the kernel-2.4.22 instead of 2.4.20.

adrien1977 11-19-03 10:06 AM

where is the mobo website

UnarmedPlayer 11-20-03 02:58 AM


Originally posted by adrien1977
where is the mobo website

for my mother board it is:


spun_g 12-06-03 10:07 PM

using the nforce chipset & Gentoo Linux
Hello adrien1977,

I assume that you have an NForce 2 chipset and are using the K7nCR18D (or better) series of motherboards as I think they have integrated graphics.

Go to http://www.leadtek.com/motherboard.html and find your motherboard, do some clicking and you should be able to find the necessary BIOS update for you.

As for me, I built my parents a computer based on a Asus A7N266-VM mobo, with the NForce 2 chipset with Integrated GeForce 2 MX graphics, ethernet, and sound. Basically the mobo had everything so I didn't have to wad out the dough for extra junk. :afro:

I installed Gentoo from their latest 1.4 Live CDs (stage 3 of course!) and emerged both nvidia-kernel AND nvidia-glx (IN THAT ORDER). ALSO ITS HIGHLY IMPORTANT TO MAKE SURE YOUR SYSTEM HAS THE COMMAND "lspci". I think the NVidia drivers use "lspci" to figure out what card you have so as to "act" appropriately. Try emerging "pciutils" that MAY have the lspci command if its not on your system. That problem almost drove me insane for my computer (Shuttle AK35GT w/VIA-KT333 chipset), but whan I realised I didn't have lspci, it all came together WHY the NVidia drivers didn't work.

I addition, if you do also have integrated network and audio, also emerge both nforce-audio (Make sure you have the kernel sound module for the nforce chipset enabled as well, I have it compiled as a module) and nforce-net. There may be a little more you have to do, but the emerge script will tell you what to do if necessary. If you decide to recompile the kernel or update to a newer one, YOU'LL HAVE TO RE_EMERGE both NFORCE-NET and NFORCE-AUDIO each time you rebuild the kernel and modules! It sucks, but that's the way it is!

I seems that leadtek has quite a few boards with integrated graphics on their NForce 2 chipsets even with Integrated GeForce 4 MX (is that what you have?).

If you follow the above, that SHOULD work, if not, I'd recommend posting to a Gentoo forum, or reply to this post.

The Dark One 12-07-03 03:12 PM

I'd be interested to hear if you resolve this, had the same problem (have since moved to Mandrake 9.2 for the time being).

Also, I would be very interested to hear if you have any stability issues, I'm having loads under Mandrake with the machine locking up totally, but the graphics work fine

ErnieS 12-07-03 06:29 PM

I have the Leadtek K7NCR18D-Pro mobo, (without onboard video) My GeForce 4 video adapter works great. My problem is random crashes. watching logs tell me nothing, looping ps ax shows no new processes. Running xmbmon while compiling pkgs shows that I never see the high side of 52 degrees C. Letting top run in an xtermshows no problems. The crashes are ramdom with a frequency of from 1 hour after boot to 28 hours. The box was formerly very stable having been up 89 days before the first crash. Loading the hell out of the box with burnK7 and burnBX running, 32 instances of gimp running with 10 meg bitmaps open in each and all the normal processes (YEAH, I WAS SWAPPING 500+ MEGS) resulted in a crash after 8 hours, hardly the shortest time. Unloading all normally used apps and letting the machine sit 98% idle resulted in crashes after 3 hours and 5 hours.My step son has the same board, the same memory module a GeForce 4 5200 instead of my 4200 but a different case. He tends to run hotter. He may see 62 degrees C when building a large package. He, until a few days after I started to have problems, was still rock solid. As of today, he is crashing without x even running we have both run memtest 86 and our memory has passed. I run the board very conservatively and he uses slightly more agressive settings. We have each spent 20 + hours trying to figure this out and we have nothing. Stopping the onboard ethernet card looked promising as his box built gcc after killing eth0 after 3 failed attempts with eth0 up. I'm trying killing services at this point. Presently netmount noip ntpd postfix samba speechd and sshd are shut down and the box is up 5 hours (about average) Does anyone have any insight here?

adrien1977 12-07-03 06:44 PM

I just changed the bios of my mother board and it solved the problem
That is it
You also can use the module provided by the emerge

ErnieS 12-07-03 07:12 PM

Are you talking about the nforce-net package? I built the1.0-0261 from source and asleep is running the 0256.ebuild You're saying that a bios flash fixed you up?

spun_g 12-07-03 07:32 PM

Leadtek MoBo prognosis
Hey ErnieS,

Those temps sound REALLY HOT! I know you're in Jeb Bushlandia, but still 62C is on the high end. My Athlon 2500 Barton Core never breaks 39C at room temps of about 20C. Realize that I'm in Wisconsin however, and it's winter here now :cool: ! I also have a Vantec Aeroflow cooler on my processor and that is possibly the main reason of the low temps for my processor, but also the Barton core has lower thermal dissipation (smaller conducting pathways, I think). Even when I load my computer with hefty Fortran codes doing big iterative matrix solves or I'm fragging pixels in UT2003 I have yet to get over the 40C mark! Good case cooling is just as important as well! Try to get those temperatures down somehow, switch to a Barton core if your's is not already.

Other relevant questions:

=> What distro of Linux are you running?
=> Did you compile the kernel?
=> Do you have AGP "Fast Writes" or "SideBand Addressing" enabled?
=> Do you have "good" memory (Crucial, Corsair, or OCZ)
=> Do you have sufficient power supply (300W to 400W)

Diagnosing your problem is quite difficult from knowing only a single symptom.
I'd recommend starting with doing a power balance analysis. Estimate how much power your hard drives, graphics card, and processor eat up, then compare with the power rating of your power supply. Usually system weirdness can be attributable to power supply issues, but that's only a hunch.

Hope this helps!

ErnieS 12-07-03 08:12 PM

the memory is corsair and has a heat sync on it. The distro is Gentoo 1.4 stable (accept for a few packages. Yes, I compiled the kernel. Same setup for my stepson his PSU is a 400 watt and mine is a 450 each box runs a WD 80 gig drivew/8mb cache, a GeForce4 video card, and 2 cdrom drives which almost never get used. My rather quick guestimates when we built the boxes was about 350 watts. I'd more or less discount the PSU's because the crashes seem so random. Pushing the hell out of them doesn't seem to have either a positive or negative effect and in Jer's case at least, it happens without X running. Memtest86 shows no errors, burnK7 and burnBX running at the same time heat my processor to < 52 C without incident. My processor is generally sitting happily at 40 or 41 C. Of say >20 crashes over 10 days, the vast majority have come when the box is idle, sure the hdd is spun up but no seeks or swaps. Stopping the services mentioned above has me up an over average 6 hours still nowhere near a sign of success but a bit encouraging. I do have a dual fan 500 Watt supply here but I don't think it will do any good. AGP "Fast Writes" and "SideBand Addressing" are both disabled, atleast here. I actually found some minor framerate increase without them. Thanks for the input but I've been through all of this so far. I'm off to reboot and check my bios version....CRAP my floppy drive is fried!

All times are GMT -5. The time now is 02:49 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.