nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   download problem with linux NVIDIA driver packages (http://www.nvnews.net/vbulletin/showthread.php?t=214)

Timo 07-30-02 08:34 PM

download problem with linux NVIDIA driver packages
:( I have been attempting to download the 'NVIDIA Accelerated Linux Driver Set' from the ftp sites.
I have attempted to download the 'kernel' and GLX packes as both, rpm and tar files.

In all cases I have been getting download Warnings!
Because I prefer the tar file method, I will use those download errors as examples.

i.e. The following text is displayed after the tar file package download is completed:

For kernel package download:

WARNING! 1484 bare line feeds received in ASCII MODE
files may not be transferred correctly

For GLX package download:

WARNING! 5916 bare line feeds received in ASCII MODE
files may not be transferred correctly

Although these file downloads complete successfully on to my drive, they will not install on my OS (redhat 7.1)

When I try to install these packages, the following text errors are displayed:

For kernel package installation

tar: Skipping to next header
gzip: stdin: invalid compressed data -- crc error
gzip: stdin: invalid compressed data -- length error
tar: Child returned status 1
tar: Error exit delayed from previous errors

For kernel package installation

gzip: stdin: invalid compressed data -- format violated
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

I believe that the installation problems are probably directly related to the transfer errors
from the ftp downloads (but I could be wrong).

Please let me know how I can resolve this download problem.


Timo Reimann (linux newbie)

Kevin 07-30-02 08:58 PM

Re: Download Probs
Hi Timo:

Sounds like you are downloading the files and your file attributes are set wrong, and the download is coming in ASCII format or some such oddity. Have you tried RIGHT-CLICKING on the link for the file, then selecting "Save Link As" from the menu? This will open a dialogue to let you choose where to download the file, and will ensure it gets the proper file extension and download method for that style of file. If you are on dial-up, you may have some line noise happening, or some other crosstalk from some devices in the house. If you are on hi-speed, though, it might be the download isn't happening with the right protocol to do the d'load, like I mentioned. If you are using Mozilla, there is a setting in Preferences-Navigator-Helper Applications at the bottom of the page called 'Opening Files', where you can click to reset the file attributes so that you will be asked about what to do with files you are downloading.

I hope this helps you with your download problem. It's what came to mind almost immediately after hearing you describe the problem and reading the error messages you posted. I too am a somewhat new user of Linux, but having experienced the Dark Ages of computer OS'es and hardware, I tend to see Linux as more fun and challenging, than as another problem I have to solve because I NEED to. Good Luck!


Timo 07-30-02 09:18 PM

download problem with linux NVIDIA driver packages
Hi Kevin,

Thanks for the quick response.

That sounds like good advice. I have one little problem though:
The system I am downloading from is only running in 'shell command' mode right now. I just installed redhat 7.1 on my secondary hard drive and it is not recognizing my video drivers (at least I think thats the problem). At this point I cannot run the X windows GUI properly. This is why I was trying to download the drivers in the first place. My Vid card is a Geforce4 MX 440.



Kevin 07-30-02 10:42 PM

Re: Download Probs
Hi Timo:

Have you tried to use Midnight Commander? If you can get a text prompt, and you MUST have installed MC, then all you have to do is get connected via a text-based browser, and start mc at the command line, then point it at the FTP site address. I believe it should be net-aware, although I have not tried this myself. If you have a problem with your drivers at this point, why not drop into root, and start up Midnight Commander, navigate into /etc/x11/xf86Config-4 and then edit the file in mc, and restore the "nv" driver configuration and boot up the machine again and try starting x from the command prompt? If it is a bad install of the drivers, the original driver is still available, and you should be able to get X up and running if you do that. At least when I had a similar problem, that's what I ended up doing. Give that a whack and see what develops! Good Luck!

Infinite Life, Infinite Diversity.
:) :)

Timo 07-31-02 01:13 AM

download problem with linux NVIDIA driver packages
Hey Kevin:

Thanks again for the advice. Unfortunately I am only 2 days into learning Linux. I don't know how to use midnight commander or even how to access it for that matter. I don't think that it would help me with this problem anyway. I know that my file attributes are set properly because I am able to download files/drivers from other ftp sites. The other thing is that I never had an original 'nv' driver configration that worked. I haven't been able to get into x from the moment I installed redhat.

thanks again


Gobo 07-31-02 08:24 AM

Hi Timo,

Try doing the following to download the files:
(Assuming you have a uniprocessor 686 system... Replace with the correct filename if I got it wrong. :)

ncftpget ftp://download.nvidia.com/XFree86_40/1.0-2960/NVIDIA_kernel-1.0-2960.rh71up.i686.rpm
ncftpget ftp://download.nvidia.com/XFree86_40/1.0-2960/NVIDIA_GLX-1.0-2960.i386.rpm

Alternatively, use ncftp directly to download.nvidia.com and browse to the directory and "get" the files you need/want.


Kevin 07-31-02 09:10 AM

Download problems
Hi again Timo:

Sorry, I had not realized that your X server had not worked from the get-go. :rolleyes: . Have you tried to edit the XFree config files in your etc directory and see what drivers the X server is expecting to see? It could be that the card has been identified incorrectly, and the drivers do not match the card. The ncftp idea mentioned in the earlier post, sounds like a good bet.

Midnight Commander is easy to start. At the command line prompt type 'mc' without the quotes of course, and you will see the dual pane layout, and all the other function keys and such that are mapped by the app at the bottom of the screen, along with a command line prompt. Check the attached screenshot of Midnight Commander running in a terminal session, but it looks the same when you run it from a command prompt. This allows you to navigate when you are dumped into command-line land. It's a lonely place without a few tools and such to help you along the way. Also, there are a few text based browsers that may be available to you. Try entering 'lynx' or 'links' at the command prompt for a text based web browser that will allow you to navigate the web while you are using runlevel 3. I hope some of the information we are all throwing at you will help some with your problem. :)

I am wondering though, why the X server disn't start after installation. Did you have problems while you were installing RH? I have heard that it is a bit quirky at times, but I have not used it myself. I am using Mandrake 8.2 currently, and I do like the install process it uses. :cool: . I am sure the makers of RH have included tools for you to get your machine running without the use of X, but a lot of users would get really upset at getting dumped into a command prompt, and not know what to do without the pretty GUI front end.

Hopefully things will come together and you will have the machine configured and running like you expect, very soon. Good luck to you.


Kevin 07-31-02 09:22 AM

Download Probs
1 Attachment(s)
For some reason the system didn't attach my screenshot of Midnight Commander. Unless I cannot see it for some reason, but I cannot think of any reason why not. I'll try to repost the image file.

All times are GMT -5. The time now is 05:49 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.