nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   SIS 655FX and Nvidia Lock up (http://www.nvnews.net/vbulletin/showthread.php?t=21694)

Silent Bob 12-01-03 06:02 AM

SIS 655FX and Nvidia Lock up
 
Hi there,

Having a few problems here, nvidia's driver 4496 compiles fine in Redhat 9, when I modprobe nvidia it complains the driver is tainted. Then when you try to run X the whole system just locks up, only a hard reset will recover. Tried this with Fedora Core 1 with the same results. I've even tried going back a few driver versions no joy :(.

PC spec:
ASUS P4S800D
P4 2.53
512 PC3200
GeForce FX5200

Anyone else had this problem? If so did you manage to get round it? Any suggestions would be welcome.

Cheers
SB

kovacs 12-17-03 09:56 AM

I have the same problem, ASUS P4S800D with GeForce4 MX 440 AGP, P4 3.2 with 2GB DDR400 RAM, locks up as soon as I startx and the box has to be reset. The screen is just blank and the keyboard is unresponsive. I assume this is a motherboard issue - I have had this video card working fine on the motherboard I had before this (an Asus P4R800-VM, I swapped it for my current one because the old one wouldn't pick up all the RAM, and now my video card won't work). The nv driver works fine for desktop stuff though.

nexus32 12-18-03 03:07 AM

Same problem here with my Asus P4S800 (blank screen and lock up). :( Getting my new P4P800 on Friday hopefully that will give me better results. If anyone here with a SIS board has gotten this to work or have the problems I'm sure the rest of us woudl like to hear it. So post away! :D

Silent Bob 12-18-03 01:50 PM

Hello nexus32

The ASUS P4P800 works fine with Nvidia, have used them before. If you have a Hyperthreading CPU and want to use the SMP kernel, you'll need to copy the driver the compiler makes for the uni processor kernel to the smp kernel directory should be okay after that. (there is a bug in the makefile) This is Redhat not too sure about suse or mandrake more than likely the same.

Cheers
SB

PS spelling bah! I'm in a rush

kovacs 12-18-03 06:56 PM

Solved for the P4S800D anyway!

What I did was disable ACPI in the bios, and add these two lines to my XF86Config under "device" (where you change the "nv" to "nvidia"):

Option "NvAGP" "2"
Option "IgnoreDisplayDevices" "TV"

I'm not sure which change did the trick but I suspect it was the "NvAGP" part, which tells X to use AGPGart instead of the nvidia AGP driver. I'm using Slackware 9.1 btw.


All times are GMT -5. The time now is 09:50 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.