nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   broken framebuffer and XF86Config-4? (http://www.nvnews.net/vbulletin/showthread.php?t=21706)

Sir_Brizz 12-01-03 01:03 PM

broken framebuffer and XF86Config-4?
 
first of all, I'm wondering, how do you "fix the framebuffer" if you can only boot to X in a blank screen?

and where is the XF86Config-4 file in SuSE 9.0? The only file I've ever seen in any distro is just XF86Config in /etc/X11 am I missing something??

Running SuSE 9.0 on Kernel 2.6.0-test11 with the system stats below. Driver 4496.

LordMorgul 12-01-03 05:00 PM

You can actually use any config file named whatever you please (with creative setup). Check your XFree log to see which config file is in use (listed within the first 10 or so lines from the top).
/var/log/XFree86.0.log

Not sure what you mean by 'fix the framebuffer'. What problem do you have with the framebuffer, which framebuffer are you using? What 'blank screen' are you using to boot X (are you using startx or is the machine booting up into graphical mode)?

Sir_Brizz 12-01-03 07:07 PM

thanks I was wondering if I was doing something wrong because I didn't have a XF86Config-4 file... :)

Anyways, to the blank screening. I am on SuSe 9.0 with the 2.6.0-test11 kernel. First of all, I can't seem to boot normally no matter what. If I just let it boot into Linux vanilla without any options, I get a black screen. I know it is doing stuff bc the hard drive light flickers. OK. So I go into Failsafe (with acpi, apic, apm etc all turned off) and I can get in...I still can't get into X with the nVidia drivers, I will either get a black screen with nothing on it and all I can do is reboot, or I get garbled ASCII characters all over the screen with the same result, all I can do is reboot. I tried installing from sources, with patches, etc etc etc and everytime I get the same result. I have tried setting NvAgp to every option under the sun and it has no effect. I am reduced to being able to access X from the nv driver only.

I have turned off FrameBuffer support in my kernel hoping that that was part of the problem, and no dice...I tried at one point turning off agpgart support in the kernel but that hammered my nic into disuse. I really have no idea what is going on...except that until I removed machine exception checking from the kernel I was getting bank error's every 5 seconds, which was very annoying. I hadn't had any trouble getting anything to work until I tried to get the graphics driver to work in any kernel since 2.4.21-144-athlon :-/

Any help or suggestions for me to try would be divine. I have started using the forcedeth driver for my NIC since this all started happening, and it works like a dream. I dunno if turning off agpgart in the kernel would make any difference though??

LBJM 12-02-03 02:36 AM

I posted this in the nvnet thread you made the comment in but the thread doesnt show I replied but the post is there. here it is again. I'm using an ati 9800 pro now but I was using a geforce 4 ti4600 and the patch works.

Originally posted by Sir_Brizz
but since have installed 2.6.0-test11 trying to get the video card working, and I can't.



use the 2.6 series patch from this site
http://www.minion.de/
for hte video card drivers

Sir_Brizz 12-03-03 12:47 AM

I apologize that I didn't mention that I had already tried that driver.

My whole problem is that the driver installs, it just doesn't work :-/

LBJM 12-03-03 01:48 PM

what do you mean doesnt work?
what happens what you try it?

have you changed the XF86config from nv to nvidia?

Sir_Brizz 12-03-03 06:57 PM

doesn't work, as in boots/loads to a black screen and I can't do anything but reboot.

I have tried using Sax2, yast2, manually changing the config, etc and every single time I will either get the black screen or ASCII garbage. Nothing else.

LBJM 12-03-03 07:22 PM

as it loads X it goes to a black screen?

whats your /var/log/XFree86.0.log say? that file tell whats going on.

ribx 12-04-03 06:49 AM

when do the blank screen appear?
 
there are 3 main possibilities:
1. when the kernel loads the framebuffer (just after the bios checkt the system)
2. when modprobe loads the driver
3. when you start x

for me it seems to be your kernel framebuffer.. do you have any kernel flags in your bootloader? something like vga=XXX or vga=0xXXXX? if yes set this to vga=ask, then will (in my case lilo) your bootloader ask your grafic card which resolution you could use or which are supported.

in my case there is a problem with my tv-out. it is always on, also when no cable is pluged in so the highest resolution is 720x400..
if i set a higher resolution like vga=791 (i think 1024x768x16) the screen is blank untill x server started and the settings from my XF86Config are loaded

hope i could help you


All times are GMT -5. The time now is 09:33 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.