nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   SuSE 9.0, GeForce4 MX440 & 1.0-4496 (http://www.nvnews.net/vbulletin/showthread.php?t=21772)

mroz 12-02-03 06:27 PM

SuSE 9.0, GeForce4 MX440 & 1.0-4496
I've just built a new machine based on an ASRock Mobo K7S8X & a 'Sparkle' GeForce4 MX440. Previously I've been using Win98SE & SuSE 7.2 (principally with Matrox agp cards). On to my new machine I've installed XP & SuSE 9.0. No problems with XP.

SuSE 9, I installed via NFS after downloading the FTP tree for 9.0 via FTP to another machine on my lan; followed by acceptance of all offered updates including an updated kernel specific to the athlon xp(2.4) processor. Note I also installed the kernel sources, inc the athlon update sources (confirmed by the nvidia-installer.log).

SuSE has still caused me a major pain. The SuSE nv driver works fine, but is obviously crippled compared to the nvidia offering.

I've downloaded the latest nvidia driver & tried to install it. At first I found it installed but wouldn't function, crashing my system, requiring a reversion to nv. Upon invoking sax2 or startx, the display turned dark grey with garbage at the bottom; the whole machine locked.

Examining XFree86.0.log showed it ended with a 'failed to initialize AGP', seemingly causing a reversion to nv & a lock up.

Amongst other problems, sax2 seems to misidentify the board. sax2 -p reports
Chip: 0 is -> NVidia GeForce4 MX440SE 01:00:0 0x10de 0x0181 AGP nv, despite the fact that 0x181 corresponds to an MX440 (confirmed by my hardware & the README accompanying the 4496 download).

This doesn't seem to present a problem to the nv driver as it covers both the MX440SE & MX440, but is worrying none the less.

Eventually I found if I added an
option "NvAgp" "1" to XF86Config, after the dpms option, X would start.

However XFree86.0.log now showed, midway, "failed to verify AGP useage" & at 1280x1024 16bpp I got about 1400 fps from glxgears, iirc.

Reconfiguring my bios from 'AGP auto' to 'AGP x4' (rather than x8 or auto) worked around this problem, at the cost of no x8. XFree86.0.log now reads AGP 4X successfully initialized (see attached file). glxgears then gives me about 2600fps for the default window at 1280x1024, 16bpp.

I've since changed to 24bpp, 1600x1200, losing 3D acceleration, as colour depth for 2D work is more important to me. I now get about 1200fps for glxgears.

Can anyone in the know explain the cause of the above problems to me? This has been a steep learning curve & I still don't understand why any of these problems arose, or how I ought to have dealt with them.

Also, is it possible to make use of the tv output under linux? This hasn't looked hopeful so far. Even with the nvidia driver active, sax2 tells me a dual head output isn't supported.

Shame this is all so much simpler under Windows (& it's not as though I've not tried).


Nitro 12-03-03 01:52 AM

TVout will work, well it did for me in 8.2 with a mx and a ti4800 (currrently in rma)

You need to make some manual changes in xf86config i found them here a while ago, if you cant find them then ill come back and post my gfx and monitor sections.

how ever that was tvout alone im about to try to see if I can get twinveiw working as it is supposed to work. And i have 9.0 now installed and I have to say im pleased with the fact it actually seems to work with 54g wireless pci :)

mroz 12-03-03 06:03 AM

It's good to know TVout can work :)

I've just done a quick search on these archives. tvout & xf86config doesn't turn anything up, while twinview & xf86config doesn't get me far.

Any suggestions would be welcome.

Before I spend more time on this, will it give me the ability to have cloned output on the tv at the same time as the monitor, with the monitor at an independant resolution/refresh?

Any chance it also lets you direct replayed video to the tv in full screen mode, whilst the desktop remains useable for other purposes?

That's what I get from the MX440's nView under Windows. Thanks for any help or feedback.

Incidentally, I notice my 'attached' config didn't turn up (I think); not sure what I did wrong. Will try again later if it would help with the other questions (I'm posting this from a different machine so don't have it available atm).

Nitro 12-03-03 05:49 PM


you could try this GUI it got twinview working for me with a 128mb mx440 in suse pro 9.0 think it may even be a sparkle

just watch the metamodes in the GUI it insist on metamodes before it will save the xf86config and it asks for ie 800x600 @ ??? x ???

leaving the second section blank after the @ it inserts into the config

metamodes "800x600 @x, 800x600 @x"

well that will just crash X so edit the metamodes line in XF86.Config after saving it "800x600,800x600" should work fine or whatever res you want set.

unless of course you know what is suposed to go in the @ ???x??? portion.

if you still want monitor or tv only then save your current XF86Config that is working for your monitor and ill post my tvout only sections then you can just switch the configs and restart X.

there are other methods plenty of them posted here to have crt,crt and switch methods between multiple monitors or tvs,

just search "tvout" "twinveiw" "xf86config" its all i did. and yes i failed to config twinveiw even from examples but I can get tvout only manual and the GUI sorted my crt,TV :)

mroz 12-04-03 06:50 PM

SuSE 9.0, GeForce4 MX440 & 1.0-4496
Thanks. I've saved your post & will give this a go next week (got two assignments due in atm for uni).

I'll try yanc first. The @ part is puzzling. OTOMH (so probably rubbish), nothing to do with refresh rates or colour depth?

I'll post back next week to say how it went. Thanks again :)

All times are GMT -5. The time now is 11:22 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.