nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Error on startx after updating drivers. (http://www.nvnews.net/vbulletin/showthread.php?t=2181)

PktLoss 09-24-02 07:06 PM

Error on startx after updating drivers.
 
I just updatd to the newest linux drivers from the website, and am running RedHat 7.3 with the kernel update to .10

On X Start i get
Code:

XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-8) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
        If the server is older than 6-12 months, or if your card is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.17-0.13smp i686 [ELF]
Build Host: daffy.perf.redhat.com
 
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Tue Sep 24 19:04:31 2002
(==) Using config file: "/etc/X11/XF86Config-4"
(EE) Failed to load module "GLcore" (module does not exist, 0)
Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
(II) [GLX]: Calling GlxExtensionInit

Fatal server error:
Caught signal 11.  Server aborting


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.

I am relativly inexperianced with *nix, but have enough familirity as a user to follow instructions and innovate etc (ie i unerstand output redirection, just howusefull grep is and wonder why everything takes so much longer on my windows machines, etc.)

PktLoss 09-24-02 07:13 PM

If the full log is of use you can view it at this link (posting long pastes is generally frowned upon where i come from)

http://www.preinheimer.com/XFree86.0.log

bwkaz 09-24-02 08:21 PM

Did you edit /etc/X11/XF86Config-4 like the README says to? You have to comment the Load "GLcore" and Load "dri" lines...

You will also have to change Driver "nv" to Driver "nvidia", but that's farther down in the config file. I see from your log that it's still trying to load the "nv" driver.

PktLoss 09-24-02 10:58 PM

Whoa, I thought i went through that thing.


I shall hang my Head in shame


Thank you, especially for telling me where the file was, that was a quientessential peice of information for the newbie.


All times are GMT -5. The time now is 01:40 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.