nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   X11 crushes with NVIDIA FreeBSD x86_64 on [MCP89 (GeForce 320M)], but Linux works. (http://www.nvnews.net/vbulletin/showthread.php?t=218803)

frank.ganske 05-02-14 07:55 AM

X11 crushes with NVIDIA FreeBSD x86_64 on [MCP89 (GeForce 320M)], but Linux works.
 
1 Attachment(s)
Bug report: X11 crushes with NVIDIA FreeBSD x86_64 on [MCP89 (GeForce 320M)] chipset, but Linux works.

Steps to reproduce:
- Install FreeBSD and invoke freebsd-update fetch install
- Install Xorg, nvidia-driver and nvidia-xconfig
- Prepare rc.conf and loader.conf for X and the Nvidia driver, call nvidia-xconfig
- invoke startx

What should happen:
- An X session should be launched.

What actually happens:
- After 2 up to 4 seconds the system reboots and a crash dump will be reported.
- No recent Xorg.0.log is available. Nothing is been written.

Hardware:
- MacBookPro7,1 (13-inch, mid-2010) with [MCP89 (GeForce 320M)] chipset.

Software:
- MBR partition scheme with Mac OS X, FreeBSD and Linux. The binary Nvidia
driver works well in Arch Linux and Debian (squeeze) OLDSTABLE.
- FreeBSD Release 10.0 (and 9.2 would be tested)
- Nvidia binary drivers 304, 311 installed with pkg.
- Drivers installed from ports with all available build options.
- Beta driver 337 installed from Nvidia source.

Other notes:
- Linux works but FreeBSD fails with the same hardware.
- VESA works well, but only 800x600 with X.
- Loading nvidia.ko works, but sysctl -a | grep nvidia looks ugly:
hw.nvidia.registry.Mobile: 4294967295
hw.nvidia.registry.ResmanDebugLevel: 4294967295
...
hw.nvidia.gpus.0.vbios: ??.??.??.??.??
hw.nvidia.gpus.0.uuid: GPU-????????-????-????-????-????????????
- The network driver needs dev.bge.0.msi="0" to work, so I've tryed to set
hw.nvidia.registry.EnableMSI="0" with no success.
- I've tryed to set hint.agp.0.disabled="1" to use NvAGP with no success.
- The behaviour is allways the same.

Possibly related topics:
- MacBook Air mid-2010: http://forums.freebsd.org/viewtopic.php?t=45661
- Another GeForce 320M: http://forums.freebsd.org/viewtopic.php?t=30384

Please find attached a bug report log.


All times are GMT -5. The time now is 06:46 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.