nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVdriver error (http://www.nvnews.net/vbulletin/showthread.php?t=2208)

OnlyTheTony 09-25-02 02:37 PM

NVdriver error
I've been happily using RH72 with 2.4.7 kernel for the past few months, and my NV drivers have been working fine.

Today I upgraded to 2.4.18-10 kernel, downloaded the appropriate RPMs and tried to install them.

However, when it tries to insmod NVdriver it keeps reporting back with "unresolved symbols" and therefore won't finish the install.

Any ideas?

PS. I've tried the tar.gz and the .src.rpm files and none of these seem to want to work either.

pps... I tried copying my old NVdriver file accross from my previous kernel.. but still no luck.

OnlyTheTony 09-26-02 02:59 AM

Just had a thought...
...given that I can't run the RH7.2 rpm's, (and for some reason I can't "make" the tar.gz or build the src.rpms) could the fact that the RH7.3 (2.4.18-10) rpm won't "insmod NVdriver" be linked to the fact that 7.3 uses an updated glibc library?

Not really clued up on this part of it.. things usually just run when I install them!!


OnlyTheTony 09-27-02 05:52 AM

Finally figured it out
It's because I lazily downloaded the RPM of 2.4.18-10, which had been compiled on RH7.3, so when I did "cat /proc/version" it was returning (part of) "7.3", but "cc -v" was returning 7.2 (my distro), so obviously the two weren't matching.

So I've downloaded the 2.4.19 kernel (www.kernel.org) and am going to compile it THEN compile the driver.

Just thought this info would help others in the same situation.


OnlyTheTony 09-27-02 08:50 PM

Did It!
Well. that worked.. but for some reason it can't find my ethernet card now.


All times are GMT -5. The time now is 01:56 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.