nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA GeForce 7, 8, And 9 Series (http://www.nvnews.net/vbulletin/forumdisplay.php?f=5)
-   -   GeForce4 hard lockup with games under Windows XP (http://www.nvnews.net/vbulletin/showthread.php?t=2210)

Snap 09-25-02 03:17 PM

Geforce4/WinXP/Games Hard Lockup
I have recently installed WinXP on my computer and now my games freeze after a few seconds to one minute of play.

I have a VisionTek GeForce4 Ti 4200 se 128mb card running the 40.41 drivers.

Morrowind will freeze on the opening video (or if i hit escape and get to the menu quickly it will freeze in there)

Neverwinter Nights will freeze after I get into the game itself or at the screen to pick a new character.

These games used to run flawlessly under Win98 with all the bells and whistles turned on. I have only had hard lockup problems under Windows xp while trying to run games. Any suggestions?

saturnotaku 09-25-02 03:25 PM

Did you do a clean install of XP or did you install it on top of Win 98? You also want to make sure you have the latest drivers for your motherboard, sound and everything else. If you could post the rest of your system specs (especially motherboard) that would help us.

Snap 09-25-02 03:32 PM

Nope, Clean install of XP. Here are my system specs:

AMD Athlon 750mhz
256mb RAM
Biostar M7MKE Motherboard (VIA KX133/686A chipset)
Soundblaster AWE32
3Com PCI Network Card
50x CD-ROM
3 Harddrives (94gb)

I have not had anything other than games cause any lockups so far. When they do freeze I have to reboot.

Thanks for the help =)

saturnotaku 09-25-02 03:39 PM

That KX133 might be problematic under XP. I'd snag a copy of the 4.41 VIA 4-in-1 drivers and give those a shot. You might also want to force the card to use AGP 2x or 1x in your BIOS and through software (I think RivaTuner might have this option). You could also try the "Large page minimum" registry hack that we had to use for Windows 2000 so our games wouldn't lock up. That reg fix should be available for download at www.amd.com

If I think of anything else off the top of my head, I'll be sure to post it.

Snap 09-25-02 04:07 PM

I have the latest VIA 4-in-1 drivers (version 443v). Tried the AMD reg patch. These didn't work. I'm downloading DirectX 8.1b right now to give that a try.

saturnotaku 09-25-02 04:18 PM

The 4.43 VIA drivers were problematic even on my KT266A system. Have you tried running XP without installing any VIA drivers at all? The ones that come with XP are really good, especially on older chipsets - they were awesome on my old KT133A board.

Other than that, I don't know what to tell 'ya. Perhaps go back to an older set of detonators like the 30.82's or 29.42's if you haven't already. Or, try the latest leaked 40.52's or wait until tomorrow when NVIDIA is supposedly going to release new official drivers.

Snap 09-27-02 02:37 PM

I installed DirectX v8.1b and that seems to have cleared up the problems. Thanks for the help.

All times are GMT -5. The time now is 03:47 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.