nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   That's strange... Do I have it installed or not? (http://www.nvnews.net/vbulletin/showthread.php?t=2218)

Imperito 09-25-02 06:59 PM

That's strange... Do I have it installed or not?
After beating this driver in every possible manner, I've finally got X to come back up.

I can run 'glxgears' and see them spinning. Without NVdriver being loaded.

Does the fact that I have a screen before NVdriver is loaded mean I'm still not actually getting my GeForce2's help? If so, how is GLX working?

Imperito 09-25-02 07:08 PM

I can modprobe it and it loads fine (a warning about tainting) but it seems odd that it doesn't load automatically. Or is it just required for installation?

bwkaz 09-25-02 07:56 PM

It must be loaded when GLX loads (or maybe it's when the "nvidia" driver in XF86Config-4 loads...) in order to use your card's help.

I don't think it helps to load the module after X is running, but of course, I could be wrong as I've never tried it.

If you want to get it to load automatically, I've posted some decent instructions about 4 times now -- do a search for "[ -c /dev/.devfsd ]" (or "alias" and my username) and you should find at least two of them.

Imperito 09-25-02 08:31 PM

I've tried it.

I get errors. I asked for help but no one answered. :(

Trying to install the driver results in everything from an erro message to being totally unable to enter X and having to backtrack on the command like.

Imperito 09-25-02 08:52 PM

This happens:

(II) NVIDIA(0): AGP 4X successfully initialized
(EE) NVIDIA(0): Failed to allocate LUT context DMA
(EE) NVIDIA(0): *** Aborting ***

Fatal server error:
AddScreen/ScreenInit failed for driver 0

Sounds bad.

bwkaz 09-26-02 08:24 AM

A quick www.google.com/linux search found that in the nVidia readme, this specific problem is addressed:


Q: X fails with error "Failed to allocate LUT context DMA"

A: This is one of the possible consequences of compiling NVdriver with a different gcc version than used to compile the Linux kernel (see above).
"above", it says:


Q: Compiling the NVdriver kernel module gives this error:

        You appear to be compiling the NVdriver kernel module with
        a compiler different from the one that was used to compile
        the running kernel. This may be perfectly fine, but there
        are cases where this can lead to unexpected behaviour and
        system crashes.

        If you know what you are doing and want to override this
        check, you can do so by setting IGNORE_CC_MISMATCH.

        In any other case, set the CC environment variable to the
        name of the compiler that was used to compile the kernel.

A: You should compile the NVdriver kernel module with the same compiler
  version that was used to compile your kernel.  Some Linux kernel data
  structures are dependent on the version of gcc used to compile it;
  for example, in include/linux/spinlock.h:

        * Most gcc versions have a nasty bug with empty initializers.
        #if (__GNUC__ > 2)
          typedef struct { } rwlock_t;
          #define RW_LOCK_UNLOCKED (rwlock_t) { }
          typedef struct { int gcc_is_buggy; } rwlock_t;
          #define RW_LOCK_UNLOCKED (rwlock_t) { 0 }

  If the kernel is compiled with gcc 2.x, but gcc 3.x is used when the open
  files in NVdriver are built (or vice versa), the size of rwlock_t will vary,
  and things like ioremap will fail.

  To check what version of gcc was used to compile your kernel, you
  can examine the output of:

        cat /proc/version

  To check what version of gcc is currently in your $PATH, you can examine
  the output of:

        gcc -v

So let me guess... you used IGNORE_CC_MISMATCH, right?

Imperito 09-26-02 10:19 AM

Um, no...
and they are the same version:

imperito@sanchez:~> cat /proc/version
Linux version 2.4.18-64GB-SMP (root@SMP_X86.suse.de) (gcc version 2.95.3 20010315 (SuSE)) #1 SMP Wed May 29 15:37:15 UTC 2002
imperito@sanchez:~> gcc -v
Reading specs from /usr/lib/gcc-lib/i486-suse-linux/2.95.3/specs
gcc version 2.95.3 20010315 (SuSE)

bwkaz 09-26-02 11:38 AM

OK, then does this help?

The guy sent a message to the Mandrake cooker list complaining of the same error as you're getting; it turned out to be the AGP driver he was using (well, a combination of that and which AGP mode his motherboard was able to do). Does using agpgart rather than NVAGP help? Or vice versa, using nVidia's AGP rather than agpgart?

If not, the contents of your X log would be helpful.

All times are GMT -5. The time now is 05:38 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.