nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   I Will Never Buy an Nforce Chipset again (http://www.nvnews.net/vbulletin/showthread.php?t=22262)

tourettes 12-14-03 08:44 AM

I Will Never Buy an Nforce Chipset again
 
Early last year, when I went searching for a new motherboard, I came across these "Nforce" boards (ASUS A7N 266-E), I thought "Great!" NVidia is a great company, they support linux, there shouldn't be any problems. Before ordering, I checked to make sure that they did, indeed, have drivers, and saw that they did. I must say, purchasing this motherboard with the nforce chipset was one of the worst purchases I have ever made. I have had nothing but problems with this chipset in linux (and just as many in windows). To run any game that uses the Quake3 engine, I have to constantly kill my X-server manually (Ctrl-Alt-Backspace) because the sound locks up the X-server, it is really annoying. i have sent several emails to the tech support bug email address, to no response.

Once again, I am in the market for a new motherboard, and I see all these Nforce chipsets out there, and i'm just too scared off to even try another one. It's really sad, because I know there is the strong possiblity that they are great, but I can't justify shelling out more cash for something that I'm really scared of buying.

Obviously, I think this problem could have been avoided by either answer the bug emails, or opening up their drivers and letting the open source community have a chance at them, but either doesn't seem to be happening any time soon.

I don't hate NVidia or anything, i Have a ti4200 graphics card that i'm (somewhat) happy with, I will just never buy anything outside of a graphics card again.

serialdave 12-14-03 09:27 AM

The ASUS A7N 266 uses the Realtek® ALC650 audio module. Is the sound device defined as that? Not all Nforce boards used nvidias sound module.

tourettes 12-14-03 03:40 PM

lspci:
Quote:

00:05.0 Multimedia audio controller: nVidia Corporation: Unknown device 01b0 (rev c2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce Audio (rev c2)
Most, if not all, auto-detection picks it up as this. When using Alsa, it uses the intel8x0 driver. For OSS it uses i810_audio, which partially works, but still craps out in the same manner as above.

When using the nvaudio module, running quake3 segfaults on sound initialization, and then locks the audio device so nothing else can use it, and am unable to remove the module. I attempted to pass spdif_status=0 as stated in the README, but the same thing happens.

No matter what I use, i get the same problem. If you have any other suggestion of modules i could try , I will definitly attempt it. I would love to get this resolved somehow.

tourettes 12-15-03 01:26 PM

Using your suggestion that the chipset in this board is a Realtek ALC650, I went ahead and downloaded the linux drivers off of Realtek's website . I went ahead and followed the instructions and installed the drivers, used their suggested modules.conf file, and probed the modules. I again, started up quake3, and it once again Seg faulted on Sound initialization, and i was unable to access sound again until i rebooted.

This is absolutly hopeless. Is it at all possible that there is something physically wrong with my hardware? It would be impossible to return it now though.

geowiz 12-17-03 09:00 AM

Question
 
This may be a silly question but have you tried passing the kernel acpi=off as a boot parameter? When I see X, sound and lock in the same paragraph my thoughts turn to turning off acpi.

Maybe this'll help. Good luck.

BTW, I really like my Nforce2 Abit board but acpi and other issues drove me mad until I switched to the 2.6 series of kernels. Now I be happy ;-)

tourettes 12-17-03 12:15 PM

Nope, i've never tried that before, but i'll give it a shot, and post my results.

Thanks

tourettes 12-18-03 01:22 PM

Okay, i passed acpi=off to my kernel line on bootup, now when i start quake3, i get the following on sound init:

Quote:

------- sound initialization -------
GETOSPACE: Invalid argument
Um, can't do GETOSPACE?
------------------------------------
Sound memory manager started
Also, this locked my sound so i can't play any sounds nor remove the module until i rebooted.

After rebooting, I re-inserted the nvaudio module with spdif_status=1 instead of 0, this time, i get the following output:

Quote:

------- sound initialization -------
------------------------------------
----- Sound Info -----
sound system is muted
1 stereo
32768 samples
16 samplebits
1 submission_chunk
0 speed
0x4d5fa000 dma buffer
No background file.
----------------------
Sound memory manager started
So, everything looks fine, except for the fact that the screen stays blank and never actually goes into the game itself.


All times are GMT -5. The time now is 08:09 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.