nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Installing on Fedora Core 1 (http://www.nvnews.net/vbulletin/showthread.php?t=22339)

linuxnewb 12-16-03 11:19 AM

Installing on Fedora Core 1
 
Please bear with me as I am a linux newb!

I am trying to install the nvidia drivers on my fresh install of Fedora Core 1 and i don't know how to get fedora to not automatically login to the X login screen i'm trying to get fedora so that when i boot up it take me to command ( text based login ) so that i can install the nvidia drivers. When i try to install in a terminal session or if i type ctrl + alt + f2 it still says that i have X running. I have also tried typing ctrl + alt + backspace but that just takes me back to the GUI login screen.

If any one knows how to keep fedora from automatically taking me to the GUI interface let me know.

THX in advance
........linuxnewb

Silent Bob 12-16-03 11:41 AM

Hi there

edit the file /etc/inittab on about line 18 change the 5 to a 3, it should read like this: id:3:initdefault:

if you want to change it back later change it back to 5.

Cheers
SB

Alowishus 12-16-03 11:51 AM

You can also, as root, just type 'init 3' to drop into runlevel 3, which will kill the graphical login on F7. Do your nVidia install, and then type 'init 5' to get the graphics back. Saves you two reboots!

Oh but for FC1, your life is even easier if you use the RPM drivers found here.

linuxnewb 12-16-03 02:17 PM

OK thx that worked perfectly its not booting into GUI.

Now about those rpm's for fedora core are thier any instructional guides to show me how to install them? If not can someone please tell me ow to install?

Silent Bob 12-17-03 06:51 AM

Hello Again

Got this from: http://www.moongroup.com/nvidia-fedora.html

Worked on the test machine I was workin on with no problems

5. rpmbuild --rebuild NVIDIA_GLX-1.0-4496.src.rpm
6. rpmbuild --rebuild NVIDIA_kernel-1.0-4496.src.rpm
7. rpm -ivh /usr/src/redhat/RPMS/i386/NVIDIA_GLX-1.0-4496.i386.rpm
8. rpm -ivh /usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-4496.i386.rpm

Section 2

1. Edit /etc/X11/XF86config in your favorite editor.
2. In a section which will look something like this:

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Change the driver line to say Driver "nvidia" instead of Driver "nv".

You should now be able to run X with the nvidia driver installed.

Cheers
SB

mlmitton 12-17-03 05:47 PM

As a beginner, I thank you for the help, Silent Bob. I was trying to upgrade from a GeForce 3 to a 5700 Ultra, and whatever drivers come with FC1 weren't working. It worked just fine after following those steps.

Well, almost. I had to reverse steps 7 and 8. And, the link you give, which has steps 1-4--those steps didn't work. The packages weren't found at that web address. (Perhaps this is why you didn't list those steps.) But of course the packages are easy enough to find elsewhere.

Silent Bob 12-17-03 06:16 PM

Hi again

Sorry about missin a few things out, was kinda in a rush at the time. Glad you're up and running though. I do recall having to change things around when I was setting up Fedora n Nvidia.

Cheers
SB

AndrewMyers 12-23-03 12:54 AM

Just installed the new drivers on Fedora Core 1 for my Geforce4 4400 without a hitch (although I'm not running any games or anything).

I used my existing 4496 package as the start point, although it should work exactly the same if you've downloaded the newer one (I used --update, which makes it go get the newest automagically).

The skinny:

$ sudo init 3

(things stop, things start, login prompt appears)

$ export CC=gcc32
$ ./NVIDIA-Linux-x86-1.0-4496-pkg2.run --update

(should work just as well with any of their .run scripts)

The script went ahead and downloaded the new driver, determined it needed to build it (since there were no prebuilts available), uninstalled the 4496 driver, compiled the new, installed it, and left me at a shell prompt.

$ sudo init 5

(things stop, things start, x fires up, graphical login appears)

Done! That's all it took for me, didn't need to touch a thing in my configs -- my old settings worked fine. I'll paste it here, in case it's helpful to anyone.

Again, I have a geforce4 4400, with a pair of 19" monitors, running twinview.

Oh, yeah, and kernel 2.4.22.

Quote:

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "6 7"
Option "Emulate3Buttons" "no"
Option "Resolution" "120"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell P991"
HorizSync 30.0 - 107.0
VertRefresh 48.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
VideoRam 131072
Option "TwinView"
Option "SecondMonitorHorizSync" "30.0 - 107.0"
Option "SecondMonitorVertRefresh" "48.0 - 120.0"
Option "MetaModes" "1600x1200, 1600x1200"
Option "ConnectedMonitor" "CRT, CRT"
Option "NoLogo" "1"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "3200x1200" "1920x1440" "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

tero 12-23-03 01:12 AM

one more HOWTO
 
I wrote an "HOWTO" a while ago, as this seemed to be a FAQ on #fedora.
Read it here: HOWTO: Installing NVIDIA drivers on Fedora Core 1

bms20 12-23-03 07:08 AM

Fedora Core 1 NVDriver install bug
 
Guys,

I'm writing this from memory, as I'm on vacation, and this step seems skipped by most of the tutorials on installing NVidia drivers on Fedora 1:

I got the 4496 drivers installed properly on Fedora Core 1, and the GUI worked just fine... However, Quake3 produced terrible textures... This is a known about problem with Quake3, and has to do with the use of MesaGL on top of the NVidia drivers. The problem has to do with a second copy of libGL.so.1.2 that sits in /usr/X11R6/lib/tls - this file must be removed and the symlink replaced with one that points to the correct libGL.so.1.0.4496.

-Brett


All times are GMT -5. The time now is 07:27 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.