nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   problems installing on a mandrake 9.2 system ! (http://www.nvnews.net/vbulletin/showthread.php?t=22587)

Kjelland 12-22-03 07:46 AM

problems installing on a mandrake 9.2 system !
 
Hi !
Does someone here know what's wrong when the installer says i either
have the wrong source path or the wrong version of the headerfiles and
as far as i can check it, it is the right path and version files. according
to uname -r and the name of the rpm pakage. What do i do now ?
I have tried both the 4496 and the 4363 i think that points towards
my machine or mandrake 9.2 ! any ideas ?

Regards Kjell

afrosheen 12-23-03 05:16 AM

Mandrake screwed up and didn't include the kernel-source rpm with the download edition ISOs. If you installed from downloaded iso files and burned your own cds, you have to find a mandrake Contrib site and get the kernel source. Make SURE it matches your running kernel. Mandrake issued a new kernel-source package that's on the ftp mirrors that DOESN'T match your kernel. All mirrors should have both. To check which kernel you're running (should be -10) run uname -r and write that down. Go get that kernel-source rpm, install it, and run the driver installer again. Should work fine.

Kjelland 12-23-03 06:19 AM

Quote:

Originally posted by afrosheen
Mandrake screwed up and didn't include the kernel-source rpm with the download edition ISOs. If you installed from downloaded iso files and burned your own cds, you have to find a mandrake Contrib site and get the kernel source. Make SURE it matches your running kernel. Mandrake issued a new kernel-source package that's on the ftp mirrors that DOESN'T match your kernel. All mirrors should have both. To check which kernel you're running (should be -10) run uname -r and write that down. Go get that kernel-source rpm, install it, and run the driver installer again. Should work fine.
But i have installed the source twice and i get the same results!
the kernel is -10 ( uname -r) and the source is -10 but it doesn't work !

schelli 12-23-03 10:06 AM

i run the installation programm on my mandrake 9.2 system without problems. i installed the kernel-source via "urpmi kernel-source" and didn't bother which sources were installed.

after installing the nvidia drivers i checked the kernel-souces and realized they didn't match the running kernel.

[root@laptop schelli]# rpm -qa|grep kernel
kernel-source-2.4.22-21mdk
kernel-2.4.22.10mdk-1-1mdk

the nvidia installer run without problems, but the screen is not centered and i can scroll off-screen (see http://www.nvnews.net/vbulletin/show...threadid=22615 and help if you can:-)). but probably this error occurs because of the mismatching sources?!

:-(
mario


All times are GMT -5. The time now is 04:55 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.