nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Toshiba Sat 1950 screen setup (http://www.nvnews.net/vbulletin/showthread.php?t=2260)

beaulieu 09-26-02 08:24 PM

Toshiba Sat 1950 screen setup
 
Hello,

I have been monitoring your forum for setting
up laptop screen and I could not find anything
about the Toshiba Sat 1950 16-in screen. I just
acquired this machine and I am trying to setup
the screen with not luck. We have installed ReHat
7.3 and have downloaded the latest XFree86 and
NVIDIA files.

My system manager and I have tried many of the
tricks found on your site but we still get a
much smaller display than the 1280x1024 I should
get and we have that "warp-up" problem at the
bottom of the screen (with teh white/black large
bar) already discussed on you site (but most
of the suggestions are for 15-in screen and
smaller).

If anyone has new options to offer us, it would
be greatly appreciated.

Best regards,

Dr Beaulieu

scarrillo 10-05-02 01:22 PM

1 Attachment(s)
Hi,

I have also a satellite 1950, but unable to use the nvidia driver. Got the same bar as you have in the middle of the screen...

It is however wirking with the vesa driver.

If you find a solution with the nvidia driver, let me know. I really would like to make TwinView work....

Here is the working 1280x1024 XF86config attached.

Regards,
Sébastien Carrillo

beaulieu 10-05-02 05:16 PM

Hi,

We were finally able to get a setup yesterday but not with nV.
This following setup was provided by a Toshiba technician from
Montreal. Of this setup (see below) we found we also had to
commented out three lines in the "XF86Config-4" file:

Load "GLCORE"...
Load "dri"...
Load "glx"...

I am happy with this since I am able to run all my own programmes
and imaging packages. This will do until we can get the proper
nV driver.

Although RedHat8.0 is out now, I have not tried it yet. Maybe it
will help but we may have to wait for the new driver also.

This recipe is probably very similar, if not the same, as
Mr Scarrillo just posted. I have not yet had time to verify
this.


Best regards,

Dr Beaulieu

******************************
From Toshiba technician:

You need to install 2 packages from the 3rd Redhat 7.3 CD.

rpm -Uvh XFree86-compat-modules-3.3.6-44.i386.rpm
rpm -Uvh XFree86-FBDev-3.3.6-44.i386.rpm

run the following command:

Xconfigurator --usefbdev

follow these steps:

Click OK
Click OK
Click Custom and OK
Click OK
Select "Monitor that can do 1280x1024 @ 60Hz and Click OK Select 50-70
Hz and Click OK Click Don't Probe Select 32MB and click OK Select "No
Clockchip Setting (Recommended) and Click OK Select 1280x1024 in all 3
sections and Click OK Click Skip Click OK


Edit the /etx/X11/XF86Config-4
Change the Section "Screen" to reflect this:

Section "Screen"
Identifier "Screen0"
Device "Linux Frame Buffer"
Monitor "My Monitor"
DefaultDepth 16
Subsection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
Subsection "Display"
Depth 16
Modes "1280x1024"
EndSubSection
Subsection "Display"
Depth 8
Modes "1280x1024"
EndSubSection
EndSection

Edit the /etc/grub.conf file and add the vga=0x31A line. So change this
line

kernel /vmlinuz-2.4.18-3 ro root=/dev/hda2 hdc=ide-scsi

to this
kernel /vmlinuz-2.4.18-3 ro vga=0x31A root=/dev/hda2 hdc=ide-scsi
****************************

buckyball 11-13-02 07:46 PM

I've been working through a slightly different issue with my Satellite 2410-S203, and found the following a helpful means of getting useful info about the display.

Launch X with the command:

startx -- -logverbose 5

(that's 2 hyphens, then hyphen-logverbose)

This will provide more info about the values returned by the EDID query in the XFree86.0.log file (usually in /var/log).

Hope this helps you some.

AndyR

Drughino 04-24-03 01:33 PM

problems with NVIDIA Geforce4
 
I am having problems analogous ot those mentioned in the forum to have a toshiba satellite 1900-704 to work with nvidia geforce4 and the latest version of debian. I have recompiled the kernel with nvidia drivers, but it is still not working. Do you have any hints on how tto install the framebuffer under Debian ? Ouwld it be possible to contact the Canadian Technician to see if he can help ?
Thanks

nightshadow 06-04-03 11:13 AM

I have a toshiba 1900-703 with debian. everything works fine.

simply put "IngoreEDID" "true" Options in your config file..

gil 06-11-03 06:01 PM

Toshiba Satellite 1955-S805 (16")
 
1 Attachment(s)
I have this working in TwinView. I'm using Suse 8.2 as my distribution, but probably more importantly are your XFree86 versions and kernel versions:

gil@asterix:~> XFree86 -version

XFree86 Version 4.3.0
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: SuSE Linux [ELF] SuSE
Build Date: 17 March 2003
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
gil@asterix:~> uname -a
Linux asterix 2.4.20-4GB #5 Tue May 13 18:30:55 PDT 2003 i686 unknown unknown GNU/Linux

Here's my XF86Config file

habo 06-13-03 04:17 PM

:confused: Hi all,
Also have a brand new Satellite 1950 and nvidia problems. Not sure they are of the same nature as earlier quoted in the thread.
My history:
a) Downloded the latest version ...4363, and installed. That worked without errors. The kernel module inserts Ok. But when starting X (along with fvwm95) the screen is garbage.
b) Stepped down to version ...4349, that kind of works.

The problem:
When using Display Mode 1280x1024 (having enabled ignoreEDID) it behaves like expected. Any other Mode like 1024x768, however, only uses part
of the screen with right part black and the top of the active window copied at the bottom.

Anyone have a solution to this ???

N.B. It works under the vesa driver.

Regards
habo


All times are GMT -5. The time now is 08:00 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.