nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   suse linux 9.0 & nvidia driver 5328 (http://www.nvnews.net/vbulletin/showthread.php?t=22603)

w32.nimda 12-22-03 01:21 PM

suse linux 9.0 & nvidia driver 5328
 
Hello!
i have got one question about the new 5328 driver...
when i install ist, it says to run sax to configure 3d acceleration. when i try to start the 3d acceleration, sax says:
Quote:

To activate the 3D subsystem for this card you need to
use the commercial driver from nVidia. Please download
the nVidia installer from the nVidia web server (http://
www.nvidia.com) first. After you have installed the
driver you can enable 3D with Sax2.
please can someone explain? I already installed the driver twice and more times!

thunderace 12-22-03 08:46 PM

1) Kernel sources must be installed and configured.

2) switch to runlevel 3 ("init 3")

3) Do not go to sax2 configuration, just type sax2 -m 0=nvidia (0 is a digit, not a letter!)

4) Sax still will ask you to configure your monitor, etc. just cancel out of that and startx.
NOTE: you might want to reboot before starting X-windows. I had to because my system gave me a font error.

5) When you see Nvidia splash screen while starting X means nvidia drivers enabled and you have 3D support.

6) Bottom line you don't have to enable 3D in sax2

niki_iv 12-23-03 02:09 AM

It is not that simple. Driver is crashing
 
Using athlon optimized kernel, driver is 'crashing' and sending crash info in /var/log/messages. It's 3D part is not working. Sorry, I am at work now using Windows, but later I will post full debug message.
I tried with preloaded driver module for Suse 9.0 and I compiled new one - same error.

jedah 01-19-04 05:02 AM

I have installed 53.28 and although Xserver starts with the NVIDIA logo,3D applications run extremely slow.I have an GeForce FX 5700 Ultra and I use SUSE9.0.I've tried Red Hat 9.0 and the Xserver won't start at all.I must admit that I haven't tried "sax2 -m 0=nvidia",but if someone sees the logo does not mean that 3D acceleration works:(

Timothy_Shawn 01-19-04 09:40 AM

Same here, the Nvidia Splash Screen shows up but the 3D Support doesnt work.

Have a look in /etc/var/log/XFree86.0.log is there a line which says unknown Chipset?

kmare 01-19-04 05:34 PM

Plz send your /etc/X11/XF86Config and /var/log/XFree86.0.log

Here I have suse9 and it is working great... (with self compiled kernel 2.6)
no crashes here... and I got about 7600 fps with glxgears :)

maybe you are using the nv driver (XFree86) and not the nvidia (NVIDIA) one...

Timothy_Shawn 01-19-04 11:02 PM

Please have a look at this thread

LINK

jedah 01-21-04 02:36 AM

I've downloaded a patched version of the drivers from
http://www.sh.nu/download/nvidia/linux-2.4/
and everything is ok now.I highly recommend that 5700 Ultra users should download this file.Racer really rocks now!!Thanks for the support guys:D :D


All times are GMT -5. The time now is 04:54 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.