nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problems with 1.0-5328 (http://www.nvnews.net/vbulletin/showthread.php?t=22629)

woga 12-22-03 11:39 PM

Problems with 1.0-5328
 
1 Attachment(s)
Hi there,

I downloaded the driver NVIDIA-Linux-x86-1.0-5328-pkg1.run from the NVIDIA web page a few days ago. I followed the instructions for installing the driver and it looks like everything went ok. It even recognizes the correct chipset (see log file) Unfortunately I always get a blank (black) screen when I try to start X :mad: Any idea what could be wrong?

I am running Mandrake Linux 9.2
Athlon XP 2400
MSI GeForce FX5200

Thanks in advance.

P.S.: Is it possible to attach more than one file? I also wanted to attach my XF86Config-4 file, but I have no clue how to do this.

Antiorganic 12-22-03 11:52 PM

Does your card have TV-out? If so, it'll work after five minutes or so -- it's black while it's probing for a television. Add the following lines to your XF86Config:

Option "ConnectedDevices" "CRT"
Option "IgnoreDisplayDevices" "TV, DFP"


and it will stop looking for a television.

Soul-Crusher 12-23-03 03:04 AM

Looks like it's having a lot of difficulty finding the proper resolution to display for your monitor. What kind of monitor do you have, what maximum resolution have you set it to use, and what refresh rates have you set in your XF86Config-4 file?

woga 12-23-03 08:16 PM

Still not working
 
1 Attachment(s)
Antiorganic, my card does have a TV-out. So I decided to try your suggestions. Unfotunately nothing changed, my screen stays blank. Even after several minutes nothing happens. :mad: So now I switched back to the generic nv driver. By the way, Soul-Crusher, I have a CTX 7695 monitor.

Any ideas what else could be wrong? I glanced over some of the other posts. It seems like there are problems with the VIA chipset. I have to read them in more detail though. I do have a Biostar M7VIP motherboard that uses the VIA KT333/VT8235 chipset. Did anyone with that chipset get it to work yet?

Any other suggestions? If not, then I will just run the nv driver for now. I will follow the message board and hope that someone finds a solution. I am pretty new to Linux configuration and don't have that much time to play around with that stuff right now.

Thanks for your help.

bwkaz 12-23-03 09:14 PM

I will assume that you're trying to startx from a text mode runlevel. If this isn't the case, then you might want to try. :)

If you hit Ctrl-Alt-F1 at the blank screen, do you get a prompt back?

If so, check the output of dmesg for a kernel oops. If you're getting one, then try the patches at minion.de (or just bunzip2 the 5328 patch, remove everything except the hunk that patches os-registry.c, near line 618, and apply just that hunk).

woga 12-23-03 10:48 PM

1 Attachment(s)
Hi bwkaz,

thanks for your answer. Like I said in previous post I am pretty new to configuring stuff under Linux. I didn't know about Ctrl-Alt-F1 but I just tried it and I do get the prompt back. I see the following message:

XIO: fatal IO error 104 (connection reset by peer) on Xserver ":0.0" after 0 requests (0 known processed) with 0 events remaining.

In several other posts I read about kernel oops but I am not sure what that is (like I said, I am a newbie, but willing to learn ;) ). Is that linux slang for errors reported by the kernel? Anyway, I attached the demsg file. Do you see anything wrong with it? Do you think I should apply that patch from minion.de?

Thanks.

RacaClone 12-24-03 06:20 AM

I've got the same problem, but I can't get back text-mode

bwkaz 12-24-03 01:00 PM

You could also reboot, then check /var/log/messages (on a Red Hat based machine), /var/log/syslog on some other distros, or /var/log/kern.log on LFS. If you don't have any of those, look around in /var/log for a file that appears to hold kernel type messages. If you have anything similar to "unable to handle kernel NULL pointer dereference", then the problem you're having can be fixed by that one hunk of the minion.de patch.

woga -- the attachment appears to be empty? Try looking in the aforementioned log files for the "unable to handle" string.


All times are GMT -5. The time now is 05:59 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.