nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   crashes and freezes (http://www.nvnews.net/vbulletin/showthread.php?t=2276)

Lethal Weapon 09-27-02 07:27 AM

crashes and freezes

I'm curious if i'm the only one having all those problems, or if the drivers of nvidia are the guilty ones:

I'm using a redhat beta null (i've just upgraded to rh8.0, but the first symtoms i have are still the same), p3 1000, via appolo pro on a tyan
1542 mobo; 512MBram, kernel 2.4.19; gcc 3.2; gef4ti4200 128MB (sparkle);
here are the symtomps:

q3 sometimes freezes
return to castle wolf often freezes (like once per half hour)

unreal tourn2003demo often freezes (if you click in many menus and at the launch of a game)

when i run mplayer, this happens when the pc is up for a week or so, the mouse cursor becomes a gray-box; and if i then put licq back into
foreground, the whole pc freezes

and now xawtv (when using with rivatv, i know it isn't supported by you), freezes also (other programs like ffmpeg or mplayer can capture
without problems)

I think i'm having this problems since i've upgraded to gcc 3.2, but
can't swear this is the cause... I'm already digging for a month with
this :/ Almost everything was working fine a big month ago, untill ...
Untill when, can't find out

Checked mobo cpu and main memory, that hardware part seems to be fine.

agpgart: Maximum main memory to use for agp memory: 440M
agpgart: Detected Via Apollo Pro chipset
agpgart: AGP aperture is 32M @ 0xe2000000
NVRM: AGPGART: VIA Apollo Pro chipset
NVRM: AGPGART: aperture: 32M @ 0xe2000000
NVRM: AGPGART: aperture mapped from 0xe2000000 to 0xe1b7c000
NVRM: AGPGART: mode 2x
NVRM: AGPGART: allocated 16 pages

]$ cat /proc/interrupts
0: 152062 XT-PIC timer
1: 11139 XT-PIC keyboard
2: 0 XT-PIC cascade
5: 12792 XT-PIC aic7xxx
8: 1 XT-PIC rtc
10: 17252 XT-PIC usb-uhci, eth0
11: 147251 XT-PIC EMU10K1, nvidia, rivatv
14: 24 XT-PIC ide0
15: 36 XT-PIC ide1
NMI: 0
ERR: 0

Yes shared irq, but xawtv crashes also without the sblive, so i don't
think it's irq related.

This began to happen when i was using drivers 2960, and still occurs
with 3123.

So, am i the only one crashing 3times a day? If i wanted a system like that, i would have installed windows!


gOLeM 09-27-02 11:40 AM

are there ne nvidia guys out here!
i dont think so
sorry pal , your question will not be answered . i have been asking the same question for about 2 days , and i get no replies

dont you think that its problem with quake
quake is 'THE BEST' rendering engine.
ofcourse it will be beaten by the new doom III engine but dont you ever think that its the problem with quake
these nvidia drivers are really buggy .
i hate nvidia

i think you will be getting a mail that some xyz has answered your post. so u might be here .
i am very sorry about this .i cannot answer your post. if i ever want to buy a graphics card i would definitely go for ATI or MATROX , i hate NVIDIA bull **** , they dont care about the drivers , all very buggy ...

so the gist of it is that you are not getting ne help from these nvidia guys here.
they are nothing but ***holes .

i would suggest you go for winblow$ rather than linux

bwkaz 09-27-02 12:01 PM

If it's truly a driver problem, then reporting it to linux-bugs@nvidia.com might help. It helped me when I was using gcc 3.2 and the GLX library kept coming up with an unresolved reference to __divdi3. They said it was going to be fixed in the next release... and what do you know, it was.

But it might not necessarily be a driver problem, either. What's cat /proc/version tell you?

When you upgraded to gcc 3.2, did you replace all your system software with versions compiled with gcc 3.2? The ABI used by gcc 3.2 is different than the one used by 2.x (the ABI is more or less the way symbols and things get put into the binaries); what this amounts to is that you might have problems trying to link stuff that was compiled with gcc 3.2 against stuff that was compiled with earlier versions. Which is why the source install of the nVidia drivers complains when there's a compiler mismatch between the kernel and the compiler you're trying to use.

Is the "kernel 2.4.19" that you're using from kernel.org, or off your distro's CDs?

gOLeM 09-27-02 12:06 PM

i have mailed them thrice .
and i didnot receive a reply


Lethal Weapon 09-27-02 01:48 PM

]$ cat /proc/version
Linux version 2.4.19 (root@little.lethalwp) (gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #6 Thu Sep 26 22:15:12 CEST 2002

i've upgraded all packages at once, so they should all be ready to use with gcc 3.2 (before that i was using beta null, which was already on gcc 3.2)

2.4.19 of kernel.org

I had problems with the 2960 drivers, even when i rebuilded them, had to insmod -f them to be able to use them

this was fixed with version 3123
but not all of my problems were ;)

bwkaz 09-27-02 02:54 PM

Are you using insmod, modprobe, or modules.conf to load the NVdriver kernel module?

Lethal Weapon 09-27-02 03:32 PM

alias char-major-195 NVdriver

when i'm makeing tests, modprobe (that will read modules.conf) or some times insmod

when i first upgraded to 3.2 gcc compiled kernel, i was forced to use insmod -f; i don't need it anymore with 3123 version

but all 3D stuff is crashing, glxgears when i move the wheels, q3 (in the menus if i move mouse quickly a bit everywhere, it freezes in less than 2 minutes), about the same for unreal etc etc

i've just finished trying on gcc2.96 built kernel, it's still crashing

bwkaz 09-27-02 05:32 PM


Is this an Athlon (non-XP or -MP) chip? If so, booting with mem=nopentium might help. You'll have to either edit /etc/grub.conf (or wherever it is), or pass the option to Linux on the lilo boot line, depending on which of grub or lilo you use.

Otherwise... it probably isn't the XP/MP with AGP bug, because AFAIK that was fixed in 2.4.19...

Does trying the other AGP handler help (nvagp vs. agpgart)? The setting is in your X config file -- Option AGPMode.

Lethal Weapon 09-27-02 07:31 PM

p3 1Ghz

I was using agpgart by default, tried with nvidia's agp, same results

same freezes

btw, even if my mobo has an AGP 4x Enable option in bios, when i load the NVdriver it shows 4x is possible

once i startx it only goes for 2x
(NVreg_EnableVia4x=1 in modules.conf)

I suppose my mother board just doesn't support 4x very well

But it's not my main problem actually ;)

bwkaz 09-27-02 08:23 PM

mmm... if you back it down to 1 maybe?

I don't know, I'm grasping at straws here. :(

All times are GMT -5. The time now is 02:01 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.