nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Greetings, I come pleading for help (http://www.nvnews.net/vbulletin/showthread.php?t=22774)

fAAt 12-27-03 04:03 AM

Greetings, I come pleading for help
 
Hello all, I've been lurking these forums for about the last week or so - ever since I decided to take the linux plunge.

I've been a computer nerd since the days of DOS 4, and I have used Windows since 3.0.

I decided to check out linux for one simple reason - to achieve better framerates in the single FPS game that I play, Wolfenstein: Enemy Territory. I heard that linux was a much more efficient OS than Windows. That peaked my interest because I'm an avid system tweaker.

So, being a Windows user and a Linux noob, I think, "Ok, just install linux and install the drivers from nVidia and everything will be cool". I couldn't have been more incorrect. I got Red Hat 9 and Mandrake 9.2 and tried my luck installing ET/drivers etc. This has, so far, been an excercise in futility.

I thought I could find pretty much any answers I needed by browsing the forums, but that has not done the job. So I'm hoping that I can get this working by asking all of you helpful Linux users how the fark I can get these openGL/nVidia drivers working!

System Info:
Mandrake Linux Download Edition 9.2
P4 - 1.5
512MB RAM
GeForce3 64MB VRAM

WHAT HAS BEEN DONE SO FAR:

I have the newest nVidia drivers, NVIDIA-Linux-x86-1.0-5328-pkg1.run, downloaded. I try to simply double-click on this file, nothing. Ok, that's expected.

So I did some digging and ran the file in the command line like this:

"sh NVIDIA-Linux-x86-1.0-5328-pkg1.run"

while logged in as root, and the following error message appears:

"ERROR: Unable to find the system utility 'ld'; please make sure you have the package "binutils" installed. If you do not have binutils installed, then please check that 'ld' is in your PATH."

And that's pretty much where I'm stumped. Having no knowledge of linux, this error message might as well be written in Swahili.

Can anyone tell me what my next step should be to rectify this problem?

Many, many thanks to anyone that can help.

thebeen 12-27-03 04:26 AM

run this command as root


urpmi binutils

and u should be golden

:)


description:

urpmi updates your "RPM" (a package handler) and basically mdk is telling you that it cannot find the program/packaged named binutils.

So when u run the command:
urpmi binutils,

mandrake will look on its files and seee which installation cd has that package .. if no installtion cd (i believe) it will look on the internet.

so remember to have your installation cds handy, as i can guarantee it will be on the cds....
this is also known as a FAILED DEPENDENCY
meaning it failed to find one of the dependent packages

:)
hope it helps.... you will learn linux slowly as you go .. i might sound like I know alot, but heck, I am still a n00b..only 3-4 weeks into it...but yea...you learn A LOT your first 2 weeks!! :)

fAAt 12-27-03 04:33 AM

Thank you much sir.

I will now close down XP and boot up linux to try this out and then post my next roadblock (it seems inevitable lol)

fAAt 12-27-03 04:48 AM

Darn, can't edit posts. Won't make that mistake again! :)

So, what you said worked, but I have now progressed to my next roadblock. In the nVidia installer, now a new error message appears that reads:

"ERROR: You appear to be running an X server; please exit X before installing"

Then it tells me to check the readme. Well I did that, and consulted other threads regarding shutting down xfree86, but they are all far above my head.

Can someone help me with this, my next obstacle?

Many thanks :)

fAAt 12-27-03 07:02 AM

Ok, ignore my last post, I got the drivers installed.

Now I'm having problems editing my xf86config-4 file. It says I don't have permission to edit it.

I know I have to log in as root to edit read only files, and I know how to do that throught the console, but how do I log in as root in KDM so I can edit this file using KWrite?

Thanks in advance.

fAAt 12-27-03 09:58 AM

Yay! After much perserverance I got my nVidia openGL drivers installed. Now I'm wondering what I can do driver-wise to tweak the performance of my vid card...

Anyone got any suggestions?

Moled 12-27-03 10:47 AM

to overclock your card:

http://www.linuxhardware.org/nvclock/

if you want a windows style control pannel:

http://public.pny.com/quadro/FX3000g...-4620-pkg1.run

run it with the --extract-only option, the binary you want is in usr/bin/
copy nvidia-settings to /usr/bin

or look at the readme and do it manually

in your case:

__GL_FSAA_MODE GeForce3, Quadro DCC, GeForce4 Ti, GeForce4 4200 Go,
and Quadro4 700,750,780,900,980 XGL
-----------------------------------------------------------------------
0 FSAA disabled
1 2x Bilinear Multisampling
2 2x Quincunx Multisampling
3 FSAA disabled
4 4x Bilinear Multisampling
5 4x Gaussian Multisampling
6 2x Bilinear Multisampling by 4x Supersampling
7 FSAA disabled

for example
"export __GL_FSAA_MODE=6"

__GL_DEFAULT_LOG_ANISO GeForce3/GeForce4 Ti/GeForce FX Description
-----------------------------------------------------------------------
0 No anisotropic filtering
1 Low anisotropic filtering
2 Medium anisotropic filtering
3 Maximum anisotropic filtering

VBLANK SYNCING

Setting the environment variable __GL_SYNC_TO_VBLANK to a non-zero value
will force glXSwapBuffers to sync to your monitor's vertical refresh rate


as you can see its easiest to use the gui ;)

screenshots: http://www.nvnews.net/vbulletin/show...threadid=21848

make sure you also have agp enabled

"cat /proc/driver/nvidia/agp/status"

eg:
Status: Enabled
Driver: AGPGART
AGP Rate: 8x
Fast Writes: Enabled
SBA: Enabled

not really nvidia related but it may be an idea to switch to alsa for sound if your card can do hardware mixing, rather than rely on oss/arts. would mdk 9 use alsa by default?




one thing I find strange from what you have said is that mdk would have installed gcc but not binutils heh

Derek 12-27-03 11:33 AM

fAAt.. any chance you could let me know what you done to get your card working?...

<on edit> Nm fixed it now got it working...

fAAt 12-27-03 06:45 PM

Quote:

Originally posted by Moled
to overclock your card:

eg:
Status: Enabled
Driver: AGPGART
AGP Rate: 8x
Fast Writes: Enabled
SBA: Enabled

one thing I find strange from what you have said is that mdk would have installed gcc but not binutils heh

Thanks for the advice Moled, I'm gonna check out that util now. I have one question though, when I check my agp status, it shows:

Status: Enabled
Driver: AGPGART
AGP Rate: 4x (max for my rig)
Fast Writes: Disabled
SBA: Disabled

My questions, what is SBA, and how do I turn on Fast Writes and SBA? I assume its in some config file somewhere, but is it as simple as editing the "status" file to show enabled? I would assume not.

Oh, and fastwrites is enabled in my bios just to let you know.

As far as mdk not installing binutils, ya after doing some reading (I'm quite new to linux, as you might have guessed) I discovered that this was strange. Why wouldn't binutils get installed? I know I didn't conciously tell mdk NOT to install it. Strange.

And Derek, I'm glad you got that worked out. Game on!


All times are GMT -5. The time now is 01:22 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.