nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   libGL.la broken ??? (http://www.nvnews.net/vbulletin/showthread.php?t=22791)

axobeauvi 12-27-03 03:39 PM

libGL.la broken ???
 
Hi,

I just installed the new NVIDIA-Linux-x86-1.0-5328-pkg1.run on my SuSE 9.0 box
and all seemed well ,until I went to compile k3b
I get "libtool: link: `/usr/lib/libGL.la' is not a valid libtool archive"
when I installed the drivers I did the --opengl-headers option ,and the date on "/usr/lib/libGL.la" is from that
I didn't see anyone here with this ,but found someone on google groups with the same problem

any ideas ?

SuLinUX 12-27-03 03:43 PM

Yes I get this probelm when compiling as well, just get the rpm HERE the site is great for Suse 8/9 rpm's HERE is the main site for aload of goodies.

marekbull 12-27-03 07:02 PM

I have this same problem whilst tryin to compile another KDE app (kopete in this case), seems as tho there is either sumthin up with the libGL.la file or the suse 9.0 version of libtool.

Hamlet 12-28-03 05:40 PM

The same **** on slackware... :( I cannot compile sim

aritger 12-28-03 11:04 PM

This is a problem with the libGL.la generated by the nvidia-installer. Please edit /usr/lib/libGL.la, and replace the line:

# Generated by nvidia-installer: 1.0.5

with

# Generated by nvidia-installer: 1.0.5 (for use by libtool)

libtool greps for "^# Generated by .*libtool" before using .la files.

This will be fixed in the next driver release. I apologize for the inconvenience.

SuLinUX 12-28-03 11:41 PM

Yes that has sorted it, thanks very much.

Hamlet 12-29-03 05:39 AM

Suppper ... Thnk you !! :)))) next time I'll be smarter :)


All times are GMT -5. The time now is 07:46 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.